Risultati da 1 a 15 di 15

Discussione: Fare un totale con riferimento di una percentuale in un altro foglio



  1. #1
    L'avatar di paolo913
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Napoli
    Messaggi
    25
    Versione Office
    Office 2016
    Likes ricevuti
    0
    Likes dati
    4

    Fare un totale con riferimento di una percentuale in un altro foglio

    Ciao ragazzi, eccomi di ritorno con un altro problemino e piccolo quesito credo alquanto facile da risolvere!
    Ho da risolvere il seguente file in allegato e provo a dare delle informazioni.
    Ho dei 'prodotti', 'quantità venduta', un loro 'prezzo cadauno', un 'totale in base a quanti pezzi vendo' (la * di quantità e prezzo cadauno)
    Ognuno di questi prodotti in un altro foglio ha 'un'iva' (in questo caso o '22%' o '10%')

    Devo farmi un totale dei totali dei soli prodotti che hanno il 10 % IVA.
    Attendo con ansia la soluzione! Un ringraziamento in anticipo.

    ----------Post unito in automatico----------

    In riferimento, la questione è stata non del tutto risolta, con una funzione SOMMA.SE e una CERCA.VERT
    File Allegati File Allegati

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Fare un totale con riferimento di una percentuale in un altro foglio

    Ciao Paolo
    Il SOMMA.SE va benissimo il problema è fare capire quali prodotti avevano il 10% o il 22%
    Ti consiglio vivamente di mettere l'IVA a fianco di ogni prodotto, cosi è facile usare il SOMMA .SE perchè per come sono messi i dati, per fare capire chi ha il 22% ho scritto in una matrice di costanti {"io"."e"."sei"} (vedi rosso)

    X il 22%
    =PRODOTTO(MATR.SOMMA.PRODOTTO(SOMMA.SE(A2:C7;
    {"io"."e"."sei"};F2:F7));0,22)

    X il 10%
    =PRODOTTO(MATR.SOMMA.PRODOTTO(SOMMA.SE(A2:C7;{"che"."sono"."tu"};F2:F7));0,1)

    Fammi sapere

    A
    B
    C
    D
    E
    F
    G
    1
    Prodotto
    Quantità Prezzo Un Totale
    2
    che
    3
    € 2,00
    € 6,00
    3
    io
    7
    € 1,50
    € 10,50
    4
    sono
    5
    € 2,50
    € 12,50
    5
    e
    8
    € 3,00
    € 24,00
    6
    tu
    2
    € 6,00
    € 12,00
    7
    sei
    1
    € 16,00
    € 16,00
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    IVA 22% IVA 10 %
    18
    € 11,11
    € 5,05
    Sheet: Ciao





    A
    B
    C
    1
    prodotto prezzo iva
    2
    che
    € 2,00
    10,00%
    3
    io
    € 1,50
    22,00%
    4
    sono
    € 2,50
    10,00%
    5
    e
    € 3,00
    22,00%
    6
    tu
    € 6,00
    10,00%
    7
    sei
    € 16,00
    22,00%
    Sheet: Ciao2

  3. I seguenti 2 utenti hanno dato un "Like" a Gerardo Zuccalà per questo post:


  4. #3
    L'avatar di paolo913
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Napoli
    Messaggi
    25
    Versione Office
    Office 2016
    Likes ricevuti
    0
    Likes dati
    4

    Re: Fare un totale con riferimento di una percentuale in un altro foglio

    Ciao Gerardo e buonasera ti ringrazio infinitamente per essere stato tempestivo e di grande aiuto. Vedendo il tuo esempio, è stato semplice perchè gia sapevi quali erano i prodotti con il 10%, in questo caso io invece, devo supporre che si tratti di una grande azienda e si debbano SOMMARE (senza fare la percentuale momentaneamente) solo quei totali di quelli col 10 %, senza sapere quali sono e quindi matricolarli XDMagari prendendo di riferimento qualcosa dal secondo foglio! c'è una via alternativa o bisogna mettere di fianco l'IVA?

  5. #4
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: Fare un totale con riferimento di una percentuale in un altro foglio

    Ciao Paolo913 e buona sera a tutti i partecipanti al forum, se non ho capito male, propongo le seguenti:

    In G13:
    =SOMMA(MATR.SOMMA.PRODOTTO((Ciao!$A$2:$C$7=Ciao2!$A$2:$A$7)*(Ciao2!$C$2:$C$7=Ciao2!$C$2)*(Ciao!$D$2:$D$7)*(Ciao!$E$2:$E$7));(MATR.SOMMA.PRODOTTO((Ciao!$A$2:$C$7=Ciao2!$A$2:$A$7)*(Ciao2!$C$2:$C$7=Ciao2!$C$2)*(Ciao!$D$2:$D$7)*(Ciao!$E$2:$E$7)))*10/100)

    In E13:
    =SOMMA(MATR.SOMMA.PRODOTTO((Ciao!$A$2:$C$7=Ciao2!$A$2:$A$7)*(Ciao2!$C$2:$C$7=Ciao2!$C$3)*(Ciao!$D$2:$D$7)*(Ciao!$E$2:$E$7));(MATR.SOMMA.PRODOTTO((Ciao!$A$2:$C$7=Ciao2!$A$2:$A$7)*(Ciao2!$C$2:$C$7=Ciao2!$C$3)*(Ciao!$D$2:$D$7)*(Ciao!$E$2:$E$7)))*10/100)
    allego il file di prova, fa sapere se va bene, Ciao.
    File Allegati File Allegati

  6. I seguenti 3 utenti hanno dato un "Like" a pkrome59 per questo post:


  7. #5
    L'avatar di paolo913
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Napoli
    Messaggi
    25
    Versione Office
    Office 2016
    Likes ricevuti
    0
    Likes dati
    4

    Re: Fare un totale con riferimento di una percentuale in un altro foglio

    ciao pkrome e grazie anche a te per l'aiuto, non si trovano i totali. Con le tue formule viene in IVA 10% 33.55 e invece deve essere 30,50,mentre l'IVA 22% ti viene 55,55 e invece dovrebbe trovarsi 50,50 . C'è qualcosa che non va?

  8. #6
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    2302
    Versione Office
    Excel 2010
    Likes ricevuti
    913
    Likes dati
    451

    Re: Fare un totale con riferimento di una percentuale in un altro foglio

    Ciao pk, mi hai anticipato ci stavo smanettando su....
    se permetti hai messi per svista in entrambi *10/100

    ma se ci diamo una sfoltita del tipo:
    =SOMMA(MATR.SOMMA.PRODOTTO((Ciao!$A$2:$C$7=Ciao2!$A$2:$A$7)*(Ciao2!$C$2:$C$7=Ciao2!$C$2)*(Ciao!$D$2:$D$7)*(Ciao!$E$2:$E$7))*1,1)

    mi pare funzioni lo stesso ovviamente modificare *1,1 con *1,22 per l'altra aliquota.


    EDIT: ho visto ora la risposta di paolo913 se vuoi solo l'imponibile basta togliere alla formula la parte finale cioè *1,1
    =SOMMA(MATR.SOMMA.PRODOTTO((Ciao!$A$2:$C$7=Ciao2!$A$2:$A$7)*(Ciao2!$C$2:$C$7=Ciao2!$C$2)*(Ciao!$D$2:$D$7)*(Ciao!$E$2:$E$7))

  9. I seguenti 5 utenti hanno dato un "Like" a Berna11 per questo post:


  10. #7
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: Fare un totale con riferimento di una percentuale in un altro foglio

    Ciao Berna, complimenti per la formula, purtroppo mi è scomparso il mi piace, per darti il dovuto riscontro, lo faccio così.
    Di nuovo ciao e buon proseguimento di serata.

    P.S. diamo un'altra sforbiciata, togliendo il somma, che a questo punto diventa superfluo, per cui si ha:

    In G13
    =MATR.SOMMA.PRODOTTO((Ciao!$A$2:$C$7=Ciao2!$A$2:$A$7)*(Ciao2!$C$2:$C$7=Ciao2!$C$2)*(Ciao!$D$2:$D$7)*(Ciao!$E$2:$E$7))

    In E13:
    =MATR.SOMMA.PRODOTTO((Ciao!$A$2:$C$7=Ciao2!$A$2:$A$7)*(Ciao2!$C$2:$C$7=Ciao2!$C$3)*(Ciao!$D$2:$D$7)*(Ciao!$E$2:$E$7))

  11. I seguenti 2 utenti hanno dato un "Like" a pkrome59 per questo post:


  12. #8
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    2302
    Versione Office
    Excel 2010
    Likes ricevuti
    913
    Likes dati
    451

    Re: Fare un totale con riferimento di una percentuale in un altro foglio

    Ciao pk i complimenti sono per te ( e ti ho dato il Mi Piace) io l'ho solo modificata in parte. Anche se come detto ci stavo lavorando su.

  13. #9
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: Fare un totale con riferimento di una percentuale in un altro foglio

    Ciao Berna, non fare il modesto, più che una sforbiciata hai dato uno strappo netto alla formula da me concepita.
    A mio avviso, i più sinceri complimenti.
    Ciao, alla prossima.

  14. #10
    L'avatar di paolo913
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Napoli
    Messaggi
    25
    Versione Office
    Office 2016
    Likes ricevuti
    0
    Likes dati
    4

    Re: Fare un totale con riferimento di una percentuale in un altro foglio

    Ciao e buonaserata berna11. Che dire, FANTASTICO, mi è bastato poi cambiare $C$2 in un semplice $C$3 così prendendo poi di riferimentro l'altra percentuale e si trovava! Magistrale direì. Grazie infinite vi lascio una buonaserata a tutti.

  15. #11
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    782
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1

    Re: Fare un totale con riferimento di una percentuale in un altro foglio

    Buona Sera

    =SOMMA(SE(Ciao2!A2:C7=Ciao2!C2;Ciao!F2:F7)) control +shift +enter 10%

    =SOMMA(SE(Ciao2!A2:C7=Ciao2!C3;Ciao!F2:F7)) control +shift +enter 22%

    Saluti
    Window 8.1 Excel 2013/2016

  16. I seguenti 2 utenti hanno dato un "Like" a Pitagora per questo post:


  17. #12
    L'avatar di Raffaele_53
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Binasco
    Età
    64
    Messaggi
    506
    Versione Office
    2007
    Likes ricevuti
    85
    Likes dati
    7

    Re: Fare un totale con riferimento di una percentuale in un altro foglio

    Complimenti a tutti
    Non voglio fare il guastafeste, se l'ordine dei due fogli non fosse uguale(capovolti oppure michiati?
    In colonna G un cerca.vert non sarebbe l'ideale?

  18. #13
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Fare un totale con riferimento di una percentuale in un altro foglio

    Citazione Originariamente Scritto da Raffaele_53 Visualizza Messaggio
    Complimenti a tutti
    Non voglio fare il guastafeste, se l'ordine dei due fogli non fosse uguale(capovolti oppure michiati?
    In colonna G un cerca.vert non sarebbe l'ideale?
    Ciao Raffaele, a quale formula ti riferisci a quella con i MATR.SOMMA.PRODOTTO? hai visto la formula del post #2? funziona bene anche con i dati mischiati...

  19. #14
    L'avatar di Raffaele_53
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Binasco
    Età
    64
    Messaggi
    506
    Versione Office
    2007
    Likes ricevuti
    85
    Likes dati
    7

    Re: Fare un totale con riferimento di una percentuale in un altro foglio

    Scusami, non l'ho vista.
    Pensavo hai due range nei due fogli (in posizioni strambe).
    Certo che oggi rispondere con un'unica formula è bello (tranne il fatto che ogni tanto una colonna d'appoggio forse è la migliore)
    Siccome l'utente ha risposto OK. Chiedo venia, mà non ci credo troppo in quello che troverà in azienda domani.

  20. #15
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: Fare un totale con riferimento di una percentuale in un altro foglio

    Ciao Raffaele_53, hai perfettamente ragione riguardo alle formule proposte al post#7, nel caso di dati mischiati danno errore, per cui propongo le seguenti:

    In E13:
    =MATR.SOMMA.PRODOTTO((Ciao2!$C$2:$C$7=Ciao2!$C$3)*(Ciao!$D$2:$D$7)*(Ciao!$E$2:$E$7))

    In G13:
    =MATR.SOMMA.PRODOTTO((Ciao2!$C$2:$C$7=Ciao2!$C$2)*(Ciao!$D$2:$D$7)*(Ciao!$E$2:$E$7))
    Ciao a tutti alla prossima.

  21. I seguenti utenti hanno dato un "Like"


Discussioni Simili

  1. Risposte: 2
    Ultimo Messaggio: 28/02/17, 21:47
  2. Riferimento a celle di altro foglio a prescindere dal nome del foglio
    Di Matteo2017 nel forum Domande su Excel in generale
    Risposte: 20
    Ultimo Messaggio: 18/02/17, 21:01
  3. avviso riferimento circolare rallenta foglio?
    Di corfurio nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 18/02/17, 14:32
  4. Risposte: 4
    Ultimo Messaggio: 23/12/16, 20:33
  5. Riferimento formula a foglio non ancora esistente
    Di camoncino nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 03/07/16, 22:27

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •