Risultati da 1 a 16 di 16

Discussione: Cerca il valore mancante



  1. #1
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127

    Cerca il valore mancante

    Ciao ragazzi sono bloccato, sto sperimentando una formula ma non mi viene, pensavo fosse facile:226:

    Come potete vedere nella colonna A:A ho dei codici
    quando inserisco manualmente dei codici nella colonna B:B , vorrei scoprire automaticamente con delle formule quali sono i codici mancanti che verranno inseriti nella colonna C:C ( ovviamente questo è solo un piccolo esempio ma in realtà ho 100 di questi codici da sbrogliare)
    non so se si puo fare con il VBA o con le formule
    anche se io ovviamente preferisco le formule
    ciao e grazie

    A
    B
    C
    1
    Codice Inseriti Mancanti
    2
    a f d
    3
    b b e
    4
    c c a
    5
    d
    6
    e
    7
    f
    Ultima modifica fatta da:Canapone; 05/07/17 alle 17:24
    Invia MPPM 

  2. #2
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    Ciao Gerry!

    In D1:

    =MATR.SOMMA.PRODOTTO(1-VAL.NUMERO(CONFRONTA(B$2:B$7;A$2:A$7;0)))

    In C2:

    =SE(RIGHE($1:1)>$D$1;"";INDICE(A:A;AGGREGA(15;6;RIF.RIGA(A$2:A$7)/(1-VAL.NUMERO(CONFRONTA(B$2:B$7;A$2:A$7;0)));RIGHE($1:1))))

    Saluti!
    Advanced Excel Techniques: http://excelxor.com/
    Invia MPPM 

  3. I seguenti utenti hanno dato un "Like"


  4. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7174
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2066
    Likes dati
    1308
    In C2, trascinandola verso il basso

    =SE.ERRORE(INDICE($A$2:$A$6;AGGREGA(15;6;RIF.RIGA($A$2:$A$6)-1/((CONTA.SE($B$2:$B$6;$A$2:$A$6)=0)*($A$2:$A$6<>""));RIF.RIGA(A1)));"")
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!
    Invia MPPM 

  5. I seguenti utenti hanno dato un "Like"


  6. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    @XOR LX
    Hhmmm
    Jos, ho fatto dei test e sembra che non funziona
    infatti in B4 ho messo la (o) e non dovrebbe ripetersi in C4


    A
    B
    C
    1
    Codice Inseriti Mancanti
    2
    m h f
    3
    h g z
    4
    g o o
    5
    f
    6
    z
    7
    o
    Invia MPPM 

  7. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7174
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2066
    Likes dati
    1308
    Ciao Gerardo,
    forse perchè ho messo nella formula l'area A2:A6 ... avrei dovuto mettere A2:A7
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!
    Invia MPPM 

  8. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7174
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2066
    Likes dati
    1308
    Prova così:

    =SE.ERRORE(INDICE($A$2:$A$7;AGGREGA(15;6;RIF.RIGA($A$2:$A$7)-1/((CONTA.SE($B$2:$B$7;$A$2:$A$7)=0)*($A$2:$A$7<>""));RIF.RIGA(A2)));"")
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!
    Invia MPPM 

  9. #7
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    Citazione Originariamente Scritto da XOR LX Visualizza Messaggio
    Ciao Gerry!

    In D1:

    =MATR.SOMMA.PRODOTTO(1-VAL.NUMERO(CONFRONTA(A$2:A$7;B$2:B$7;0)))

    In C2:

    =SE(RIGHE($1:1)>$D$1;"";INDICE(A:A;AGGREGA(15;6;RIF.RIGA(A$2:A$7)/(1-VAL.NUMERO(CONFRONTA(A$2:A$7;B$2:B$7;0)));RIGHE($1:1))))

    Saluti!

    Oops!
    Advanced Excel Techniques: http://excelxor.com/
    Invia MPPM 

  10. I seguenti utenti hanno dato un "Like"


  11. #8
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    In C2, trascinandola verso il basso

    =SE.ERRORE(INDICE($A$2:$A$6;AGGREGA(15;6;RIF.RIGA($A$2:$A$6)-1/((CONTA.SE($B$2:$B$6;$A$2:$A$6)=0)*($A$2:$A$6<>""));RIF.RIGA(A1)));"")

    Woow Ges!
    funziona alla grande anche se io una piccola correzione l'ho fatta (vedi in rosso) perchè se per qualsiasi ragione viene aggiunta una riga in alto la formula sballa invece cosi no


    =SE.ERRORE(INDICE($A$2:$A$7;AGGREGA(15;6;RIF.RIGA($A$2:$A$7)-RIF.RIGA($A$2)+1/((CONTA.SE($B$2:$B$7;$A$2:$A$7)=0)*($A$2:$A$7<>""));RIF.RIGA(A1)));"")

    Anche se questo pezzetto di formula non lo capirò mai
    CONTA.SE($B$2:$B$7;$A$2:$A$7)
    Ultima modifica fatta da:Gerardo Zuccalà; 06/08/15 alle 16:46
    Invia MPPM 

  12. #9
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Prova così:

    =SE.ERRORE(INDICE($A$2:$A$7;AGGREGA(15;6;RIF.RIGA($A$2:$A$7)-1/((CONTA.SE($B$2:$B$7;$A$2:$A$7)=0)*($A$2:$A$7<>""));RIF.RIGA(A2)));"")
    Si ho notato già corretto
    Invia MPPM 

  13. #10
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    @ XOR LX la tua formula funziona alla grande

    @ GES anche la tua formula funziona benissimo

    adesso devo studiarmele perchè le voglio capire

    grazie :156:
    Invia MPPM 

  14. #11

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7174
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2066
    Likes dati
    1308
    @Gerardo:
    Hai fatto bene a correggere, come hai messo tu è più sicuro ... commetto sempre questa distrazione ... anche quando per esempio mi serve un numero crescente e mi viene sempre di mettere RIF.RIGA(A1) al posto del più sicuro RIGHE($A$1:A1)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!
    Invia MPPM 

  15. #12
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Citazione Originariamente Scritto da XOR LX Visualizza Messaggio
    Oops!
    Jos voglio rivelarti un segreto:262:


    Ho visto questo esercizio sul tuo Blog e pensavo che avessi usato questa formula, invece improvvisamente hai fatto una formula piu semplice

    http://excelxor.com/2014/09/18/advan...ssion/#respond

    Ciao
    Invia MPPM 

  16. #13
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    Jos voglio rivelarti un segreto:262:


    Ho visto questo esercizio sul tuo Blog e pensavo che avessi usato questa formula, invece improvvisamente hai fatto una formula piu semplice

    http://excelxor.com/2014/09/18/advan...ssion/#respond

    Ciao
    Ma non, Gerry! Questa qui si tratta di una questione più complicata, perché ci sono i duplicati nella gamma. Non è facile, allora!

    Saluti.
    Advanced Excel Techniques: http://excelxor.com/
    Invia MPPM 

  17. #14
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Ciao a tutti gli amici del forum
    mi è molto piaciuta questa discussione che ho deciso di farci un video
    grazie a Ges e XOR LX per le loro competenze


    Invia MPPM 

  18. #15
    L'avatar di marco71
    Clicca e Apri
    Data Registrazione
    Dec 2016
    Località
    Brescia
    Messaggi
    39
    Versione Office
    2013
    Likes ricevuti
    1

    Re: Cerca il valore mancante

    quesito
    se dovessi avere più selezioni da confrontare e purtroppo non sono in colonna
    come posso fare ?
    grazie
    Invia MPPM 

  19. #16

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4046
    Versione Office
    2013
    Likes ricevuti
    1239
    Likes dati
    931

    Re: Cerca il valore mancante

    Citazione Originariamente Scritto da marco71 Visualizza Messaggio
    quesito
    se dovessi avere più selezioni da confrontare e purtroppo non sono in colonna
    come posso fare ?
    grazie

    Ciao a tutti,

    @Marco71
    questa discussione è già risolta...
    per non creare confuzione, apri una nuova discussione, allega un file d'esempio e spiega bene quello che hai e quello che vorresti ottenere.... ed al massimo riporta il link di questa discussione (giusto per far capire da dove hai preso spunto).

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."
    Invia MPPM 

Discussioni Simili

  1. [Risolto] Cerca il prossimo valore
    Di S7yzrs nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 16/03/17, 01:56
  2. Trova il valore mancante nella lista
    Di Bruno nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 04/09/16, 00:47
  3. trovare un numero mancante
    Di Gialvin nel forum Domande su Excel in generale
    Risposte: 28
    Ultimo Messaggio: 09/07/16, 16:19
  4. Cerca ultimo valore alfanumerico
    Di Olly nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 28/12/15, 17:26
  5. Cerca valore min /max
    Di VICTOR BUJA nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 23/11/15, 09:40

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •