Risultati da 1 a 6 di 6

Discussione: Estrarre un numero random tra due valori (max - min) ma con una concentrazione maggiore specifica



  1. #1
    L'avatar di elfo_pak
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    milano
    Età
    37
    Messaggi
    5
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    0

    Estrarre un numero random tra due valori (max - min) ma con una concentrazione maggiore specifica

    Rieccomi!

    Mi ritrovo a dover estrarre una serie di numeri random tra due valori (ad esempio 20-65) e fin qui tutto semplice.

    Ma è possibile, all'interno di quel range, specificare che voglio (su migliaia di righe) la massima concentrazione in un sotto-range, per esempio 25-45 ?
    grazie :-)

  2. #2
    L'avatar di Marius44
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Catania
    Età
    73
    Messaggi
    3209
    Versione Office
    Excel2010
    Likes ricevuti
    625
    Likes dati
    155

    Re: Estrarre un numero random tra due valori (max - min) ma con una concentrazione maggiore specific

    Ciao elfo_pak
    Mi sta capitando sempre più spesso di non capire le richieste formulate.
    La funzione CASUALE.TRA(min;max) genera un numero compreso fra min e max. Premesso che non l'ho mai provata (ma perchè complicarsi la vita invece di mettere il solo range ridotto) ma si potrebbe "nidificare" la funzione in questo modo:
    Codice: 
    =CASUALE.TRA(CASUALE.TRA(20;25);CASUALE.TRA(45;65))
    Ma non mi pare che abbia molto senso.

    Ciao,
    Mario

  3. #3

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923

    Re: Estrarre un numero random tra due valori (max - min) ma con una concentrazione maggiore specific

    Ciao a tutti,

    per concentrare l'estrazione in un sotto-range, potresti usare questa:

    =SE(CASUALE.TRA(1;100)<=$C$1;CASUALE.TRA(25;45);SCEGLI(CASUALE.TRA(1;2);CASUALE.TRA(1;19);CASUALE.TRA(46;65)))

    nella cella C1 c'è la percentuale "di concentrazione" che vuoi in quel range.

    Nel file d'esempio allegato, nella tabella G2:M19 viene usata la formula di prima per l'estrazione casuale.
    Nella cella C1 metti la percentuale di concentrazione che vuoi.
    Nelle celle B3 e B4 potrai verificare le percentuali reali dell'estrazione.
    Premi il tasto F9 per aggiornare il foglio e quindi effettuare nuove estrazioni.
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  4. I seguenti 3 utenti hanno dato un "Like" a cromagno per questo post:


  5. #4
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1660
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184

    Re: Estrarre un numero random tra due valori (max - min) ma con una concentrazione maggiore specific

    complimenti, originale soluzione....
    forse come errore di distrazione hai lasciato fuori i numeri da 20 a 24:
    =SE(CASUALE.TRA(1;100)<=$C$1;CASUALE.TRA(20;45);SCEGLI(CASUALE.TRA(1;2);CASUALE.TRA(1;19);CASUALE.TRA(46;65)))
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  6. #5

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923

    Re: Estrarre un numero random tra due valori (max - min) ma con una concentrazione maggiore specific

    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    complimenti, originale soluzione....
    forse come errore di distrazione hai lasciato fuori i numeri da 20 a 24:
    =SE(CASUALE.TRA(1;100)<=$C$1;CASUALE.TRA(20;45);SCEGLI(CASUALE.TRA(1;2);CASUALE.TRA(1;19);CASUALE.TRA(46;65)))


    Si, hai ragione.

    Thanks

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  7. #6

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1017
    Versione Office
    .
    Likes ricevuti
    366
    Likes dati
    0

    Re: Estrarre un numero random tra due valori (max - min) ma con una concentrazione maggiore specific

    Ciao,

    visto che si parla di migliaia di righe io propongo un approccio diverso.

    Ammettiamo di voler dare ai numeri da 25 a 45 il doppio delle probabilità di uscita rispetto agli altri.

    In colonna A, da A1 a A46 mettiamo i numeri da 20 a 65.
    In colonna B, da B1 a B46 mettiamo i numeri da 20 a 65; poi da B47 a B67 mettiamo i numeri da 25 a 45.

    mettiamo in D2 la semplice formula =INDICE($A$1:$A$46;CASUALE.TRA(1;46)) che ci restituirà un numero tra 20 e 65 con una distribuzione equa (su grandi numeri) dei valori estratti.
    e trascinate fino a D1000

    mettiamo in E2 la semplice formula =INDICE($B$1:$B$67;CASUALE.TRA(1;67)) che ci restituirà un numero tra 20 e 65 ma con una distribuzione maggiore nella fascia 25-45.
    e trascinate fino a E1000

    per verifica in D1 mettete =MATR.SOMMA.PRODOTTO(((D2:D1000 > 0)*(D2:D1000 > 24)*(D2:D1000 < 46)))
    ed in E1 mettete =MATR.SOMMA.PRODOTTO(((E2:E1000 > 0)*(E2:E1000 > 24)*(E2:E1000 < 46)))

    E' evidente a tutti cosa succederà se in colonna B, da B68 a B88, mettiamo ancora i numeri da 25 a 45 e modifichiamo la formula in =INDICE($B$1:$B$88;CASUALE.TRA(1;88)).

    ----------Post unito in automatico----------

    P.S.: Ovviamente per il lavoro finale servirà solo la colonna B.

    ----------Post unito in automatico----------

    ... e la colonna E.
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  8. I seguenti 2 utenti hanno dato un "Like" a scossa per questo post:


Discussioni Simili

  1. Estrarre numero a destra da testo
    Di Samuela nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 21/01/17, 11:20
  2. [Risolto] Aumentare il valore di un numero verificando con maggiore / minore
    Di Samuela nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 31/10/16, 13:51
  3. [Risolto] dovrei estrarre un numero ma non ci riesco
    Di Eddie18 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 22/10/16, 11:00
  4. Come estrarre le centinaia da un numero
    Di angelimaleducati nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 09/07/16, 07:18
  5. Risposte: 11
    Ultimo Messaggio: 29/04/16, 18:10

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •