Risultati da 1 a 7 di 7

Discussione: Associa testo a celle identiche



  1. #1
    L'avatar di saturn87
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    toscana
    Messaggi
    14
    Versione Office
    2010
    Likes ricevuti
    1

    Associa testo a celle identiche

    Buongiorno cerco di spiegarmi:

    Ho 4 colonne,
    la colonna A è composta da 3 righe dove sono presenti 3 nomi (marco, mario e luca)
    la colonna B è composta da 3 righe ed ha dei numeri (3, 11 e 5)
    la colonna C è composta da 1300 righe dove sono presenti i nomi marco, mario e luca in ordine sparso
    la colonna D è composta da 1300 righe ed è vuota, vorrei riempirla con i numeri corrispondenti a ciascun nome (3 corrispondente al nome marco (nella colonna C), 11 corrispondente al nome mario (nella colonna C), 5 corrispondente al nome luca (nella colonna C))

    Sapete come posso farlo in automatico ?

    Grazie mille per l'aiuto. Saluti

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Associa testo a celle identiche

    Ciao Saturn
    benvenuto in Forumexcel
    Ti sei spiegato bene e quindi eccoti subito la risposta....

    Nella cella D1 metti questa formula e trascinala in basso fino alla riga 1300

    =SE(C1=$A$1;3;SE(C1=$A$2;11;$A$3))

    A
    B
    C
    D
    1
    Marco
    3
    Marco
    3
    2
    Mario
    11
    Mario
    11
    3
    Luca
    5
    Luca
    5
    4
    Marco
    3
    5
    Mario
    11
    6
    Luca
    5
    7
    Marco
    3
    8
    Mario
    11
    9
    Luca
    5
    10
    Marco
    3
    11
    Mario
    11
    12
    Luca
    5
    13
    Marco
    3
    14
    Mario
    11
    15
    Luca
    5
    16
    Marco
    3
    17
    Mario
    11
    18
    Luca
    5
    19
    Marco
    3
    20
    Mario
    11
    21
    Luca
    5
    22
    Marco
    3
    23
    Mario
    11
    24
    Luca
    5
    25
    Marco
    3
    26
    Mario
    11
    27
    Luca
    5


    in attesa di un riscontro un saluto

  3. #3
    L'avatar di saturn87
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    toscana
    Messaggi
    14
    Versione Office
    2010
    Likes ricevuti
    1

    Re: Associa testo a celle identiche

    Ti ringrazio,

    Ho modificato la formula che mi hai mandato così e funziona

    =SE(C4=$A$1;3;SE(C4=$A$2;11;SE(C4=$A$3;1)))

    per come ho posto la domanda la soluzione è giusta, però per spiegarmi bene avevo semplificato il problema.

    In realtà nella colonna A ci sono circa 550 nomi con associati i rispettivi 550 valori, la colonna C è composta da circa 19000 celle. E' problematico quindi utilizzare la formula che hai detto tu perchè dovrei inserire tutte le 550 condizioni manualmente.

    Grazie ancora

  4. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Associa testo a celle identiche

    Prova questa formula
    in D1 e trascinala in basso per 19000 righe

    =CERCA.VERT(C1;$A$1:$B$550;2;0)

    Fammi sapere

  5. #5
    L'avatar di saturn87
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    toscana
    Messaggi
    14
    Versione Office
    2010
    Likes ricevuti
    1

    Re: Associa testo a celle identiche

    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    Prova questa formula
    in D1 e trascinala in basso per 19000 righe

    =CERCA.VERT(C1;$A$1:$B$550;2;0)

    Fammi sapere
    Funziona alla perfezione !!!

    Grazie mille !

  6. #6
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    2279
    Versione Office
    Excel 2010
    Likes ricevuti
    906
    Likes dati
    450

    Re: Associa testo a celle identiche

    Un saluto a tutti,
    infatti stavo per suggerire il cerca vert. ma sono stato battuto sul tempo da Gerardo.
    Se non dovesse andar bene suggerisco di allegare un file con una decina di righe spiegando cosa si vuole ottenere in modo da evitare di andare per tentativi.

  7. #7
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Associa testo a celle identiche

    Grazie per il riscontro positivo e torna quando vuoi

Discussioni Simili

  1. [Risolto] Somma celle con stringa di testo
    Di nicocaporale nel forum Domande su Excel in generale
    Risposte: 22
    Ultimo Messaggio: 05/11/16, 13:53
  2. Adattare testo in celle unite
    Di Menin G. nel forum Domande su Excel in generale
    Risposte: 23
    Ultimo Messaggio: 01/10/16, 13:19
  3. tradurre contenuto celle di testo
    Di NicolaO nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 11/05/16, 00:08
  4. Trova Testo e copia celle
    Di robynud nel forum Domande su Excel VBA e MACRO
    Risposte: 7
    Ultimo Messaggio: 20/04/16, 01:59
  5. Associare ad un testo più celle variabili
    Di Lucas88 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 11/12/15, 21:43

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •