Risultati da 1 a 6 di 6

Discussione: Matr. Somma Prodotto - Stessa matrice per matrici diverse



  1. #1
    L'avatar di danyk125
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Roma
    Età
    26
    Messaggi
    3
    Versione Office
    2016 MAC
    Likes ricevuti
    0
    Likes dati
    0

    Matr. Somma Prodotto - Stessa matrice per matrici diverse

    Salve a tutti ragazzi del forum!
    Avrei un quesito forse un po ingenuo per i più esperti. Ho un foglio excel dove tramite la funzione MATR.SOMMA.PRODOTTO. moltiplico e sommo due matrici in modo da ottenere il risultato in una cella. Io vorrei che la prima matrice venga moltiplicata e sommata per altre matrici e che il risultato di ogni singola funzione venga memorizzato in una cella separata.
    Vi allego qualche foto sperando di schiarire le idee su cosa vorrei fare.



  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923

    Re: Matr. Somma Prodotto - Stessa matrice per matrici diverse

    Ciao e benvenuto,
    con le foto ci si può fare ben poco....

    allega un file excel che riporti la situazione iniziale e (scritto manualmente) il risultato che vuoi ottenere.

    Ciao
    Tore

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  3. #3
    L'avatar di danyk125
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Roma
    Età
    26
    Messaggi
    3
    Versione Office
    2016 MAC
    Likes ricevuti
    0
    Likes dati
    0

    Re: Matr. Somma Prodotto - Stessa matrice per matrici diverse

    La matricola A deve essere moltiplicata e sommata (MATR.SOMMA.PRODOTTO) per tutte le colonne e riportate il valore nella cella del totale. Questo è un esempio che ho fatto sperando che riesca a farvi capire ciò che cerco di fare. Nel file originale dovrei scrivere la formula manualmente troppe volte, bisognerebbe quindi trovare un modo più veloce. Allego il file excel.
    File Allegati File Allegati

  4. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7125
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1298

    Re: Matr. Somma Prodotto - Stessa matrice per matrici diverse

    Ciao Danyk,
    se ho ben capito devi bloccare i riferimenti della colonna A, in pratica metti in B7 da trascinare a destra:

    =MATR.SOMMA.PRODOTTO($A$2:$A$6;B2:B6)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  5. #5
    L'avatar di danyk125
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Roma
    Età
    26
    Messaggi
    3
    Versione Office
    2016 MAC
    Likes ricevuti
    0
    Likes dati
    0

    Re: Matr. Somma Prodotto - Stessa matrice per matrici diverse

    Salve Ges!
    Si assolutamente quello che stavo cercando di fare! In pratica il simbolo $ blocca un certo dato?

  6. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7125
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1298

    Re: Matr. Somma Prodotto - Stessa matrice per matrici diverse

    Si, Danyk,
    in pratica il simbolo del dollaro $ blocca quello che viene dopo.

    Esempio $A$2 blocca sia la colonna A che la riga 2, se invece metti il dollaro prima della lettera $A2 blocca solo la colonna A mentre se lo metti prima del numero A$2 blocca solo la riga 2.

    Nel tuo caso visto che si trascina a destra si poteva bloccare solo la colonna, così:

    =MATR.SOMMA.PRODOTTO($A2:$A6;B2:B6)

    In termini di excel si parla di "riferimenti assoluti" quando sono bloccati colonna e riga ($A$2), "riferimenti relativi" quando è tutto sboccato(A2)," riferimenti misti" quando è bloccato in parte ($A2 o A$2)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  7. I seguenti utenti hanno dato un "Like"


Discussioni Simili

  1. MATR.SOMMA.Prodotto... un pò di teoria
    Di Beppe nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 29/05/16, 22:02
  2. Matr.somma.prodotto
    Di Khan nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 29/03/16, 13:33
  3. =matr.somma.prodotto()
    Di marigenny nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 11/11/15, 12:59
  4. matr.somma.prodotto
    Di Alessandro nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 19/10/15, 17:52
  5. MATR.SOMMA.PRODOTTO per contare o sommare
    Di Baloon_50 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 22/08/15, 22:12

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •