Risultati da 1 a 12 di 12

Discussione: sommare valori uguali a se stessi con SOMMA.SE o altra formula



  1. #1
    L'avatar di Freemanna
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    roma
    Messaggi
    3
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    0

    sommare valori uguali a se stessi con SOMMA.SE o altra formula

    Ciao a tutti, avrei bisogno di aiuto:
    ho una lista di 3.000 nomi, molti dei quali doppi, con tutte le relative informazioni e devo impostare una formula che mi pulisca la lista dai nominativi doppi, lasciando una sola riga con la somma di uno dei valori presenti per ogni doppione e con la copia delle restanti info (che sono invece uguali per tutti i doppioni).
    Pensavo di utilizzare una formula tipo SOMMA.SE, che andasse a scorrere la lista e che agisse con condizione UGUALE A SE STESSO sul nominativo presente, ma ho passato una intera giornata a cercare senza successo: sembra che questo criterio non esista.

    Esempio (non allego il file perché sono dati sensibili e soggetti a tutela della privacy):

    Colonna A........Colonna B......Colonna C
    Pippo.................223.............Italia
    Pippo.................414.............Italia
    Carlo.................21...............Malta
    Gino..................398.............Germania
    Chiara...............212.............Finlandia
    Chiara...............29...............Finlandia
    Roberto.............76...............Danimarca

    La formula mi dovrà restituire:

    Colonna A.....Colonna B............Colonna C
    Pippo..............637.....................Italia
    Carlo..............21.......................Malta
    Gino...............398..................Germania
    Chiara............241...................Finlandia
    Roberto...........76...................Danimarca

    In pratica: quando la colonna A è uguale a se stessa, somma tra loro i valori delle relative colonne B e restituisce una sola riga.

    Potete aiutarmi con questa o un'altra formula? Non so usare matrici.

    Grazie mille

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: sommare valori uguali a se stessi con SOMMA.SE o altra formula

    Ciao Fremana benvenuto/benvenuta in forumexcel
    Potrebe accadere che la stessa persona incassa in piu nazioni?
    esempio pippo è solo italia o anche altre nazioni?


    Femana Essendo questa la tua prima volta ti consiglio di leggerti il “Regolamento” e a visitare la sezione “Annunci dello staff”, in ultimo ti consiglio di mettere una immagine avatar che meglio ti identifica, In attesa della tua prima domanda
    Cordiali saluti e buona continuazione nel forum!.

  3. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7159
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1300

    Re: sommare valori uguali a se stessi con SOMMA.SE o altra formula

    Ciao, prova con questa:

    =SOMMA.SE(A:A;"Pippo";B:B)

    Se vuoi anche separarli per nazione, questa:

    =SOMMA.PIÙ.SE(B:B;A:A;"Pippo";C:C;"Italia")


    EDIT: Ciao Gerardo, non ti avevo visto.

    ----------Post unito in automatico----------

    Per evitare di scrivere ciascun nome nella formula ti suggerisco questa soluzione, con questa formula:

    =SE(CONTA.SE($C$2:C2;C2)=1;MATR.SOMMA.PRODOTTO((A:A=A2)*(C:C=C2)*(B:B));"")

    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  4. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: sommare valori uguali a se stessi con SOMMA.SE o altra formula

    Ciao a tutti
    Se ho capito bene vorresti una lista univoca dei nomi (colonna A) e poi le somme

    Nella cella E2 metti questa formula che ti servira per spegnere altre formule in caso di errore
    da confermare con i tasti di scelta rapida CtRL+SHIFT+ENTER

    =SOMMA(SE(FREQUENZA(CONFRONTA($A$2:$A$8;$A$2:$A$8;0);RIF.RIGA($A$2:$A$8)-RIF.RIGA($A$2)+1)>0;1))

    in F2 metti questa formula e trascinala in basso
    da confermare con i tasti di scelta rapida CtRL+SHIFT+ENTER

    =SE(RIGHE($F$2:F2)>$E$2;"";INDICE($A$2:$A$8;PICCOLO(SE(FREQUENZA(CONFRONTA($A$2:$A$8;$A$2:$A$8;0);RIF.RIGA($A$2:$A$8)-RIF.RIGA($A$2)+1);RIF.RIGA($A$2:$A$8)-RIF.RIGA($A$2)+1);RIGHE($F$2:F2))))

    in G2
    =SE(RIGHE($F$2:F2)>$E$2;"";SOMMA.SE($A$2:$A$8;F2;$B$2:$B$8))

    in H2
    =SE(RIGHE($F$2:F2)>$E$2;"";CERCA.VERT(F2;$A$2:$C$8;3;0))

    Attenzione i numeri evidenziati in rosso corrispondono all'altezza dell'intervallo di riferimento, e quindo dovrai scrivere anzichè (8) il numero di riga esatto esempio 3251

    In attesa di un riscontro
    un saluto

    A
    B
    C
    D
    E
    F
    G
    H
    1
    Nome Tot Stato tot unici Nome Tot Stato
    2
    Pippo
    223
    Italia
    5
    Pippo
    637
    Italia
    3
    Pippo
    414
    Italia Carlo
    21
    Malta
    4
    Carlo
    21
    Malta Gino
    398
    Germania
    5
    Gino
    398
    Germania Chiara
    241
    Finlandia
    6
    Chiara
    212
    Finlandia Roberto
    76
    Danimarc
    7
    Chiara
    29
    Finlandia
    8
    Roberto
    76
    Danimarc

  5. I seguenti utenti hanno dato un "Like"


  6. #5
    L'avatar di GiuseppeMN
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Mantova
    Messaggi
    864
    Versione Office
    2000 - 2013
    Likes ricevuti
    285
    Likes dati
    160

    Re: sommare valori uguali a se stessi con SOMMA.SE o altra formula

    Buona giornata, Freemanna;
    prendendo spunto dalla giusta richiesta di Gerardo (che saluto):
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    Ciao Fremana benvenuto/benvenuta in forumexcel
    Potrebe accadere che la stessa persona incassa in piu nazioni?
    esempio pippo è solo italia o anche altre nazioni?
    Ho pensato da una soluzione di questo tipo:



    In Cella "G2"
    Codice: 
    =SOMMA.PIÙ.SE($B:$B;$A:$A;$E2;$C:$C;$F2)
    da copiare nelle Celle sottostanti.

    Un Saluto a Ges.



    A disposizione.

    Buon Lavoro e buona serata.

    Giuseppe
    Windows XP Excel 2000 - Windows 10 Excel 2013

  7. #6
    L'avatar di Freemanna
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    roma
    Messaggi
    3
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    0

    Re: sommare valori uguali a se stessi con SOMMA.SE o altra formula

    Grazie a tutti per le risposte!!
    Ora proverò le vostre soluzioni, ma lasciatemi chiarire alcune cose: il "paese" l'ho aggiunto io giusto per farvi capire, al posto di questo sono presenti dati sensibili univoci come codice fiscale et similia. Sono circa 12 colonne con dati uguali (per ogni nome uguale), tranne appunto la colonna con il valore in € che indica che il cliente ha stipulato un contratto con un determinato ammontare economico. Ed ovviamente a me interessa il totale in € di ogni contratto stipulato dalla stessa persona.
    Giuisto per chiarire.

  8. #7

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7159
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1300

    Re: sommare valori uguali a se stessi con SOMMA.SE o altra formula

    Allora, se non ti serve la distinzione per Paese, basta questa:

    =SE(CONTA.SE($C$2:C2;C2)=1;MATR.SOMMA.PRODOTTO((A:A=A2)*(B:B));"")

    o semplicemente questa:

    =SOMMA.SE(A:A;"Pippo";B:B)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  9. #8
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: sommare valori uguali a se stessi con SOMMA.SE o altra formula

    Oltre alla soluzioni di Ges e Giuseppe ai quale va il mio saluto (), ho visto che tu (fremanna)hai scritto:

    Potete aiutarmi con questa o un'altra formula? Non so usare matrici.
    a questo punto ho fatto delle modifiche

    in E2 metti questa
    =MATR.SOMMA.PRODOTTO(--(FREQUENZA(CONFRONTA($A$2:$A$8;$A$2:$A$8;0);RIF.RIGA($A$2:$A$8)-RIF.RIGA($A$2)+1)>0))

    e in F2 metti questa

    =SE(RIGHE($F$2:F2)>$E$2;"";INDICE($A$2:$A$8;AGGREGA(15;6;(RIF.RIGA($A$2:$A$8)-RIF.RIGA($A$2)+1)/(FREQUENZA(CONFRONTA($A$2:$A$8;$A$2:$A$8;0);CONFRONTA($A$2:$A$8;$A$2:$A$8;0))>0);RIGHE($F$2:F2))))

    Vedi allegato er capire meglio



    File Allegati File Allegati

  10. #9
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: sommare valori uguali a se stessi con SOMMA.SE o altra formula

    Ciao Freemanna
    Stavo rivedendo dei miei vecchi post e noto con dispiacere che non hai ancora dato un riscontro alla varie soluzioni ottenute
    Se anche tu vuoi far parte della Black List benvenuto!!


    Regola nr.1.1 "Rispondere alla soluzione ottenuta"
    E' buona educazione rispondere a coloro che ti hanno dato un aiuto e magari sono riusciti a risolverti il problema, vorrei ricordarti che coloro che ti hanno aiutato hanno messo a disposizione il loro tempo gratuitamente, e sono spinti solo dalla loro generosità verso il prossimo e dalla passione per Excel, e quindi un vostro grazie è il vero motore della motivazione e verrà tenuto in considerazione per un futuro aiuto, in caso contrario non verrai più aiutato

  11. #10

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7159
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1300

    Re: sommare valori uguali a se stessi con SOMMA.SE o altra formula

    Son già passati 3 giorni dalla tua richiesta ....
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  12. #11
    L'avatar di Freemanna
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    roma
    Messaggi
    3
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    0

    Re: sommare valori uguali a se stessi con SOMMA.SE o altra formula

    Ciao a tutti.
    Non sono riuscito ad utilizzare alcuna formula in quanto la mia tabella è molto più complicata e dovrei sostituire ogni singolo elemento di ogni parte delle vostre formule e sinceramente non ci riesco.

  13. #12
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: sommare valori uguali a se stessi con SOMMA.SE o altra formula

    Citazione Originariamente Scritto da Freemanna Visualizza Messaggio
    Ciao a tutti.
    Non sono riuscito ad utilizzare alcuna formula in quanto la mia tabella è molto più complicata e dovrei sostituire ogni singolo elemento di ogni parte delle vostre formule e sinceramente non ci riesco.
    Ciao Fremanna
    Se non hai dimestichezza con le formule è difficile adattare le formule al tuo foglio,
    potresti inserire un allegati con nomi di fantasia e vedere come risolvere ( se l'allegato ha dimensioni superiore hai 400 kb potresti usare una piattaforma di file sharing come DropBox, google drive, One drive, Box, mega ecc ecc)
    in attesa di un tuo riscontro
    Un saluto

Discussioni Simili

  1. [Risolto] Sommare celle adiacenti per gruppo numerosissimo di parole uguali
    Di smiley nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 06/02/17, 19:27
  2. Evidenziare valori uguali
    Di Escapeme89 nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 31/12/16, 11:49
  3. [Risolto] Somma dei valori di altra tabella = zero
    Di Alessandro nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 08/11/16, 18:31
  4. [Risolto] Formula per sommare valori univoci ad una condizione
    Di rmalenc nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 27/10/16, 15:23
  5. matrice somma prodotto che esclude le celle uguali
    Di ALESSANDRADS nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 14/03/16, 19:41

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •