Risultati da 1 a 18 di 18

Discussione: Calcolo valore da tabella



  1. #1
    L'avatar di jacopoabe
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    roma
    Età
    43
    Messaggi
    1
    Versione Office
    13
    Likes ricevuti
    0
    Likes dati
    0

    Calcolo valore da tabella

    Ovviamente sono nuovo e ho apprezzato moltoi video su youtube... sto cercando di imparare velocemente le funzioni base...
    Vi riporto una necessità
    vorrei applicare una provvigione diversa in base a due eventi
    - il primo è il numero di pezzi venduto
    - il secondo è il pricing level applicato dall'agente
    quale formula mi consigliate di usare per estrapolare la giusta percentuale dalla tabella che allego?
    Concatenare se e cerca vert? oppure Indice? o addirittura scegli?
    Grazie mille
    File Allegati File Allegati

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125

    Re: Calcolo valore da tabella

    Ciao jacopoabe benvenuto in forumexcel.it
    La tua domanda non mi è molto chiara
    Per evitare equivoci prova a fare un esempio pratico, scrivendo a mano il risultato che vorresti ottenere e specificando il perchè di quel risultato
    specifica in quale celle vuoi la formula...

  3. #3
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183

    Re: Calcolo valore da tabella

    ciao
    secondo me, le intestazioni in E4,F4 e G4 sono forvianti.
    ammettendo che siano:
    da 0 a 43
    da 44 a 104
    da 105 in su
    una formula potrebbe essere:
    =CERCA.VERT(L10;Tabella135;4-(L9<105)-(L9<44);FALSO)
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  4. I seguenti utenti hanno dato un "Like"

    ges

  5. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7108
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: Calcolo valore da tabella

    Credo che ninai (un saluto) abbia ragione, c'è sicuramente un errore in F4.

    Come alternativa alla sua formula propongo la seguente:

    =INDICE(SE(L9<=43;E5:E31;SE(E(L9>=44;L9<=104);F5:F31;G5:G31));CONFRONTA(L10;D5:D31;0))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. #5
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125

    Re: Calcolo valore da tabella

    aaaa ok adesso ci siamo!

    Avendo visto le formule di ninai e ges (), ho capito la domanda jacoboabe

    infatti la mia soluzione è leggermente diversa da quella di ges con la funzione SCEGLI alla quale sono più affezionato



    =INDICE(SCEGLI(SE(L9<43;1;SE(L9<104;2;3));E5:E31;F5:F31;G5:G31);CONFRONTA(L10;D5:D31;0))

    Un saluto

  7. #6
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183

    Re: Calcolo valore da tabella

    sì...., ma........, troppo lunghe!!!!!
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  8. #7
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125

    Re: Calcolo valore da tabella

    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    sì...., ma........, troppo lunghe!!!!!
    Effettivamente...

    Comunque complimenti ninai non avevo mai visto creare l'argomento "Indice" del cerca verticale con delle condizioni, più passa il tempo e piu scopro la versatilità che ha excel e la bravura dei guru a sfruttarne le potenzialità

  9. #8
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183

    Re: Calcolo valore da tabella

    prima che venga chi so io a farmelo notare, anche la mia si può accorciare, sostituendo il FALSO con 1.
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  10. #9

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7108
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: Calcolo valore da tabella

    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    sì...., ma........, troppo lunghe!!!!!
    Ma come???
    Anche tu allora sei stato sprecone hai scritto
    =CERCA.VERT(L10;Tabella135;4-(L9<105)-(L9<44);FALSO)

    potevi anche scrivere

    =CERCA.VERT(L10;D5:G31;4-(L9<105)-(L9<44);1)

    con un risparmio di ben 8 caratteri!!!!


    EDIT: Mi hai letto nel pensiero!!!
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  11. #10
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183

    Re: Calcolo valore da tabella

    ho rinominato la tabella: b ed eliminato l'ultimo argomento
    =CERCA.VERT(L10;b;4-(L9<105)-(L9<44))

    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  12. #11
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125

    Re: Calcolo valore da tabella

    Bé allora se proprio insistete potete togliere anche ;1
    Perche il CERCAVERT è stato costruito per la ricerca è approssimativa, e quindi si puo omettere l'ultimo argomento

    =CERCA.VERT(L10;D5:G31;4-(L9<105)-(L9<44))

    ----------Post unito in automatico----------

    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    ho rinominato la tabella: b
    =CERCA.VERT(L10;b;4-(L9<105)-(L9<44);1)

    e ma cosi non vale, hai barato

  13. #12

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7108
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: Calcolo valore da tabella

    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    ho rinominato la tabella: b
    =CERCA.VERT(L10;b;4-(L9<105)-(L9<44);1)

    Una furbata!!!
    ... ma anche questo è ammesso!
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  14. #13
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183

    Re: Calcolo valore da tabella

    in queste cose, scossa, mi ha abituato a tutte le "scorrettezze" possibili. Voi non sapete quanto è diabolico quell'uomo

    vediamo se riesco a stanarlo
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  15. #14

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7108
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: Calcolo valore da tabella

    Se arriva scossa mi aspetto una formula molto esigua magari con la sua solita funzione "soglia"
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  16. #15
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183

    Re: Calcolo valore da tabella

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Se arriva scossa mi aspetto una formula molto esigua magari con la sua solita funzione "soglia"
    Da lui ci si può aspettare di tutto, ma con pochi scaglioni, soglia non credo gli faccia risparmiare caratteri, da quello che ricordo dovrebbe venire qualcosa del genere:
    =CERCA.VERT(L10;b;2+SOMMA(SOGLIA(L9;{44.105})))
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  17. #16
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    2068
    Versione Office
    2016
    Likes ricevuti
    551
    Likes dati
    116

    Re: Calcolo valore da tabella

    Ciao
    portate pazienza
    ma me le mettete sul foglio e le allegate?

    cavolo non riesco a farle funzionare
    e che il mio amatissimo cerca verticale mi tradisca non lo sopporto

    però sembra che tra L9 e L 10 ci sia un pelino di confusione




    annullate tutto
    sbagliavo io nella cella L10
    Ultima modifica fatta da:Gianfranco55; 22/07/16 alle 21:48 Motivo: Pirla IO

  18. #17
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183

    Re: Calcolo valore da tabella

    eccoti un riassunto
    File Allegati File Allegati
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  19. #18
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    2068
    Versione Office
    2016
    Likes ricevuti
    551
    Likes dati
    116

    Re: Calcolo valore da tabella

    Grazie Ninai

    mi sono ripreso dal colpo di "pirlaggine"

    stavo valutando la cella L10 in modo diciamo
    improrio

Discussioni Simili

  1. [Risolto] Formula calcolo valore
    Di ste77 nel forum Domande su Excel in generale
    Risposte: 15
    Ultimo Messaggio: 06/03/17, 18:16
  2. [Risolto] da una tabella estrapolare un valore da due dati di partenza
    Di Eddie18 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 19/01/17, 09:57
  3. [Risolto] Cercasi regola per trovare un valore in una tabella
    Di -ADG- nel forum Domande su Excel in generale
    Risposte: 19
    Ultimo Messaggio: 17/09/16, 09:44
  4. ricerca valore tabella e risultato colonna
    Di PENNY nel forum Domande su Excel in generale
    Risposte: 34
    Ultimo Messaggio: 29/11/15, 09:57
  5. Pescare un valore all'interno di una tabella tramite coordinate
    Di quartafeira nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 23/09/15, 14:49

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •