Risultati da 1 a 7 di 7

Discussione: Associazione di condizioni contrattuali a date



  1. #1
    L'avatar di Antonio_Avitabile
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Torre Annunziata
    Messaggi
    11
    Versione Office
    Office 2010
    Likes ricevuti
    0
    Likes dati
    0

    Associazione di condizioni contrattuali a date

    Estate, tempo di smanettamenti e prove varie.
    Sto elaborando un foglio elettronico in cui si verifica un condizione contrattuale ad una certa data, conoscendo l'evoluzione temporale delle stesse.
    Nel file allegato ho utilizzato una formula un po' complessa in [G5] (se>...) che mi appesantisce notevolmente il file, anche perché nell'esempio che allego c'è solo una delle n condizioni contrattuali che devo sviluppare quindi dovrei aggiungere un parametro di selezione della condizione contrattuale ripetendo tutta la sequenza di calcolo.
    Considerato che la tabella delle condizioni è strettamente a date crescenti è possibile utilizzare una formula che associ in maniera più semplice il dato ricercato alla tabella?

    Grazie in anticipo
    Antonio Avitabile

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7108
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296
    Ciao Antonio,
    non so se ho capito bene quello che vuoi, prova a mettere in G5 questa formula, da confermare con Ctrl+Shift+Invio trascinandola verso il basso:

    =SE(F5:F19<B6:B12;C5;C6)
    Ultima modifica fatta da:ges; 13/08/15 alle 00:20
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di Antonio_Avitabile
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Torre Annunziata
    Messaggi
    11
    Versione Office
    Office 2010
    Likes ricevuti
    0
    Likes dati
    0
    Ciao Ges.
    La formula mi da errore.
    In realtà in G5 inserisco la data cui occorre associare il canone vigente, cioè quello che corrisponde alla data precedente quella richiesta nella colonna B con il valore in colonna C.
    Si tratta in pratica di associare il costo di canoni e servizi ad ogni ordine periodico fatto da un cliente (colonna F)

    Da cui la mia formula che si basa sul SE F5 < *;... per un numero smisurato di volte.

    =SE($F5=0;"";SE($F5<$B$6;$C$5;SE($F5<$B$7;$C$6;SE($F5<$B$8;$C$7;SE($F5<$B$9;$C$8;SE($F5<$B$10;$C$9;SE($F5<$B$11;$C$10;SE($F5<$B$12;$C$11;SE($F5<$B$13;$C$12;SE($F5<$B$14;$C$13;SE($F5<$B$15;$C$14;SE($F5<$B$16;$C$15;SE($F5<$B$17;$C$16;SE($F5<$B$18;$C$17;SE($F5<$B$19;$C$18;SE($F5<$B$20;$C$19;SE($F5<$B$21;$C$20;SE($F5<$B$22;$C$21;SE($F5<$B$23;$C$22;SE($F5<$B$24;$C$23;SE($F5<$B$25;$C$24;SE($F5<$B$26;$C$25;SE($F5<$B$27;$C$26;SE($F5<$B$28;$C$27;SE($F5<$B$29;$C$28;SE($F5<$B$30;$C$29;SE($F5<$B$31;$C$30;SE($F5<$B$32;$C$31;SE($F5<$B$33;$C$32;SE($F5<$B$34;$C$33;SE($F5<$B$35;$C$34;SE($F5<$B$36;$C$35;SE($F5<$B$37;$C$36;SE($F5<$B$38;$C$37;SE($F5<$B$39;$C$38;SE($F5<$B$40;$C$39;SE($F5<$B$41;$C$40;SE($F5<$B$42;$C$41;SE($F5<$B$43;$C$42;SE($F5<$B$44;$C$43;SE($F5<$B$45;$C$44;SE($F5<$B$46;$C$45;SE($F5<$B$47;$C$46;SE($F5<$B$48;$C$47;SE($F5<$B$49;$C$48;SE($F5<$B$50;$C$49;SE($F5<$B$51;$C$50;SE($F5<$B$52;$C$51;SE($F5<$B$53;$C$52;SE($F5<$B$54;$C$53;SE($F5<$B$55;$C$54;SE($F5<$B$56;$C$55;SE($F5<$B$57;$C$56;SE($F5<$B$58;$C$57;SE($F5<$B$59;$C$58;SE($F5<$B$60;$C$59;SE($F5<$B$61;$C$60;SE($F5<$B$62;$C$61;SE($F5<$B$63;$C$62;SE($F5<$B$64;$C$63;SE($F5<$B$65;$C$64;SE($F5<$B$66;$C$65;SE($F5<$B$67;$C$66;SE($F5<$B$68;$C$67;0))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))

    Un po' pesantuccia _:247:_, considerato che devo ripeterla per un buon numero di colonne (Canone2 .... Canone N) e che le stesse righe (60) saranno probabilmente insufficienti a coprire tutte le variazioni contrattuali (associando ad ogni riga una singola variazione, lasciando ferme le altre).


    Aggiungo nuova versione del file un po' più chiara negli intenti
    Ultima modifica fatta da:Antonio_Avitabile; 13/08/15 alle 08:33

  4. #4
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    ciao
    se ho ben capito, in G5:
    =SE($F5;CERCA.VERT($F5;$B$5:$D$68;2);"")

    stessa formula la copi in J5, sostituendo il 2 in 3.

    Ovviamente , poi, le trascini in basso

  5. #5
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    non riesco a capire bene che risultato vuoi ottenere, però a naso credo che serva un CERCA.VERT, praticamente vuoi un canone diverso compreso tra 2 date?

  6. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7108
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296
    Non è chiarissimo, almeno per me, vediamo la soluzione di ninai va bene, che in alternativa si può usare anche questa:

    in G5 trascinando basso il basso:

    =SE.ERRORE(INDICE($C$5:$C$68;CONFRONTA(F5;$B$5:$B$68;1));"")

    e in J5 sempre trascinando verso il basso:

    =SE.ERRORE(INDICE($D$5:$D$68;CONFRONTA(F5;$B$5:$B$68;1));"")
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  7. #7
    L'avatar di Antonio_Avitabile
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Torre Annunziata
    Messaggi
    11
    Versione Office
    Office 2010
    Likes ricevuti
    0
    Likes dati
    0
    Le soluzioni vanno entrambe bene; avevo pensato al cerca.vert, ma credevo che la ricerca fosse puntuale, cioè che dovesse esistere nella tabella delle condizioni la stessa data interrogata. E' stata una piacevole sorpresa vedere che la formula sceglie il dato corrispondente alla data antecedente utile.

    Ugualmente per l'abbinata Indice/confronta che ho utilizzato tempo fa sempre però per ricerche puntuali e non per intervalli.

    Grazie mille a tutti.

Discussioni Simili

  1. associazione automatica fra nomi di diversi fogli
    Di LucaB85 nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 04/03/17, 18:54
  2. [Risolto] calcolo giorni tra date che soddisfano alcune condizioni
    Di dr.colussus nel forum Domande su Excel in generale
    Risposte: 20
    Ultimo Messaggio: 15/11/16, 17:12
  3. SE con più condizioni
    Di warriorspa nel forum Domande su Excel in generale
    Risposte: 66
    Ultimo Messaggio: 13/02/16, 00:43
  4. Date
    Di cesare nel forum Domande su Excel VBA e MACRO
    Risposte: 10
    Ultimo Messaggio: 23/09/15, 18:28
  5. Sommare ore a delle condizioni escludendo degli orari e delle date
    Di RiccardoDengo nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 17/08/15, 18:39

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •