Risultati da 1 a 13 di 13

Discussione: Cercare valore per colonne



  1. #1
    L'avatar di robbiecs
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Roma
    Età
    37
    Messaggi
    6
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    0

    Cercare valore per colonne

    Ciao a tutti, ho provato a fare qualche ricerca nel forum per rispondere al mio quesito ma senza risultati.
    Ho bisogno di cercare un valore in determinate colonne, e per quel valore ricercato deve restituirmi tutti i nomi delle colonne in cui è presente. Faccio un esempio

    Gennaio Febbraio Marzo Aprile Maggio Giugno Luglio Agosto Settembre Ottobre Novembre Dicembre
    Categoria 03 01 05 03 07 05 03 02 02 01 03 03
    Categoria 2 99 98 99 97 96 99 97 95 99 96 96 99

    Numero da ricercare 03
    E' presente nei mesi:

    In pratica vorrei nella seconda tabella che inserendo il numero in questo caso "03" mi venissero restituiti i mesi in cui è presente

    Spero di essere stato chiaro e di ricevere aiuto.

    Grazie

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183

    Re: Cercare valore per colonne

    se alleghi il file di esempio si può essere più precisi nei riferimenti, oltre a capire in quante righe deve essere cercato il numero
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7108
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: Cercare valore per colonne

    Ciao a tutti,
    dall'esempio che ha postato in alto forse ho capito.

    Suggerisco la seguente formula da trascinare a destra:

    =SE.ERRORE(INDICE($B$1:$M$1;AGGREGA(15;6;(RIF.COLONNA($B$1:$M$1)-RIF.COLONNA($B$2)+1)/($B$2:$M$2=$B5);COLONNE($A$1:A2)));"")

    EDIT: Se la ricerca è in entrambe le categorie basta cambiare così:

    =SE.ERRORE(INDICE($B$1:$M$1;AGGREGA(15;6;(RIF.COLONNA($B$1:$M$3)-RIF.COLONNA($B$2)+1)/($B$2:$M$3=$B5);COLONNE($A$1:A2)));"")
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  4. #4
    L'avatar di robbiecs
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Roma
    Età
    37
    Messaggi
    6
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    0

    Re: Cercare valore per colonne

    Innanzitutto grazie per le celeri risposte, allego il file excel a cui sto cercando di apportare la formula. Ges ha intuito la mia necessità ma non riesco ad apportarla sul mio foglio, non mi restituisce alcun valore... ci sono due fogli 1 dove funziona da filtro e l'altro il calendario dove pescare i dati. Ovviamente le righe sono un numero X.
    File Allegati File Allegati

  5. #5
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125

    Re: Cercare valore per colonne

    Ciao a tutti

    @ninai credo che robbies si sia dimenticato della domanda che ha fatto... come al solito..

    @ ges ho notato che ha la versione 2007 e poi nel caso in cui volesse anche la seconda categoria ma in ordine di apparenza

    allora si potrebbe usare qualcosa cosi:
    Da confermare matriciale

    =SE.ERRORE(INDICE($B$1:$M$1;PICCOLO(SE($B$2:$M$2=A$7;RIF.COLONNA($B$2:$M$2)-RIF.COLONNA($B$2)+1);RIGHE($A$10:A10)));INDICE($B$1:$M$1;PICCOLO(SE($B$3:$M$3=A$7;RIF.COLONNA($B$2:$M$2)-RIF.COLONNA($B$2)+1);RIGHE($A$10:A10)-CONTA.SE($B$2:$M$2;$A$7))))




    A
    B
    C
    D
    E
    F
    G
    H
    I
    J
    K
    L
    M
    1
    Gennaio Febbraio Marzo Aprile Maggio Giugno Luglio Agosto Settembre Ottobre Novembre Dicembre
    2
    Categoria
    3
    1
    5
    3
    7
    5
    3
    2
    2
    1
    3
    3
    3
    Categoria 2
    99
    3
    99
    3
    96
    99
    97
    95
    99
    96
    96
    99
    4
    5
    6
    criterio
    7
    3
    8
    9
    Risultato
    10
    Gennaio
    11
    Aprile
    12
    Luglio
    13
    Novembre
    14
    Dicembre
    15
    Febbraio
    16
    Aprile

  6. #6
    L'avatar di robbiecs
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Roma
    Età
    37
    Messaggi
    6
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    0

    Re: Cercare valore per colonne

    Ciao Gerardo, grazie per la risposta e scusa se ho mancato in qualche cosa. Ho provato a riportare la formula suggerita ovviamente personalizzando in base ai due fogli ma non ne vengo fuori.

  7. #7
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125

    Re: Cercare valore per colonne

    Citazione Originariamente Scritto da robbiecs Visualizza Messaggio
    Ciao Gerardo, grazie per la risposta e scusa se ho mancato in qualche cosa. Ho provato a riportare la formula suggerita ovviamente personalizzando in base ai due fogli ma non ne vengo fuori.

    Prova a vedere l'allegato
    File Allegati File Allegati

  8. #8
    L'avatar di robbiecs
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Roma
    Età
    37
    Messaggi
    6
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    0

    Re: Cercare valore per colonne

    perfetto, ora mi resta solo di assegnare un numero minimo di 300 righe

  9. #9

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7108
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: Cercare valore per colonne

    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    ...

    @ ges ho notato che ha la versione 2007 e poi nel caso in cui volesse anche la seconda categoria ma in ordine di apparenza
    ...
    Si, ho visto ora che ha excel 2007 quindi AGGREGA non funziona.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  10. #10
    L'avatar di GiuseppeMN
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Mantova
    Messaggi
    864
    Versione Office
    2000 - 2013
    Likes ricevuti
    285
    Likes dati
    160

    Re: Cercare valore per colonne

    Citazione Originariamente Scritto da robbiecs Visualizza Messaggio
    perfetto, ora mi resta solo di assegnare un numero minimo di 300 righe
    Solo? scusa se è poco; quello che ho difficoltà a capire è perchè non spiegare da subito l'ampiezza del Range. Ma, tant'è.

    Credo che vada rivista la struttura del Foglio di lavoro.

    Stiamo parlando di almeno 3600 Formule; a questo punto una domanda ... "VBA no buono?"


    Ps. Ges, Prova di evacuazione: così, così; ma forse sono io troppo pretenzioso.




    A disposizione

    Buona serata a tutti.

    Giuseppe
    File Allegati File Allegati
    Windows XP Excel 2000 - Windows 10 Excel 2013

  11. #11
    L'avatar di robbiecs
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Roma
    Età
    37
    Messaggi
    6
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    0

    Re: Cercare valore per colonne

    Grazie a tutti per la disponibilità! ho risolto con le funzioni "se" e "cerca.vert" assegnando come matrice la colonna corrispondente al mese e questo tipo di calcolo per ogni mese. Riporto qui la formula, potrebbe tornare utile a qualcun'altro.

    =SE.ERRORE(SE($B$2=CERCA.VERT($B$2;'Calendario'!B2:B515;1;0);'Calendario'!B1;"");"")

  12. #12

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7108
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: Cercare valore per colonne

    La formula che hai scelto trascinandola a destra presenta l'inconveniente di "invadere" anche le colonne non interessate oltre a lasciare celle vuote tra i dati trovati... però se va bene a te!

    Puoi almeno evitare di considerare il FALSO visto che usi SE.ERRORE trasformandola così:

    =SE.ERRORE(SE($B$2=CERCA.VERT($B$2;Calendario!B2:B515;1;0);Calendario!B1);"")


    e sempre in tema d'invasione di altre colonne con l'INDICE ce ne sono diverse formule da poter usare, esempio:

    =SE.ERRORE(INDICE(Calendario!B1:$M$1;CONFRONTA(Filtro!$B$2;Calendario!B2:B1000;0));"")

    matriciale
    =SE.ERRORE(INDICE(Calendario!B1:M1;RICERCA(Filtro!$B$2;Calendario!B2:B1000));"")


    ----------Post unito in automatico----------

    Se il tuo file ha la stessa struttura di quello che hai postato, ti suggerisco anche una soluzione col vba:

    Codice: 
    Sub Trova_Mesi()
        Dim uRow As Long, y As Long, i As Integer, x As Integer
            Sheets(2).Range(Cells(3, 2), Cells(3, 13)) = ""
            uRow = Sheets(1).Cells(Rows.Count, 2).End(xlUp).Row
            x = 2
                For i = 2 To 13
                For y = 2 To uRow
                    If Sheets(1).Cells(y, i).Value = Sheets(2).Cells(2, 2).Value Then
                        Sheets(2).Cells(3, x) = Sheets(1).Cells(1, i).Value
                    x = x + 1
                    End If
                Next: Next
    End Sub
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  13. #13
    L'avatar di robbiecs
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Roma
    Età
    37
    Messaggi
    6
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    0

    Re: Cercare valore per colonne

    Grazie mille :) si effettivamente la soluzione che ho postato invade le colonne non interessate. Utilizzerò il tuo allegato :)

Discussioni Simili

  1. [Risolto] Cerca verticale - cercare i valori comuni in due colonne
    Di stefanoste78 nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 07/03/17, 23:38
  2. [Risolto] Cercare valore non presenti in un elenco
    Di ROBERTOB nel forum Domande su Excel in generale
    Risposte: 24
    Ultimo Messaggio: 01/02/17, 21:52
  3. [Risolto] Confronto di colonne per cercare dato mancante
    Di D@nilo nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 24/12/16, 17:47
  4. Come cercare un valore parziale
    Di Jabets nel forum Domande su Excel in generale
    Risposte: 28
    Ultimo Messaggio: 05/02/16, 01:21
  5. aiuto per cercare un valore
    Di Uistiti63 nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 15/12/15, 19:30

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •