Risultati da 1 a 4 di 4

Discussione: Formule di testo



  1. #1
    L'avatar di D@nilo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Età
    45
    Messaggi
    1170
    Versione Office
    Excel 2010
    Likes ricevuti
    509
    Likes dati
    571

    Formule di testo

    Buonasera a tutti in un altro Forum ho trovato questo quesito:
    Colonna A
    (frasi)
    * vista l'ultima puntata di Lost?
    *hai saputo di Games of Thrones?
    *che ne dici di vedere Scandal?

    Colonna B
    Games of Thrones
    Scandal
    Lost

    Ho bisogno che la colonna C mi restituisca il risultato di quale Serie presente in B di parla in A.
    Ho provato con =SE(VAL.ERRORE(TROVA(B:B;A1));(B:B;A1);"no")

    ma in pratica mi copia esattamente la colonna B
    dove sbaglio?
    io ho fatto il file e in C1 ho messo
    Codice: 
    =STRINGA.ESTRAI(A1;SE.ERRORE(TROVA($B$1;A1);"")&SE.ERRORE(TROVA($B$2;A1);"")&SE.ERRORE(TROVA($B$3;A1);"");LUNGHEZZA(A1)-(SE.ERRORE(TROVA($B$1;A1);"")&SE.ERRORE(TROVA($B$2;A1);"")&SE.ERRORE(TROVA($B$3;A1);"")))
    e funziona correttamente però poi pensato e se la parola/e da estrapolare non fosse sempre l'ultima parte del testo? allora ho messo quest'altra
    Codice: 
    =STRINGA.ESTRAI(A1;SE.ERRORE(TROVA($B$1;A1);"")&SE.ERRORE(TROVA($B$2;A1);"")&SE.ERRORE(TROVA($B$3;A1);"");SE(SE.ERRORE(TROVA($B$1;A1);"")="";"";LUNGHEZZA($B$1))&SE(SE.ERRORE(TROVA($B$2;A1);"")="";"";LUNGHEZZA($B$2))&SE(SE.ERRORE(TROVA($B$3;A1);"")="";"";LUNGHEZZA($B$3)))
    che funziona correttamente....la domanda è:c'è un atro modo magari più corto e con altre funzioni?
    File Allegati File Allegati

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: Formule di testo

    Ciao,
    prova questa matriciale in C1, da trascinare in basso:

    =INDICE($B$1:$B$3;CONFRONTA(1;RICERCA("*"&$B$1:$B$3&"*";A1);0))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. I seguenti 2 utenti hanno dato un "Like" a ges per questo post:


  4. #3
    L'avatar di D@nilo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Età
    45
    Messaggi
    1170
    Versione Office
    Excel 2010
    Likes ricevuti
    509
    Likes dati
    571

    Re: Formule di testo

    Ciao Ges io ci ho sbattuto la testa per due giorni per partorire quell'obbrobrio(che funziona)....me la spieghi la tua?

  5. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Formule di testo

    Niente di particolare, la funzione RICERCA quando trova il pezzo di stringa restituisce 1 ... a questo punto confrontando 1 con RICERCA trovo la riga corrispondente e INDICE la estrae.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

Discussioni Simili

  1. Formule con testo
    Di MassimoB nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 06/12/16, 00:37
  2. [Risolto] Problema formule matriciali: risultati diversi per formule uguali
    Di matrix nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 21/11/16, 00:28
  3. Formule per valori in formato testo
    Di Bruno nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 09/07/16, 09:05
  4. Testo a capo in caselle con formule
    Di Maxsi nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 09/01/16, 21:00
  5. Formule di testo Eliminare 2 parole da una stringa
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 23/07/15, 21:58

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •