Risultati da 1 a 5 di 5

Discussione: analisi orario di pausa



  1. #1
    L'avatar di ZANZARA
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    firenze
    Messaggi
    27
    Versione Office
    excel 2010
    Likes ricevuti
    0
    Likes dati
    1

    analisi orario di pausa

    Buongiorno a tutti, vi scrivo perché come al solito ho bisogno del vostro aiuto.
    In allegato invio un file costituito da due fogli. Il primo riporta data, nominativo e orario inizio/fine pausa.
    Il secondo riporta data, nominativo, e ora operazione.
    Il primo è comprensivo di tutte le pause della giornate lavorative dei nostri dipendenti. Il secondo comprende solo le giornate in cui sono state fatte operazioni dal dipendente.
    Dovrei incrociare i due fogli in modo da estrapolare solo le giornate in cui sono state effettuate le operazioni dai nostri dipendente e controllare se l'ora dell'operazione è compresa nell'intervallo pausa descritto nel primo foglio.
    Spero di essermi spiegata abbastanza bene.......
    Vi ringrazio fin da adesso del vostro aiuto.
    File Allegati File Allegati

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1660
    Versione Office
    2010 PC
    Likes ricevuti
    891
    Likes dati
    184

    Re: analisi orario di pausa

    ciao
    pur avendo intuito, sarebbe il caso che tu riporti nell'esempio cosa vuoi ottenere, come e dove
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. #3
    L'avatar di ZANZARA
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    firenze
    Messaggi
    27
    Versione Office
    excel 2010
    Likes ricevuti
    0
    Likes dati
    1

    Re: analisi orario di pausa

    Nel terzo foglio ho allegato quello che vorrei come risultato .....Grazie
    Ciao
    File Allegati File Allegati

  4. #4
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1660
    Versione Office
    2010 PC
    Likes ricevuti
    891
    Likes dati
    184

    Re: analisi orario di pausa

    ciao
    vedendo che il risultato rispecchia la tabella "LASSO TEMPO", in questa stessa:
    in F2:
    =SE(E(E2="s";MATR.SOMMA.PRODOTTO(('ORARIO OPERAZIONE'!$B$2:$B$4='LASSO TEMPO'!B2)*('ORARIO OPERAZIONE'!$A$2:$A$4='LASSO TEMPO'!A2)*'ORARIO OPERAZIONE'!$C$2:$C$4)>0);MATR.SOMMA.PRODOTTO(('ORARIO OPERAZIONE'!$B$2:$B$4='LASSO TEMPO'!B2)*('ORARIO OPERAZIONE'!$A$2:$A$4='LASSO TEMPO'!A2)*'ORARIO OPERAZIONE'!$C$2:$C$4);"")
    in G2:
    =SE(E2<>"s";"";SE(E(E2="s";F2="");"not present";SE(E(F2>=D2;F2<=D3);"OK";"NO OK")))

    ma prima devi uniformare i dati fra le due tabelle, (i valori delle date e delle ore devono avere lo stesso formato).

    ti allego mio file di lavoro

    nb : io avrei riportato le informazioni richieste nell'altro foglio (ma tu sai meglio di me l'uso che ne devi fare)
    File Allegati File Allegati
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  5. #5
    L'avatar di ZANZARA
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    firenze
    Messaggi
    27
    Versione Office
    excel 2010
    Likes ricevuti
    0
    Likes dati
    1

    Re: analisi orario di pausa

    Grazie, seguirò il tuo esempio.
    Buona giornata.

Discussioni Simili

  1. Orario scritto in numero ma con formato orario e relativa somma
    Di Alessandro nel forum Domande su Excel in generale
    Risposte: 17
    Ultimo Messaggio: 27/02/17, 13:08
  2. Inserire Pausa/Play di un brano Wav in UserForm
    Di Pacifico437 nel forum Domande su Excel VBA e MACRO
    Risposte: 2
    Ultimo Messaggio: 06/11/16, 20:46
  3. aggiunta pausa pranzo a formula
    Di Hyipbox nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 08/06/16, 02:28
  4. divisione di 24h tra orario normale e fuori orario
    Di sebyspadaro nel forum Domande su Excel VBA e MACRO
    Risposte: 20
    Ultimo Messaggio: 25/05/16, 15:05
  5. calcolo pausa pranzo
    Di BabyLu nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 30/03/16, 13:40

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •