Risultati da 1 a 9 di 9

Discussione: Saluti a tutti, inizia qui la mia avventura



  1. #1
    L'avatar di maurizio54
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Cinisello Balsamo (MI)
    Età
    64
    Messaggi
    32
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    2

    Post Saluti a tutti, inizia qui la mia avventura

    Ciao, seguendo il video n°6 di Excel magico ho realizzato un file per calcolare un ipotetico ammortamento. Ho apportato qualche modifica per renderlo più flessibile, ma ho incontrato una piccola difficoltà. Come si fa a fare in modo che Excel tenga conto degli anni bisestili per darmi sempre il pagamento al primo di ogni mese? Allego il mio file per dare modo di verificare se sbaglio qualche cosa e per eventualmente modificare le formule che mi sembrano troppo lunghe.
    Grazie.:191:

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1339
    Ciao e
    hai provato la funzione FINE.MESE?

    fai questa formula in B10 e copia in basso

    =FINE.MESE(B9;0)+1


    Visto che sei nuovo Colgo l'occasione per consigliarti di dare una occhiata alla sezione "annunci dello staff" qui troverai tutte le informazioni e consigli necessari per poter interagire al meglio con questo forum, vedrai come inserire un allegato nella maniera corrette, inserire immagini dinamiche con il BBCode, come inserire Immagini statiche, come inserire una immagine del tuo profilo/Avatar e come inserire una firma digitale
    Ciao grazie e
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  3. #3
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    2142
    Versione Office
    2010 PC
    Likes ricevuti
    1180
    Likes dati
    239
    ciao
    premesso che in B9, inserisci manualmente la data di inizio (1° rata)
    e che in B4, metti il numero di rate annue (1,2,3,4,6,12), in B10 puoi usare:
    =SE(A10="";"";DATA(ANNO(B9);MESE(B9)+12/Rate_annue;GIORNO(B9)))
    e ricopi in basso

    ma vi possono essere altre soluzioni

  4. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    54
    Messaggi
    10004
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2575
    Likes dati
    1548
    Altra soluzione ... in B10 e copia in basso:

    =DATA.MESE(B9;1)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  5. #5
    L'avatar di maurizio54
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Cinisello Balsamo (MI)
    Età
    64
    Messaggi
    32
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    2
    Ciao Gerardo, ho sostituito la formula come da te suggerito e funziona benissimo. Come al solito sei puntuale e preciso Grande!!!_:214:

  6. #6
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    2142
    Versione Office
    2010 PC
    Likes ricevuti
    1180
    Likes dati
    239
    Citazione Originariamente Scritto da maurizio54 Visualizza Messaggio
    Ciao Gerardo, ho sostituito la formula come da te suggerito e funziona benissimo. Come al solito sei puntuale e preciso Grande!!!_:214:
    ma sei sicuro di voler fare solo ammortamenti mensili??
    secondo me dovresti rendere più flessibile la procedura.
    Vedendo la funzione di GES (non me ne ricordavo l'esistenza), io userei in B10:
    =SE(A10="";"";DATA.MESE(B9;12/$B$4))

  7. #7
    L'avatar di maurizio54
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Cinisello Balsamo (MI)
    Età
    64
    Messaggi
    32
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    2
    Grazie ninai, ho provato la tua soluzione e funziona benissimo oltre ad avere una formula più breve della mia. Ciao. :98:

  8. #8
    L'avatar di maurizio54
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Cinisello Balsamo (MI)
    Età
    64
    Messaggi
    32
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    2
    Grazie ancora ninai, ho provato anche il tuo secondo suggerimento prima di quello di GES (che ringrazio comunque) e devo dire e
    che effettivamente è un ottima soluzione. Ciao.

  9. #9

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    54
    Messaggi
    10004
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2575
    Likes dati
    1548
    La formula di ninai è più completa e più flessibile, l'importante comunque è che hai risolto.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

Discussioni Simili

  1. Buona sera a tutti
    Di Sceriffo48 nel forum Domande su Excel VBA e MACRO
    Risposte: 3
    Ultimo Messaggio: 07/11/16, 20:00
  2. Saluti e scuse
    Di CisKo nel forum Off-Topic & pausa caffè
    Risposte: 1
    Ultimo Messaggio: 20/08/16, 18:21
  3. Tutti a Tenerife!!!
    Di Dilly nel forum Off-Topic & pausa caffè
    Risposte: 14
    Ultimo Messaggio: 05/08/16, 16:00
  4. Richiesta aiuto e saluti
    Di joseph_wid nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 15/01/16, 23:38
  5. ciao a tutti, sono nuovo
    Di robert123 nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 21/10/15, 10:33

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •