Risultati da 1 a 7 di 7

Discussione: Turni di oltre 24 ore



  1. #1
    L'avatar di Pizzetto
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    62
    Messaggi
    57
    Versione Office
    2007/2013
    Likes ricevuti
    2
    Likes dati
    7

    Turni di oltre 24 ore

    Salve

    Mi è capitato di dover registrare un turno che parta dalla mezzanotte di oggi e finisca alla mezzanotte di domani. Pari pari.
    Nel senso che dovrà darmi come totale 24 ore esatte. E' possibile?


    Grazie Mauro

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1673
    Versione Office
    2010 PC
    Likes ricevuti
    894
    Likes dati
    184

    Re: Turni di oltre 24 ore

    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. #3
    L'avatar di Pizzetto
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    62
    Messaggi
    57
    Versione Office
    2007/2013
    Likes ricevuti
    2
    Likes dati
    7

    Re: Turni di oltre 24 ore

    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    Scusa Ninai ma non sono stato preciso nella domanda. Le tabelle dei turni sono per tutto il mese ed i turni che superano la mezzanotte già vengono calcolati con:
    =RESTO(F34-E34;1) che funziona alla perfezione, ma non funziona se il turno supera la 24ore


    Scusami

  4. #4
    L'avatar di D@nilo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Età
    45
    Messaggi
    1170
    Versione Office
    Excel 2010
    Likes ricevuti
    509
    Likes dati
    572

    Re: Turni di oltre 24 ore

    Ciao
    sicuramente troveranno una soluzione migliore e più elegante in G1
    Codice: 
    =SE(RESTO(F1-E1;1)=0;(F1+(RESTO(ORARIO(0;0;0)-F1;1)));RESTO(F1-E1;1))
    se devi mettere un entrata a mezzanotte e uscita a mezzanotte devi scrivere in E1 00:00 e in F1 24:00 e formattare in personalizzato [h]:mm

  5. I seguenti utenti hanno dato un "Like"


  6. #5
    L'avatar di Pizzetto
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    62
    Messaggi
    57
    Versione Office
    2007/2013
    Likes ricevuti
    2
    Likes dati
    7

    Re: Turni di oltre 24 ore

    Ciao Danilo

    Si funziona. Grazie mille

  7. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Turni di oltre 24 ore

    Ciao a tutti. rieccomi dopo una lunga latitanza dal forum

    Danilo scrive:
    se devi mettere un entrata a mezzanotte e uscita a mezzanotte devi scrivere in E1 00:00 e in F1 24:00
    Non è possibile scrivere 24:00 perchè per excel non è riconosciuto come valore, ma se proprio vuoi far riconoscere il giorno successivo dovresti scrivere anche la data e l'ore es. 15/04/2016 00:00 che mi sembra la strada migliore e più logica da percorrere perche se uno lavora piu di 24 ore come faccio a far capire ad excel che abbiamo sfondato il giorno successivo???

    Nella formula di Danilo c'è un forzatura a far riconoscere 00:00 in 24:00 ma ripeto è scorretto perchè è un valore inesistente
    Quindi dovendo usare 00:00 (inizio) e 00:00 (fine)
    dovresti fare una formula cosi (simile a quella di Danilo)

    =SE(RESTO(B2-A2;1)=0;RESTO(B2-A2;1)+1;RESTO(B2-A2;1))


    oppure più corta:

    =SE(B3-A3=0;1;SE(B3<A3;B3+1;B3)-A3)


    A
    B
    C
    1
    Entrata Uscita ore
    2
    0:00
    0:00
    24:00


    Un saluto
    Ultima modifica fatta da:Gerardo Zuccalà; 02/08/16 alle 00:59

  8. I seguenti 3 utenti hanno dato un "Like" a Gerardo Zuccalà per questo post:


  9. #7
    L'avatar di Pizzetto
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    62
    Messaggi
    57
    Versione Office
    2007/2013
    Likes ricevuti
    2
    Likes dati
    7

    [Risolto] Turni di oltre 24 ore

    Ciao Gerardo e grazie anche a te

    Questa è secondo me la soluzione più elegante che intendeva Danilo.


    Come al solito siete tutti magnifici..

    A presto Mauro

    ----------Post unito in automatico----------

    Nota per Gerardo

    Le tue soluzioni danno 24 anche a celle vuote. Ho comunque ovviato in questo modo:

    =SE(D12="";"";SE(D12-C12=0;1;SE(D12<C12;D12+1;D12)-C12))


    A presto Mauro

  10. I seguenti utenti hanno dato un "Like"


Discussioni Simili

  1. [Risolto] Conteggio turni
    Di Red65 nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 05/01/17, 22:57
  2. [Risolto] calendario turni
    Di lauriciano78 nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 24/12/16, 18:01
  3. Risposte: 6
    Ultimo Messaggio: 03/11/16, 06:20
  4. importare txt oltre numero max righe excel
    Di Loretta nel forum Domande su Excel in generale
    Risposte: 20
    Ultimo Messaggio: 19/01/16, 19:52
  5. Programmare turni : che fatica !
    Di IronEagle nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 22/12/15, 20:26

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •