Risultati da 1 a 5 di 5

Discussione: Cerca.Vert con Se



  1. #1
    L'avatar di jigen
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Vicenza
    Età
    23
    Messaggi
    30
    Versione Office
    2015
    Likes ricevuti
    0
    Likes dati
    0

    Cerca.Vert con Se

    Salve a tutti,

    come potete notare dal file allegato in esempio ho un documento formato da due fogli
    Nel foglio Differenza si trova nella colonna A una serie di codici e nella colonna B una serie di valori
    Nel foglio 2015 ho la stessa situazione ma con codici diversi e non ordinati in maniera uguale

    Ora io nella colonna C della scheda Differenza ho inserito una formula con se + cerca.vert + val.non.disp. per cercare se il codice della riga in cui mi trovo (scheda differenza) sia presente o meno nella colonna A della scheda 2015. Se si, allora dovrebbe prendermi il valore della colonna B corrispondente dalla scheda 2015 ed inserirmelo nella colonna C della scheda Differenza. Il tutto poi si concluderà con la differenza dei due valori nella colonna differenza.

    Come si può notare però nella cella evidenziata in scheda differenza, nel caso in cui il codice non sia presente viene comunque preso il valore della riga precedente invece che essere sostituito con "Non trovato".

    Qualcuno può aiutarmi?
    Grazie in anticipo
    File Allegati File Allegati

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4020
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923

    Re: Cerca.Vert con Se

    Ciao,

    prova semplicemente a cercare la corrispondenza esatta aggiungendo FALSO come ultimo argomento del CERCA.VERT.

    Quindi, nella cella C2 scriverai:

    =SE(VAL.NON.DISP(CERCA.VERT(A2;'2015'!$A$2:$B$4;1;FALSO)); "Non trovato"; CERCA.VERT(A2;'2015'!$A$2:$B$4;2;FALSO))

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  3. #3

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2809
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979

    Re: Cerca.Vert con Se

    Devi usare l'argomento [intervallo]= FALSO (oppure 0 zero) se vuoi trovare il valore esatto altrimenti CERCA.VERT ti troverà il valore inferiore più vicino.
    Codice: 
    SE(VAL.NON.DISP(CERCA.VERT(A2;'2015'!$A$2:$B$4;1;FALSO)); "Non trovato"; CERCA.VERT(A2;'2015'!$A$2:$B$4;2))
    P.S. puoi usare anche SE.ERRORE anzichè VAL.NON.DISP
    Codice: 
    =SE.ERRORE(CERCA.VERT(A2;'2015'!$A$2:$B$4;2;0);"Non trovato")
    EDIT: Bruciato sul tempo da @Cromagno

  4. #4
    L'avatar di jigen
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Vicenza
    Età
    23
    Messaggi
    30
    Versione Office
    2015
    Likes ricevuti
    0
    Likes dati
    0

    Re: Cerca.Vert con Se

    @cromagno con la tua soluzione stampa il "non trovato" correttamente, quindi bisognava settare anche il falso obbligatoriamente?

    ----------Post unito in automatico----------

    @Rubik72 mi fai morire ahah E' già la terza questione che pongo e sia tu che cromagno mi salvate letteralmente la giornata, facciamo una volta a testa dai ahah:)

  5. #5

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4020
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923

    Re: Cerca.Vert con Se

    Ciao a tutti,

    @Rubik
    beh dai, almeno ci confermiamo le risposte a vicenda

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

Discussioni Simili

  1. cerca.vert
    Di antonio64 nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 05/03/17, 22:54
  2. [Risolto] Cerca valori che si ripetono in tabella. Formula per arrivare dove il cerca.vert non può
    Di Gatt88 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 02/12/16, 11:45
  3. [Risolto] Cerca.vert
    Di replay66 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 17/09/16, 15:52
  4. Cerca.vert
    Di Snoopy nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 09/06/16, 17:01
  5. cerca vert
    Di Lucagiuseppe nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 02/02/16, 18:58

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •