Risultati da 1 a 7 di 7

Discussione: media valori ogni x righe



  1. #1
    L'avatar di Loretta
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Bari
    Età
    34
    Messaggi
    90
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    31

    media valori ogni x righe

    Buongiorno a tutti,

    ho un foglio in cui in colonna B ho valori dalla riga 3 alla riga 55228.

    In P11 voglio effettuare la seguente media: =MEDIA(B11;B47;B83;B119;B155;B191;B227;B263;B299;B335;B371;B407;ecc…….. fino a ;B55163;B55199)
    Quindi a partire dalla cella B11 solo prendendo le celle ogni 36 righe e fino alla fine dei valori in colonna B, l’intervallo di righe tra una cella e l’altra è sempre lo stesso.

    Vorrei inserire una formula in P11 che posso trascinare verso il basso e ottenere la media solo delle celle indicate.

    Ho provato con questa formula:
    =MEDIA(INDICE(B:B;36*(RIGHE($11:11)-1)+1):INDICE(B:B;36*RIGHE($47:47))) ma è ovviamente sbagliata.

    Mi date qualche suggerimento ?
    grazieee

    P:S: nel foglio allegato ho inserito solo le righe iniziali altrimenti non riuscivo ad allegarlo e ho evidenziato in giallo le celle di cui voglio ottenere la media..
    File Allegati File Allegati

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127

    Re: media valori ogni x righe

    Ciao Loretta
    Ho visto la formula che hai messo nel foglio e non è la stessa che hai scritto qui sopra

    infatti nel foglio ho visto questa
    =MEDIA(INDICE(B:B;36*(RIGHE(9:$11)-1)+1):INDICE(B:B;36*RIGHE(45:$47)))


    che è diversa da questa (vedi in rosso) che sembra funzionare bene (non testata)
    =MEDIA(INDICE(B:B;36*(RIGHE($11:11)-1)+1):INDICE(B:B;36*RIGHE($47:47)))


  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di Japogi
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Napoli
    Età
    37
    Messaggi
    64
    Versione Office
    Excel 2007
    Likes ricevuti
    1

    Re: media valori ogni x righe

    Ciao,

    una mia soluzione più artigianale è quella di servirmi del Foglio2 e utilizzare la funzione Indiretto, dove nella colonna A ho inserito i riferimenti delle righe da prelevare
    quindi nel Foglio1!P11 utlizzo la formula media della colonna B del Foglio2.

    Ti allego il file tuo modificato
    File Allegati File Allegati

  5. I seguenti utenti hanno dato un "Like"


  6. #4
    L'avatar di Loretta
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Bari
    Età
    34
    Messaggi
    90
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    31

    Re: media valori ogni x righe

    Buongiorno e grazie per i vostri utili suggerimenti.

    Ho un altro dubbio:
    devo eseguire la media su una colonna di valori. La colonna contiene diverse celle vuote che devo escludere dalla media poichè se eseguendo la funzione media le celle vuote venissero conteggiate come zero allora ciò mi sfaserebbe tutta la media.

    che funzione posso usare ?

    grazie

    loretta

  7. #5
    L'avatar di Japogi
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Napoli
    Età
    37
    Messaggi
    64
    Versione Office
    Excel 2007
    Likes ricevuti
    1

    Re: media valori ogni x righe

    Citazione Originariamente Scritto da Loretta Visualizza Messaggio
    Buongiorno e grazie per i vostri utili suggerimenti.

    Ho un altro dubbio:
    devo eseguire la media su una colonna di valori. La colonna contiene diverse celle vuote che devo escludere dalla media poichè se eseguendo la funzione media le celle vuote venissero conteggiate come zero allora ciò mi sfaserebbe tutta la media.

    che funzione posso usare ?

    grazie

    loretta
    Somma (colonna)/conta.valori (colonna)

  8. #6
    L'avatar di Loretta
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Bari
    Età
    34
    Messaggi
    90
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    31

    Re: media valori ogni x righe

    ok, grazie.

  9. #7
    L'avatar di Japogi
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Napoli
    Età
    37
    Messaggi
    64
    Versione Office
    Excel 2007
    Likes ricevuti
    1

    Re: media valori ogni x righe

    scusami ero sul cellulare e non ho scritto bene la formula stamane

    =SOMMA(B:B)/CONTA.VALORI(B:B)

    ho preso di esempio la colonna B spero che tu abbia risolto

    ciao

Discussioni Simili

  1. [Risolto] calcolo media top valori
    Di braga1 nel forum Domande su Excel in generale
    Risposte: 18
    Ultimo Messaggio: 24/02/17, 21:47
  2. [Risolto] dubbio su MEDIA righe
    Di Loretta nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 22/11/16, 12:27
  3. media ogni 10minuti
    Di Loretta nel forum Domande su Excel in generale
    Risposte: 17
    Ultimo Messaggio: 13/01/16, 11:31
  4. MEDIA ogni 6 righe
    Di Loretta nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 22/11/15, 07:42
  5. Media dei 3 valori più grandi
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 08/09/15, 00:54

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •