Risultati da 1 a 11 di 11

Discussione: Implemantare data scadenza e verifcare aggiornamento



  1. #1
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Implemantare data scadenza e verifcare aggiornamento

    Ciao a tutti,
    vorrei in questo file:https://www.dropbox.com/s/jju1pnl8chvbriy/GestForm_V3%2Bforum.xlsm?dl=0

    1) Calcolare la data di scadenza del corso nel foglio di lavoro “Dashboard”

    Il dato atteso in H29, per il lavoratore “Super Daniele” riferito al corso “ADDETTI I SOCCORSO (classe B)” è: 02/05/16
    (ottenuto implementando la data presente in D29 con l'indicazione di durata presente in "Legenda" nella cella H3

    2) Verificarne eventuali aggiornamenti

    In I29 sempre nel foglio di lavoro “Dashboard” scriverne lo stato (OK o NO).

    Quindi il dato atteso è nella cella I29 è NO ( infatti nel foglio "2_Aggiornamenti (2) " in D15 la cella è vuota ).

    Nel caso fosse stato eseguito il corso: in I29 -> dicitura: OK (questo presuppone che nella cella D15 ci sia il testo "01/04/16_06")

    Grazie in anticipo
    Gene

  2. #2
    L'avatar di Marius44
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Catania
    Età
    73
    Messaggi
    3216
    Versione Office
    Excel2010
    Likes ricevuti
    625
    Likes dati
    155

    Re: Implemantare data scadenza e verifcare aggiornamento

    Ciao Gene
    in Dashboard
    cella H29
    Codice: 
    =SINISTRA(D29;6)&ANNO(D29)+CERCA.VERT(C29;Frequenza_corsi;2)
    cella I29
    Codice: 
    =SE(CERCA.VERT(C7;'2_Aggiornamenti (2)'!A15:L34;3;0)="";"NO";"OK")
    Ti avverto, però, che non credo vada bene la seconda formula in quanto dovrebbe essere resa dinamica sia per la ricerca del nominativo sia per quanto attiene al tipo di corso. Comunque puoi studiarci un poco sopra.

    Fai sapere. Ciao,
    Mario

  3. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: Implemantare data scadenza e verifcare aggiornamento

    Ciao a tutti,
    prevederei queste formule:

    in H29:

    =MATR.SOMMA.PRODOTTO((DATA.MESE(D29;12*(Legenda!H2:H33)))*(Legenda!G2:G33=Dashboard!C29))

    Mentre in I29:

    =SE(INDICE('2_Aggiornamenti (2)'!B15:L34;CONFRONTA(Dashboard!C7;'2_Aggiornamenti (2)'!A15:A34;0);CONFRONTA(Dashboard!B29;'2_Aggiornamenti (2)'!B14:L14;0))>0;"SI";"NO")

    Aggiungo però la condizione del confronto in B29 (può essere messo anche in altra parte ma mi serve per confrontare il tipo di corso come dice Mario (un saluto) - sempre se ho ben capito)

    Allego file da scaricare
    QUI
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  4. #4
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Re: Implementare data scadenza e verificare aggiornamento

    Ciao a tutti,
    @Mario
    confermo che la formula in H29 funziona

    @Ges
    Non riesco a scaricare il file mi si impalla Dropbox, forse è la linea che qui in montagna non eccelle. Ci provo più tardi.
    Prima della tua risposta, avevo provato a trovare la soluzone partendo dalla semplificazione dell'impaginazione" del foglio "2_Aggiornamenti (2) ": https://www.dropbox.com/s/zjdue0x298...orum.xlsm?dl=0

    La tua formula come cambierebbe?

    La nuova impaginazione mi dovrebbe aiutare a creare da solo (spero!!) una macro VBA per riportare nel foglio stesso i nominativi del personale che dalla compilazione del form si evinca che ha funzioni speciali di sicurezza (RLS Addetto antincendio, etc) e per questo motivo che ti pongo la domanda di cui sopra.

    Grazie
    Gene

  5. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: Implementare data scadenza e verificare aggiornamento

    Ho visto il tuo nuovo file,
    in H29 dovrebbe andare bene la formula di cui sopra, cioè:

    =MATR.SOMMA.PRODOTTO((DATA.MESE(D29;12*(Legenda!H2:H33)))*(Legenda!G2:G33=Dashboard!C29))

    Non ho capito però l'altra cosa dovrebbe confrontare.

    Col vba dovrebbe essere più semplice ... ma spetta a te scriverlo!
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. #6
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Re: Implementare data scadenza e verificare aggiornamento

    Ciao. Un solo impegno Vba alla volta!!
    Per I29 mi tirate fuori con una formula delle vostre?
    La formula deve verificare se rispetto alla scadenza, l'operatore ha fatto un' aggiornamento successivo ed indicarlo con ok oppure no.
    Gene

  7. #7

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4019
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923

    Re: Implementare data scadenza e verificare aggiornamento

    Ciao a tutti,

    @Gene
    in base all'ultimo file che hai allegato,nella cella I29 puoi provare questa:

    =SE.ERRORE(SE(INDICE('2_Aggiornamenti (2)'!$F$5:$Z$24;CONFRONTA(Dashboard!$C$7;'2_Aggiornamenti (2)'!$A$5:$A$24;0);CONFRONTA(CERCA(ANNO(OGGI());INDICE(ANNO($D29)+(RIF.RIGA($A$1:$A$50)*CERCA.VERT($C29;Frequenza_corsi;2;FALSO));;));'2_Aggiornamenti (2)'!$F$4:$Z$4))="";"NO";"OK");"NO")

    Fai delle prove....

    Ciao
    Tore

    [EDIT]
    La formula è valida fino al 50esimo anno dopo la data in cui si è effettuato il primo corso (es. cella D29).
    Se vuoi aumentare "questi 50 anni", basta incrementare il valore 50 nel RIF.RIGA:

    =SE.ERRORE(SE(INDICE('2_Aggiornamenti (2)'!$F$5:$Z$24;CONFRONTA(Dashboard!$C$7;'2_Aggiornamenti (2)'!$A$5:$A$24;0);CONFRONTA(CERCA(ANNO(OGGI());INDICE(ANNO($D29)+(RIF.RIGA($A$1:$A$50)*CERCA.VERT($C29;Frequenza_corsi;2;FALSO));;));'2_Aggiornamenti (2)'!$F$4:$Z$4))="";"NO";"OK");"NO")

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  8. I seguenti utenti hanno dato un "Like"


  9. #8

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: Implementare data scadenza e verificare aggiornamento

    Ciao,
    sempre se ho ben capito, potrebbe andare anche questa:

    =SE.ERRORE(SE(INDICE('2_Aggiornamenti (2)'!F5:Z24;CONFRONTA(C7;'2_Aggiornamenti (2)'!A5:A24;0);CONFRONTA(ANNO(H29);'2_Aggiornamenti (2)'!F4:Z4;0))<H29;"SI";"NO");"")

    Allego file:
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  10. I seguenti utenti hanno dato un "Like"


  11. #9
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Re: Implementare data scadenza e verificare aggiornamento

    Ciao,
    grazie ad entrambi per le proposte.

    @Cromagno


    Ho provato a modificare la formula in I29 per non visualizzare il NO quando la cella scadenza è vuota ma senza risultato:
    Codice: 
    =SE.ERRORE(SE(INDICE('2_Aggiornamenti   (2)'!$F$5:$Z$24;CONFRONTA(Dashboard!$C$7;'2_Aggiornamenti  (2)'!$A$5:$A$24;0);CONFRONTA(CERCA(ANNO(OGGI());INDICE(ANNO($D29)+(RIF.RIGA($A$1:$A$50)*CERCA.VERT($C29;Frequenza_corsi;2;FALSO));;));'2_Aggiornamenti   (2)'!$F$4:$Z$4))="";"NO";"OK");"")
    Citazione Originariamente Scritto da cromagno Visualizza Messaggio

    La formula è valida fino al 50esimo anno dopo la data in cui si è effettuato il primo corso (es. cella D29).
    Se vuoi aumentare "questi 50 anni", basta incrementare il valore 50 nel RIF.RIGA:.......
    Dovrei farcela con la prima formula....ovviamente se la prof.ssa Fornero non ha eredi da fare entrare in politica nei prossimi anni...


    @Ges
    Ho aperto un thread VBA.....sii magnanimo

    Gene
    Ultima modifica fatta da:Canapone; 08/05/17 alle 20:20

  12. #10

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4019
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923

    Re: Implementare data scadenza e verificare aggiornamento

    Ciao Gene,

    per ottenere la cella vuota (all'occorrenza) puoi prendere come riferimento una delle celle a fianco...ad esempio la cella della "Data" D29.

    Quindi nella cella I29 la formula diventerà:

    =SE($D29="";"";SE.ERRORE(SE(INDICE('2_Aggiornamenti (2)'!$F$5:$Z$24;CONFRONTA(Dashboard!$C$7;'2_Aggiornamenti (2)'!$A$5:$A$24;0);CONFRONTA(CERCA(ANNO(OGGI());INDICE(ANNO($D29)+(RIF.RIGA($A$1:$A$50)*CERCA.VERT($C29;Frequenza_corsi;2;FALSO));;));'2_Aggiornamenti (2)'!$F$4:$Z$4))="";"NO";"OK");"NO"))

    Quello che ho detto prima:
    La formula è valida fino al 50esimo anno dopo la data in cui si è effettuato il primo corso (es. cella D29).
    non è spiegato bene...
    è valida per i 50 aggiornamenti successivi al corso.
    Quindi è valida per un minimo di 50 anni (nel caso di frequenza aggiornamento uguale ad 1 un anno).
    Si, credo proprio che ti basterà

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  13. #11
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Re: Implementare data scadenza e verificare aggiornamento

    [RISOLTO]


    Grazie

    Gene

Discussioni Simili

  1. Macro con "data di scadenza"
    Di Ciccio nel forum Domande su Excel VBA e MACRO
    Risposte: 16
    Ultimo Messaggio: 18/12/16, 11:58
  2. [Risolto] Ricerca della data di prossima scadenza
    Di Pabexcel nel forum Domande su Excel in generale
    Risposte: 17
    Ultimo Messaggio: 22/11/16, 03:19
  3. [Risolto] Calcolo automatico della data scadenza di fatture
    Di rmalenc nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 18/11/16, 12:09
  4. aggiornamento dati da query web in righe successive al variare di data
    Di aleao nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 24/04/16, 13:41
  5. File carico scarico in ordine di data scadenza
    Di wifi75 nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 10/03/16, 11:24

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •