Risultati da 1 a 8 di 8

Discussione: Correzione automatica di una formula incoerente per la colonna calcolata



  1. #1
    L'avatar di AndreaFr
    Clicca e Apri
    Data Registrazione
    Aug 2016
    Località
    GENOVA
    Messaggi
    5
    Versione Office
    EXCEL 2010
    Likes ricevuti
    0
    Likes dati
    3

    Correzione automatica di una formula incoerente per la colonna calcolata

    Buongiorno a tutti

    Vorrei sapere se c'è un modo per dire ad Excel di applicare automaticamente la correzzione "Ripristina formula colonna calcolata" qualora si presentasse un avviso di errore per una o piu formule non coerenti per la colonna calcolata

    In pratica vorrei evitare di dover andare singolarmente su ogni cella e selezionare manualmente l'opzione "Ripristina formula colonna calcolata"

    Spero che qualcuno di voi mi possa aiutare

    Ringrazio ancora e saluto

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7132
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299

    Re: Correzione automatica di una formula incoerente per la colonna calcolata

    Ciao,
    prova a postare un file excel con un breve esempio degli errori a cui ti riferisci.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di AndreaFr
    Clicca e Apri
    Data Registrazione
    Aug 2016
    Località
    GENOVA
    Messaggi
    5
    Versione Office
    EXCEL 2010
    Likes ricevuti
    0
    Likes dati
    3

    Re: Correzione automatica di una formula incoerente per la colonna calcolata

    Ciao GES grazie mille per la tua risposta. ti ho allegato un esempio tipo del mio problema.
    Se tu inserisci tre righe per esempio a partire dalla riga numero 14 avremo che nelle righe 14, 15 e 16 le formule della colonna K si mantengono automaticamente in modo corretto, mentre quella della riga 17 (la precedente 14) rimane quella iniziale e mi da l'errore di incoerenza.

    a questo punto dovrei andare manualmente sulla cella K17 e correggere l'errore con "Ripristina formula colonna calcolata". Quello che sto cercando di fare è evitare questo passaggio manuale perche il foglio excel creato è ben piu complicato e non posso sicuramente farlo a mano

    Grazie ancora e spero che sia stato abbastanza chiaro e che tu sappia come fare.

    A
    File Allegati File Allegati

  4. #4
    L'avatar di ggratis
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Lecce - Pisa
    Età
    45
    Messaggi
    737
    Versione Office
    Excel 2010
    Likes ricevuti
    257
    Likes dati
    215

    Re: Correzione automatica di una formula incoerente per la colonna calcolata

    con vba.
    nel modulo di classe del foglio:
    Codice: 
    Private Sub Worksheet_Change(ByVal Target As Range)
        If Not Intersect(Target, Range("tabella2")) Is Nothing Then
            Application.EnableEvents = False
            Range("K10").autofill Destination:=Range(Range("K10"), Range("K10").End(xlDown))
            Application.EnableEvents = True
        End If
    End Sub
    saluti
    gg

  5. I seguenti utenti hanno dato un "Like"


  6. #5
    L'avatar di Raffaele_53
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Binasco
    Età
    64
    Messaggi
    506
    Versione Office
    2007
    Likes ricevuti
    85
    Likes dati
    7

    Re: Correzione automatica di una formula incoerente per la colonna calcolata

    Ciao a tutti
    Potresti provare in K10=SE(E(B10<>0;B10<>"-");B10;INDIRETTO("K"&RIF.RIGA()-1))

  7. I seguenti utenti hanno dato un "Like"


  8. #6
    L'avatar di ggratis
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Lecce - Pisa
    Età
    45
    Messaggi
    737
    Versione Office
    Excel 2010
    Likes ricevuti
    257
    Likes dati
    215

    Re: Correzione automatica di una formula incoerente per la colonna calcolata

    Ciao Raffaele,
    Credo che con il tuo metodo funzioni solo una volta.
    Saluti
    GG

    Inviato dal mio GT-I9105P utilizzando Tapatalk

  9. I seguenti utenti hanno dato un "Like"


  10. #7
    L'avatar di AndreaFr
    Clicca e Apri
    Data Registrazione
    Aug 2016
    Località
    GENOVA
    Messaggi
    5
    Versione Office
    EXCEL 2010
    Likes ricevuti
    0
    Likes dati
    3

    Re: Correzione automatica di una formula incoerente per la colonna calcolata

    Grazie a tutti. siete state tutti utili e dovrei aver risolto.

    a buon rendere

  11. #8
    L'avatar di Raffaele_53
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Binasco
    Età
    64
    Messaggi
    506
    Versione Office
    2007
    Likes ricevuti
    85
    Likes dati
    7

    Re: Correzione automatica di una formula incoerente per la colonna calcolata

    Ciao ggratis
    Hai ragione, nella prima riga ==SE(E(B8<>0;B8<>"-");B8;MAX(B$8:B8)) dovrebbe andare

Discussioni Simili

  1. Risposte: 2
    Ultimo Messaggio: 30/01/17, 16:19
  2. Risposte: 5
    Ultimo Messaggio: 01/12/16, 12:36
  3. Correzione automatica e colorazione celle
    Di ceccio17 nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 25/08/16, 22:10
  4. Risposte: 10
    Ultimo Messaggio: 18/07/16, 18:25
  5. Copia formula su intera colonna
    Di follaro nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 02/01/16, 17:34

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •