Risultati da 1 a 5 di 5

Discussione: Formula "ore lavorate"



  1. #1
    L'avatar di Shingo18
    Clicca e Apri
    Data Registrazione
    Aug 2016
    Località
    Trieste
    Messaggi
    2
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    0

    Formula "ore lavorate"

    Buongiorno, avrei bisogno di un aiuto per determinare una formula.

    Nelle colonne A, B, C, D inserisco rispettivamente: orario di ingresso alla mattina, orario di uscita alla mattina, orario di ingresso al pomeriggio, orario di uscita al pomeriggio.

    Nella colonna E vorrei ottenere il totale delle ore lavorate, quindi: (uscita mattina-entrata mattina)+(uscita pomeriggio-entrata pomeriggio), ma allo stesso tempo vorrei che la cella E rimanesse vuota se non inserisco i dati nelle colonne precedenti (come in caso di ferie).

    Mi era stata suggerita questa formula:
    =SE(E(A9="";B9="";C9="";D9="");"";SE(E(A9<>0;B9<>0);((B9<A9)+B9-A9);0)+SE(E(C9<>0;D9<>0);((D9<C9)+D9-C9);0))
    ma come risultato ottengo: #VALORE!

    qualche suggerimento?

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1680
    Versione Office
    2010 PC
    Likes ricevuti
    895
    Likes dati
    184

    Re: Formula "ore lavorate"

    senza entrare nel merito della formula, questa sembra funzionare, a meno che una delle celle interessate contenga del testo invece che numeri
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301

    Re: Formula "ore lavorate"

    Ciao a tutti,
    Shingo prova ad allegare un file excel con l'errore.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  4. #4
    L'avatar di D@nilo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Età
    45
    Messaggi
    1170
    Versione Office
    Excel 2010
    Likes ricevuti
    509
    Likes dati
    572

    Re: Formula "ore lavorate"

    ciao in E2 e tiri giù
    Codice: 
    =SE(RESTO(B2-A2+D2-C2;1)=0;"";RESTO(B2-A2+D2-C2;1))
    File Allegati File Allegati

  5. I seguenti utenti hanno dato un "Like"

    ges

  6. #5
    L'avatar di Shingo18
    Clicca e Apri
    Data Registrazione
    Aug 2016
    Località
    Trieste
    Messaggi
    2
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    0

    Re: Formula "ore lavorate"

    Ringrazio.....funziona!

Discussioni Simili

  1. [Risolto] Ordinare con la funzione "piccolo"..ma "portandosi dietro" anche altri dati affiancati
    Di mauri73 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 05/02/17, 14:57
  2. [Risolto] Come leggere la seguente formula =SE.ERRORE(INDIRETTO("'"&A1&"'!K1";1);""))
    Di sitolofi nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 20/12/16, 14:54
  3. problema con formula se con "maggiore" e "minore" > e <
    Di fireman80 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 09/05/16, 21:36
  4. Accorciare formula "SE" "O" con tanti valori
    Di Theinvoker nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 08/04/16, 15:16
  5. [Risolto] Codice non funzionante dopo il passaggio da "Windows" a "Mac"...
    Di joondeep nel forum Foglio di calcolo su altre Piattaforme
    Risposte: 13
    Ultimo Messaggio: 12/03/16, 21:09

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •