Risultati da 1 a 3 di 3

Discussione: Valore per ordine di grandezza in rapporto agli altri dati in matrice



  1. #1
    L'avatar di Andrau
    Clicca e Apri
    Data Registrazione
    Aug 2016
    Località
    torino
    Età
    37
    Messaggi
    2
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Valore per ordine di grandezza in rapporto agli altri dati in matrice

    Ciao,
    Ho difficoltà a spiegare la mia necessità, pertanto mi scuso per la descrizione un po' complessa.
    Ho una colonna DATI con degli elementi in formato testo, e valori sia in formato numero che testo.

    Alcuni numeri sono tuttavia scritti in formato testo e si riferiscono prodotti e relativo numero di matricola non progressivo:
    ad esempio:
    730.xxx
    Parte.xxx

    Dove xxx è un numero non univoco che indica la matricola.
    Insieme a questi so trovano anche valori in formato numero per altra funzione.
    I valori e le matricole non si trovano in ordine, ma sono sparsi.

    Il mio obiettivo non usare colonne di supporto, vba ecc... ma solo con formule matrice (quelle con le graffe).
    Su una colonna a fianco mi servirebbe avere un valore progressivo dell'ordine di grandezza di ogni matricola in relazione a tutti gli altri numeri di quella matricola. Credo che si chiami RANGO, non funziona con valori in formato testo.
    Ossia, scelto di lavorare solo sulla matricola 730, avere a fianco della più piccola matricola 730 avere 1 e via via 2,3,4 eccc... fino al valore 730.xxx più grande con a fianco l'ordine più grande.
    Tutti gli altri prodotti e valori della colonna Dati non corrispondenti a 730.xxx devono aver a fianco il valore 0.
    Ho allegato un file xls semplice con alcuni miei tentativi ma senza successo.
    Grazie per aiuti e consigli
    File Allegati File Allegati

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1653
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183

    Re: Valore per ordine di grandezza in rapporto agli altri dati in matrice

    ciao
    Secondo me la casistica che tu hai presentato come esempio è troppo ristretta per vlutare quali vincoli vi siano nel numero e tipo di caratteri previsti dalla codifica, comunque come bozza potrebbe andare:
    =SE.ERRORE((TROVA(".";A2)=4)*MATR.SOMMA.PRODOTTO((SINISTRA(range1;3)=SINISTRA(A2;3))*(DESTRA(range1;3)<DESTRA(A2;3)))+1;"")
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di Andrau
    Clicca e Apri
    Data Registrazione
    Aug 2016
    Località
    torino
    Età
    37
    Messaggi
    2
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Valore per ordine di grandezza in rapporto agli altri dati in matrice

    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    ciao
    Secondo me la casistica che tu hai presentato come esempio è troppo ristretta per vlutare quali vincoli vi siano nel numero e tipo di caratteri previsti dalla codifica, comunque come bozza potrebbe andare:
    =SE.ERRORE((TROVA(".";A2)=4)*MATR.SOMMA.PRODOTTO((SINISTRA(range1;3)=SINISTRA(A2;3))*(DESTRA(range1;3)<DESTRA(A2;3)))+1;"")
    Direi che funziona bene ma siccome devo analizzare una sola matricola ho sostituito l'argomento del TROVA "." con ad esempio "730." diventando quindi (TROVA("730.";A2)=1) se devo analizzare la matricola 730.xxx e funziona perfettamente.

    Non so perchè io mi sono impegolato con altri sistemi che mi davano problemi con valori scritti in formato testo e numeri....

    Grazie comunque!

Discussioni Simili

  1. Interpolazione e scelta di un valore da una matrice
    Di saturn87 nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 06/09/16, 17:21
  2. Avviso agli altri membri dello Staff
    Di Max nel forum Problemi, suggerimenti e Novità del forum
    Risposte: 1
    Ultimo Messaggio: 09/06/16, 13:38
  3. Cerca valore in una matrice dinamica
    Di Bolz1 nel forum Domande su Excel in generale
    Risposte: 26
    Ultimo Messaggio: 04/01/16, 09:25
  4. Dati da dashboard di un foglio agli altri
    Di mau83 nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 17/12/15, 11:49
  5. Dati da dashboard di un foglio agli altri
    Di mau83 nel forum Domande su Excel VBA e MACRO
    Risposte: 9
    Ultimo Messaggio: 17/12/15, 11:28

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •