Risultati da 1 a 10 di 10

Discussione: Formato numeri telefonici



  1. #1
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Formato numeri telefonici

    Cio a tutti
    come potete notare nel campo origine ho dei numeri telefonici scaricati che si presentano in maniera proprio precaria
    ed io vorrei che tutti i numeri che iniziano con "3" venga messo il "dash" (segno meno) dopo il 3 numero e senza lo zero davanti (cellulari)
    mentre i numeri che non iniziano con il "3" si aggiunge lo zero davanti e il "dash" (segno meno) dopo il terzo carattere
    buon divertimento


    A
    B
    1
    origine risultato
    2
    3219876543
    321-9876543
    3
    419876543
    041-9876543
    4
    21554151
    021-554151
    5
    34515511
    345-15511
    6
    359887587
    359-887587
    7
    15822
    015-822
    Ultima modifica fatta da:Gerardo ZuccalÓ; 20/08/15 alle 15:31

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Como
    EtÓ
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300
    La prima che mi Ŕ venuta:
    =SE(SINISTRA(A2;1)="3";SOSTITUISCI(A2;SINISTRA(A2;3);SINISTRA(A2;3)&"-");SOSTITUISCI(A2;SINISTRA(A2;2);"0"&SINISTRA(A2;2)&"-"))
    Ultima modifica fatta da:ges; 20/08/15 alle 15:38
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se pu˛ sembrare improbabile, non pu˛ che essere quella giusta!

  3. #3
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    La prima che mi Ŕ venuta:
    =SE(SINISTRA(A2;1)="3";SOSTITUISCI(A2;SINISTRA(A2;3);SINISTRA(A2;3)&"-");SOSTITUISCI(A2;SINISTRA(A2;2);"0"&SINISTRA(A2;2)&"-"))
    Wooww! gess
    Complimenti,
    Comunque sono sicuro che ci sono tante altre soluzioni
    comunque sarebbe interessante vedere se qualcuno saprebbe personalizzare il formato del numero senza le formule ma con il formato cella
    ciao

  4. #4

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Verona Provincia
    EtÓ
    57
    Messaggi
    1017
    Versione Office
    .
    Likes ricevuti
    366
    Likes dati
    0
    mentre i numeri che non iniziano con il "3" si aggiunge lo zero davanti e il "dash" (segno meno) dopo il terzo carattere
    Quando chiedi fa presumere che i numeri di roma non siano presenti, altrimenti 65822 diverrebbe 065-822
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  5. #5
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Milano
    EtÓ
    54
    Messaggi
    781
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1

    telefono

    Buongiorno.





    Saluti
    Window 8.1 Excel 2013/2016

  6. #6

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Sardegna
    EtÓ
    37
    Messaggi
    4019
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Vedo che oggi vi state sbizzarendo con i quiz :)
    Purtroppo ho solo il cell a disposizione.... ma guarder˛ con gusto le soluzioni.

  7. #7

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Verona Provincia
    EtÓ
    57
    Messaggi
    1017
    Versione Office
    .
    Likes ricevuti
    366
    Likes dati
    0
    @Pitagora: mi sembra un po' troppo poco generalizzata!

    hai scritto manualmente due tipi di formule:

    per i numeri che iniziano per 3 hai scritto =TESTO(A2;"000-"&RIPETI(0;LUNGHEZZA(A2)-3))
    per i numeri che non iniziano per 3 hai scritto =TESTO(A2;"000-"&RIPETI(0;LUNGHEZZA(A2)-2))

    La formula deve essere uguale in tutte le celle, altrimenti finisce lo scopo del "gioco".

    P.S.: la prossima volta, per cortesia, scrivi le formule direttamente nel post, in modo da non costringere gli utenti a scaricare il file per vederle.

  8. #8
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Milano
    EtÓ
    54
    Messaggi
    781
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1
    Buona Sera

    =SE(SINISTRA(A2;1)="3";TESTO(A2;"000-"&(RIPETI(0;LUNGHEZZA(A2)-3)));TESTO(A2;"000-"&(RIPETI(0;LUNGHEZZA(A2)-2))))

    Saluti
    Window 8.1 Excel 2013/2016

  9. #9

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Verona Provincia
    EtÓ
    57
    Messaggi
    1017
    Versione Office
    .
    Likes ricevuti
    366
    Likes dati
    0
    Citazione Originariamente Scritto da Pitagora Visualizza Messaggio
    =SE(SINISTRA(A2;1)="3";TESTO(A2;"000-"&(RIPETI(0;LUNGHEZZA(A2)-3)));TESTO(A2;"000-"&(RIPETI(0;LUNGHEZZA(A2)-2))))
    Bravo Pitagora, l'idea di usare TESTO() Ŕ buona, la ripropongo rimaneggiata:
    Codice: 
    =TESTO(A2;"000-"&RIPETI(0;LUNGHEZZA(A2)-2-(SINISTRA(A2;1)="3")))
    Resta il problema dei prefissi per Roma, Milano e simili .....
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  10. #10
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da scossa Visualizza Messaggio
    Quando chiedi fa presumere che i numeri di roma non siano presenti, altrimenti 65822 diverrebbe 065-822
    Ciao Scossa
    credo che sia impossibile far capire ad excel che alcuni prefissi sono di due cifre (tipo Roma e Milano) e altri numeri fissi con 3/4 cifre
    per cui ho voluto rendere tutto meno complicato limitandomi ad avere i numeri fissi con lo zero davanti e tutti con tre cifre
    comunque ho visto tutte le vostre risposte che funzionano benissimo e appena ho un po di tempo me le studio tutte
    Ciao

Discussioni Simili

  1. Risposte: 2
    Ultimo Messaggio: 13/01/17, 17:25
  2. [Risolto] calcolare il totale tra numeri con segno negativo e numeri con segno positivo
    Di luigiflo nel forum Domande su Excel in generale
    Risposte: 35
    Ultimo Messaggio: 05/11/16, 19:53
  3. =MAX(di numeri in formato testo con C o F davanti) - es. C002121
    Di aldomattana nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 22/03/16, 09:28
  4. Trasformare il formato cella da formato data a formato normale
    Di para siempre nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 12/03/16, 01:23
  5. trasformare cella da formato testo a formato ora
    Di Silvio65 nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 16/01/16, 13:47

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •