Risultati da 1 a 7 di 7

Discussione: Nascondere valori con due condizioni



  1. #1
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Nascondere valori con due condizioni

    Ciao a tutti,
    grazie a Pitagora il mio precedente thread è stato risolto (Copiare valore più aggiornato):
    https://www.dropbox.com/s/khi585d6sweartn/integrale%20italianGestForm_V4%2Bforum.xlsm?dl=0


    La formula è la seguente:
    Codice: 
    =MAX(SE('2_Aggiornamenti'!A5:A24=Dashboard!C7;SE(VAL.NUMERO(SINISTRA('2_Aggiornamenti'!F5:Z24;RICERCA("_";'2_Aggiornamenti'!F5:Z24)-1)+0);SINISTRA('2_Aggiornamenti'!F5:Z24;RICERCA("_";'2_Aggiornamenti'!F5:Z24)-1)+0))))
    Ho aggiunto una condizione SE per non visualizzare i valori nulli:
    Codice: 
    =SE($D29="";"";MAX(SE('2_Aggiornamenti'!A5:A24=Dashboard!C7;SE(VAL.NUMERO(SINISTRA('2_Aggiornamenti'!F5:Z24;RICERCA("_";'2_Aggiornamenti'!F5:Z24)-1)+0);SINISTRA('2_Aggiornamenti'!F5:Z24;RICERCA("_";'2_Aggiornamenti'!F5:Z24)-1)+0))))
    Ma se volessi anche evitare il presentarsi del valore 00/01/1900 in assenza di aggiornamenti?




    Grazie in anticipo
    Gene

  2. #2
    L'avatar di D@nilo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Età
    45
    Messaggi
    1170
    Versione Office
    Excel 2010
    Likes ricevuti
    509
    Likes dati
    571

    Re: Nascondere valori con due condizioni

    io ho aggiunto un altro SE e sembra funzionare
    Codice: 
    =SE(SE($D29="";"";MAX(SE('2_Aggiornamenti'!A5:A24=Dashboard!C7;SE(VAL.NUMERO(SINISTRA('2_Aggiornamenti'!F5:Z24;RICERCA("_";'2_Aggiornamenti'!F5:Z24)-1)+0);SINISTRA('2_Aggiornamenti'!F5:Z24;RICERCA("_";'2_Aggiornamenti'!F5:Z24)-1)+0))))=DATA(1900;1;0);"";SE($D29="";"";MAX(SE('2_Aggiornamenti'!A5:A24=Dashboard!C7;SE(VAL.NUMERO(SINISTRA('2_Aggiornamenti'!F5:Z24;RICERCA("_";'2_Aggiornamenti'!F5:Z24)-1)+0);SINISTRA('2_Aggiornamenti'!F5:Z24;RICERCA("_";'2_Aggiornamenti'!F5:Z24)-1)+0)))))
    File Allegati File Allegati

  3. #3
    L'avatar di ggratis
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Lecce - Pisa
    Età
    45
    Messaggi
    737
    Versione Office
    Excel 2010
    Likes ricevuti
    257
    Likes dati
    215

    Re: Nascondere valori con due condizioni

    potresti farlo con la formattazione condizionale: se il valore della cella è 0, il colore del carattere è uguale a quello di sfondo.
    saluti
    GG

    ops! ciao Danilo non avevo visto la tua risposta

  4. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7124
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1298

    Re: Nascondere valori con due condizioni

    Ciao,
    selezioni l'intervallo J29:J50 e con la formattazione condiziona metti

    =$J29=0

    impostando come carattere il colore dello sfondo.

    EDIT: Ciao Danilo e Giuseppe, non avevo visto la vostra risposta.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  5. #5
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    779
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1

    Re: Nascondere valori con due condizioni

    Buona Sera

    Ho impostato la formattazione condizionale sulla formattazione personalizzata della data.
    Window 8.1 Excel 2013/2016

  6. #6
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    779
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1

    Re: Nascondere valori con due condizioni

    Buona Sera

    Ho impostato la formattazione condizionale sulla formattazione personalizzata della data.

    La vesione del file e' denominata V5

    Saluti
    File Allegati File Allegati
    Window 8.1 Excel 2013/2016

  7. #7
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Re: Nascondere valori con due condizioni

    [RISOLTO]

    Ciao e grazie a tutti.
    I suggerimenti di Giuseppe & Ges & Pitagora mi hanno confermato che il pensiero semplice è quello premiante.

    Mentre la soluzione di Danilo (non sapevo della possibilità del doppio SE) mi ha aggiunto una nuova freccia in faretra.

    Alla prossima.
    Gene

Discussioni Simili

  1. Risposte: 6
    Ultimo Messaggio: 28/01/17, 00:18
  2. [Risolto] Contare dei valori con delle condizioni
    Di Enniop nel forum Domande su Excel in generale
    Risposte: 15
    Ultimo Messaggio: 24/01/17, 18:54
  3. [Risolto] Come visualizzare o nascondere valori in una tabella selezionando voce da menù a tendina
    Di Brivido.xls nel forum Domande su Excel in generale
    Risposte: 25
    Ultimo Messaggio: 03/12/16, 21:19
  4. Restituire dei valori in base a piu condizioni
    Di Ale64 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 05/07/16, 22:36
  5. Conta valori con condizioni
    Di Giuliano nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 09/01/16, 13:14

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •