Risultati da 1 a 7 di 7

Discussione: Nascondere valori con due condizioni



  1. #1
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    LocalitÓ
    Milano
    EtÓ
    52
    Messaggi
    907
    Versione Office
    2010
    Likes ricevuti
    25
    Likes dati
    200

    Nascondere valori con due condizioni

    Ciao a tutti,
    grazie a Pitagora il mio precedente thread Ŕ stato risolto (Copiare valore pi¨ aggiornato):
    https://www.dropbox.com/s/khi585d6sweartn/integrale%20italianGestForm_V4%2Bforum.xlsm?dl=0


    La formula Ŕ la seguente:
    Codice: 
    =MAX(SE('2_Aggiornamenti'!A5:A24=Dashboard!C7;SE(VAL.NUMERO(SINISTRA('2_Aggiornamenti'!F5:Z24;RICERCA("_";'2_Aggiornamenti'!F5:Z24)-1)+0);SINISTRA('2_Aggiornamenti'!F5:Z24;RICERCA("_";'2_Aggiornamenti'!F5:Z24)-1)+0))))
    Ho aggiunto una condizione SE per non visualizzare i valori nulli:
    Codice: 
    =SE($D29="";"";MAX(SE('2_Aggiornamenti'!A5:A24=Dashboard!C7;SE(VAL.NUMERO(SINISTRA('2_Aggiornamenti'!F5:Z24;RICERCA("_";'2_Aggiornamenti'!F5:Z24)-1)+0);SINISTRA('2_Aggiornamenti'!F5:Z24;RICERCA("_";'2_Aggiornamenti'!F5:Z24)-1)+0))))
    Ma se volessi anche evitare il presentarsi del valore 00/01/1900 in assenza di aggiornamenti?




    Grazie in anticipo
    Gene

  2. #2
    L'avatar di D@nilo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    LocalitÓ
    Roma
    EtÓ
    45
    Messaggi
    1413
    Versione Office
    Excel 2010
    Likes ricevuti
    672
    Likes dati
    692

    Re: Nascondere valori con due condizioni

    io ho aggiunto un altro SE e sembra funzionare
    Codice: 
    =SE(SE($D29="";"";MAX(SE('2_Aggiornamenti'!A5:A24=Dashboard!C7;SE(VAL.NUMERO(SINISTRA('2_Aggiornamenti'!F5:Z24;RICERCA("_";'2_Aggiornamenti'!F5:Z24)-1)+0);SINISTRA('2_Aggiornamenti'!F5:Z24;RICERCA("_";'2_Aggiornamenti'!F5:Z24)-1)+0))))=DATA(1900;1;0);"";SE($D29="";"";MAX(SE('2_Aggiornamenti'!A5:A24=Dashboard!C7;SE(VAL.NUMERO(SINISTRA('2_Aggiornamenti'!F5:Z24;RICERCA("_";'2_Aggiornamenti'!F5:Z24)-1)+0);SINISTRA('2_Aggiornamenti'!F5:Z24;RICERCA("_";'2_Aggiornamenti'!F5:Z24)-1)+0)))))
    File Allegati File Allegati

  3. #3
    L'avatar di ggratis
    Clicca e Apri
    Data Registrazione
    Sep 2015
    LocalitÓ
    Lecce - Pisa
    EtÓ
    45
    Messaggi
    836
    Versione Office
    Excel 2010
    Likes ricevuti
    298
    Likes dati
    242

    Re: Nascondere valori con due condizioni

    potresti farlo con la formattazione condizionale: se il valore della cella Ŕ 0, il colore del carattere Ŕ uguale a quello di sfondo.
    saluti
    GG

    ops! ciao Danilo non avevo visto la tua risposta

  4. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Como
    EtÓ
    54
    Messaggi
    9942
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2564
    Likes dati
    1545

    Re: Nascondere valori con due condizioni

    Ciao,
    selezioni l'intervallo J29:J50 e con la formattazione condiziona metti

    =$J29=0

    impostando come carattere il colore dello sfondo.

    EDIT: Ciao Danilo e Giuseppe, non avevo visto la vostra risposta.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se pu˛ sembrare improbabile, non pu˛ che essere quella giusta!

  5. #5
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Milano
    EtÓ
    54
    Messaggi
    994
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    395
    Likes dati
    1

    Re: Nascondere valori con due condizioni

    Buona Sera

    Ho impostato la formattazione condizionale sulla formattazione personalizzata della data.
    Window 8.1 Excel 2013/2016

  6. #6
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Milano
    EtÓ
    54
    Messaggi
    994
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    395
    Likes dati
    1

    Re: Nascondere valori con due condizioni

    Buona Sera

    Ho impostato la formattazione condizionale sulla formattazione personalizzata della data.

    La vesione del file e' denominata V5

    Saluti
    File Allegati File Allegati
    Window 8.1 Excel 2013/2016

  7. #7
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    LocalitÓ
    Milano
    EtÓ
    52
    Messaggi
    907
    Versione Office
    2010
    Likes ricevuti
    25
    Likes dati
    200

    Re: Nascondere valori con due condizioni

    [RISOLTO]

    Ciao e grazie a tutti.
    I suggerimenti di Giuseppe & Ges & Pitagora mi hanno confermato che il pensiero semplice Ŕ quello premiante.

    Mentre la soluzione di Danilo (non sapevo della possibilitÓ del doppio SE) mi ha aggiunto una nuova freccia in faretra.

    Alla prossima.
    Gene

Discussioni Simili

  1. Risposte: 6
    Ultimo Messaggio: 27/01/17, 23:18
  2. [Risolto] Contare dei valori con delle condizioni
    Di Enniop nel forum Domande su Excel in generale
    Risposte: 15
    Ultimo Messaggio: 24/01/17, 17:54
  3. [Risolto] Come visualizzare o nascondere valori in una tabella selezionando voce da men¨ a tendina
    Di Brivido.xls nel forum Domande su Excel in generale
    Risposte: 25
    Ultimo Messaggio: 03/12/16, 20:19
  4. Restituire dei valori in base a piu condizioni
    Di Ale64 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 05/07/16, 21:36
  5. Conta valori con condizioni
    Di Giuliano nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 09/01/16, 12:14

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •