Risultati da 1 a 6 di 6

Discussione: =CONTA.PIÙ.SE ( del mese selezionato)



  1. #1
    L'avatar di Bruno
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Cireggio Italy
    Età
    66
    Messaggi
    141
    Versione Office
    2016 64 Bit
    Likes ricevuti
    38
    Likes dati
    6

    =CONTA.PIÙ.SE ( del mese selezionato)

    Ciao

    Con questa formula ottengo il risultato atteso.
    Codice: 
    =CONTA.PIÙ.SE($E$5:$BL$5;">=" & DATA($B$3;$B$2;1);$E$5:$BL$5;"<=" & FINE.MESE(DATA($B$3;$B$2;1);0);E6:BL6;1)
    vi chiedo se si può semplificare qualche passaggio.

    Allego un piccolo esempio
    File Allegati File Allegati

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1678
    Versione Office
    2010 PC
    Likes ricevuti
    895
    Likes dati
    184

    Re: =CONTA.PIÙ.SE ( del mese selezionato)

    ciao
    uno dei modi, in C6:
    =MATR.SOMMA.PRODOTTO((ANNO($E$5:$BL$5)=$B$3)*(MESE($E$5:$BL$5)=$B$2)*($E6:$BL6=COLONNE($C$6:C6)))
    e trascini fino a D8
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di Bruno
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Cireggio Italy
    Età
    66
    Messaggi
    141
    Versione Office
    2016 64 Bit
    Likes ricevuti
    38
    Likes dati
    6

    Re: =CONTA.PIÙ.SE ( del mese selezionato)

    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    ciao
    uno dei modi, in C6:
    =MATR.SOMMA.PRODOTTO((ANNO($E$5:$BL$5)=$B$3)*(MESE($E$5:$BL$5)=$B$2)*($E6:$BL6=COLONNE($C$6:C6)))
    e trascini fino a D8
    Grazie della soluzione che hai proposto
    Effettivamente non devendo filtrare dalla data alla data risulta più adatta.

  5. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301

    Re: =CONTA.PIÙ.SE ( del mese selezionato)

    Ciao a tutti,
    giusto per proporre un'alternativa, matriciale, in C6 da trascinare in basso:

    =SOMMA(--(ANNO($E$5:$BL$5)=$B$3)*(MESE($E$5:$BL$5)=$B$2)*(SE(E6:BL6=1;1)))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. #5
    L'avatar di Bruno
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Cireggio Italy
    Età
    66
    Messaggi
    141
    Versione Office
    2016 64 Bit
    Likes ricevuti
    38
    Likes dati
    6

    Re: =CONTA.PIÙ.SE ( del mese selezionato)

    Grazie ges

    Ho provato anche con questo metodo, ma ritengo ottimo nel mio caso quanto suggerito nel 2° Post

    =MATR.SOMMA.PRODOTTO((TESTO($E$5:$BL$5;"AAAA/M")=$B$4)*($E6:$BL6=1))

  7. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301

    Re: =CONTA.PIÙ.SE ( del mese selezionato)

    Ciao Bruno,
    la mia era solo un'alternativa, tu scegli quale vuoi.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

Discussioni Simili

  1. excel scalare ferie annuali mese mese ad ore
    Di babi66v nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 09/03/17, 14:26
  2. Ricerca giorni mancanti a fine mese e mese successivo
    Di pixartao nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 02/08/16, 15:08
  3. Cercare il prodotto nel foglio azienda selezionato dalla combobox
    Di Vincenzo Damiani nel forum Domande su Excel VBA e MACRO
    Risposte: 20
    Ultimo Messaggio: 09/07/16, 19:24
  4. Conteggio servizi personale mese per mese
    Di pinnighi nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 06/06/16, 16:20
  5. Valore Combobox uguale all'item selezionato
    Di cromagno nel forum Domande su Excel VBA e MACRO
    Risposte: 24
    Ultimo Messaggio: 19/12/15, 11:40

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •