Risultati da 1 a 4 di 4

Discussione: MATR.SOMMA.PRODOTTO per contare o sommare



  1. #1
    L'avatar di Baloon_50
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Milano - Italy
    Età
    67
    Messaggi
    3339
    Versione Office
    2013 PC
    Likes ricevuti
    483
    Likes dati
    49

    MATR.SOMMA.PRODOTTO per contare o sommare

    Gerardo,
    ho un piccolo dubbio su quanto dici nel secondo caso dell'EP39 (quello dei TEAM)
    tu scrivi :

    MATR.SOMMA.PRODOTTO(--($A$6:&A$25=F4;--($B$6:$B$25>$C$8:$C$25)) - (anche nelle altre celle)

    il mio dubbio è sui doppi segni meno che hai messo nella seconda parte (quelli che ho segnato in rosso) e cioè, essendo le due matrici dei numeri sono necessari?

    Grazie- ciao

    A volte basta usare parole inutili come “grazie” e “per favore” per rendere la vita più bella.
    (ELKonigsburg)
    Dice il saggio : "se vuoi essere aiutato devi metter l'allegato"
    (Nick Carter - Ten)
    Invia MPPM 

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Baloon_50 ben tornato
    grazie per la domanda però noto subito un tuo errore nel copia ed incolla della tua formula

    infatti in Verde di segnalo alcuni errori;

    =MATR.SOMMA.PRODOTTO(--($A$6:&A$25=F4;--($B$6:$B$25>$C$8:$C$25))

    =MATR.SOMMA.PRODOTTO(--($A$6:$A$25=F4);--($B$6:$B$25>$C$6:$C$25))

    il mio dubbio è sui doppi segni meno che hai messo nella seconda parte (quelli che ho segnato in rosso) e cioè, essendo le due matrici dei numeri sono necessari?
    per cercare di speigarmi al meglio questa formula è simile al CONTA.PIU.SE e non al SOMMA.PIU.SE solo che ovviamente queste funzioni non sopportano matrici ma Intervalli, però ti ho fatto il paragone per evidenziare il fatto che questa formula serve per CONTARE quando si incontrano dei criteri e non sommare il risultato dei criteri incontrati

    in questo esempio noterai che la prima matrice abbiamo tanti 1 e zero perche ho messo davanti la matrice meno meno --( (tradotti VERO o FALSO)
    che quando si incontrano con l'elemento corrispondente della 2a matrice la funzione MATR.SOMMA.PRODOTTO la moltiplica e la somma...
    esempio 1x1=1 1x0=0 0x1=0 per cui quando 1 incontra 1 me lo moltiplica e me lo somma e il risultato sarà il conteggio che soddisfa il criteri

    =MATR.SOMMA.PRODOTTO({1.0.0.0.0.0.0.0.0.0.1.0.0.0.0.0.0.0.0.0};--($B$6:$B$25>$C$6:$C$25))

    =MATR.SOMMA.PRODOTTO(--($A$6:$A$25=F4);{1.1.0.1.1.1.1.1.1.1.1.1.0.1.0.1.1.1.1.1})

    in questo caso il risultato è 2 (vedi in rosso 1x1=1 + 1x1=1 totale 2) infatti la funzione MATR.SOMMA.PRODOTTO vuol dire
    PRODOTTO (moltiplicare) SOMMA (sommare) e MATR. (matrici)


    se invece aggiungi una matrice senza meno meno --(
    esempio

    =MATR.SOMMA.PRODOTTO({1.0.0.0.0.0.0.0.0.0.1.0.0.0.0.0.0.0.0.0};($B$6:$B$25))


    =MATR.SOMMA.PRODOTTO(--($A$6:$A$25=F4);{117.108.74.99.85.83.115.98.114.107.82.79.66.96.63.90.114.89.102.114})

    1x117=117 + 1x 82= 82 Totale 199

    spero di essermi spiegato bene, comunque se qualcuno del forum volesse sovrapporsi alla mia spiegazione ben venga non siate timidi!!
    Ciao
    Invia MPPM 

  3. #3
    L'avatar di Baloon_50
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Milano - Italy
    Età
    67
    Messaggi
    3339
    Versione Office
    2013 PC
    Likes ricevuti
    483
    Likes dati
    49
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    per cercare di speigarmi al meglio questa formula è simile al CONTA.PIU.SE e non al SOMMA.PIU.SE solo che ovviamente queste funzioni non sopportano matrici ma Intervalli, però ti ho fatto il paragone per evidenziare il fatto che questa formula serve per CONTARE quando si incontrano dei criteri e non sommare il risultato dei criteri incontrati
    Sei stato molto esauriente, poi con l'esempio ho capito ancora di più :98:

    Grazie della spiegazione

    P.S.
    Non sapevo della possibilità di utilizzare un tag (#) per inserire del codice da adesso in poi, se mi capiterà l'occasione, lo farò

    A volte basta usare parole inutili come “grazie” e “per favore” per rendere la vita più bella.
    (ELKonigsburg)
    Dice il saggio : "se vuoi essere aiutato devi metter l'allegato"
    (Nick Carter - Ten)
    Invia MPPM 

  4. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da Baloon_50 Visualizza Messaggio
    Non sapevo della possibilità di utilizzare un tag (#) per inserire del codice da adesso in poi, se mi capiterà l'occasione, lo farò
    Baloon_50 questo forum viaggia su piattaforma vBullettin un softwear super veloce e completissimo si possono fare tante cosa senza contare gli eventuali Plag-in che potrei aggiungere se volessi altre impostazioni
    Ciao ballon continua cosi!!!
    Invia MPPM 

Discussioni Simili

  1. =MATR.SOMMA.PRODOTTO da convertire in conta.se
    Di bopo57 nel forum Domande su Excel in generale
    Risposte: 21
    Ultimo Messaggio: 04/10/16, 22:51
  2. MATR.SOMMA.Prodotto... un pò di teoria
    Di Beppe nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 29/05/16, 22:02
  3. Matr.somma.prodotto
    Di Khan nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 29/03/16, 13:33
  4. =matr.somma.prodotto()
    Di marigenny nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 11/11/15, 12:59
  5. matr.somma.prodotto
    Di Alessandro nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 19/10/15, 17:52

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •