Risultati da 1 a 12 di 12

Discussione: Problema funzione Cella Vuota con Indice e Confronta



  1. #1
    L'avatar di davide574
    Clicca e Apri
    Data Registrazione
    Aug 2016
    Località
    Milano
    Messaggi
    65
    Versione Office
    Office 2010/16
    Likes ricevuti
    0
    Likes dati
    4

    Problema funzione Cella Vuota con Indice e Confronta

    Ciao

    sono di nuovo qui. Mi ha suggerito di postare la nuova discussione.

    come avevo postato l'allegato in un altra discussione.
    Avevo inserito questa formula: =INDICE($N6:$AB6;CONFRONTA(9,99999999999999E+307;$N6:$AB6)-COLONNE(N6:$R6)+1) nella cella N36 e ahimè non funziona tanto bene. Anzichè di raccogliere le ultime 6 partite e invece ha lasciato vuoto nella cella come potrete vedere nelle celle gialle. Vedi allegato:

    alcune celle sono rimaste vuote mentre nella giornata numero 5 sono presenti i punteggi , sicuramente molto strano.
    mi interessa ad estrarre le ultime 6 partite casalinghe partendo dalla nuova giornata alla vecchia giornata.
    Grazie.
    File Allegati File Allegati

  2. #2
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    2302
    Versione Office
    Excel 2010
    Likes ricevuti
    911
    Likes dati
    451

    Re: Problema funzione Cella Vuota con Indice e Confronta

    Ciao Davide574,
    forse la formula in S36 è:
    =INDICE($N6:$AB6;CONFRONTA(9,99999999999999E+307;$N6:$AB6)-COLONNE(S6:S6)+1)

  3. I seguenti 2 utenti hanno dato un "Like" a Berna11 per questo post:


  4. #3
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Problema funzione Cella Vuota con Indice e Confronta

    Ciao Davide
    Un' altro approccio diverso dalla formula di Berna11()

    in N36
    =INDICE($N6:$AY6;AGGREGA(15;6;(RIF.COLONNA($N$6:$AY$6)-RIF.COLONNA($N$6)+1)/($N6:$AY6<>"");N$35))

    fai sapere!

    EDIT riferimenti di cella errati

  5. I seguenti 2 utenti hanno dato un "Like" a Gerardo Zuccalà per questo post:


  6. #4
    L'avatar di davide574
    Clicca e Apri
    Data Registrazione
    Aug 2016
    Località
    Milano
    Messaggi
    65
    Versione Office
    Office 2010/16
    Likes ricevuti
    0
    Likes dati
    4

    Re: Problema funzione Cella Vuota con Indice e Confronta

    ciao a voi due

    Berna: ti ringrazio ma copre solo la colonna s mentre mancano altre colonne da riempire.
    Gerardo: sei troppo genio, sono perfetti ma solo estrarre le prime sei partite mentre mi interessava le ultime 6 cioè nelle ultime partite man che man si aggiorna ogni giornata

  7. #5
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    2302
    Versione Office
    Excel 2010
    Likes ricevuti
    911
    Likes dati
    451

    Re: Problema funzione Cella Vuota con Indice e Confronta

    mentre nella giornata numero 5 sono presenti i punteggi
    ho dato per scontato che la formula esistente andava bene fino alla colonna 5 ed ho modificato la formula esistente aggiungendo la colonna S.

  8. #6
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    2302
    Versione Office
    Excel 2010
    Likes ricevuti
    911
    Likes dati
    451

    Re: Problema funzione Cella Vuota con Indice e Confronta

    Prova in N36 e trascina a destra ed in basso:

    =INDICE($N6:$AY6;CONFRONTA(9,99999999999999;$N6:$AY6)-COLONNE(N6:$S6)+1)

  9. #7
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1677
    Versione Office
    2010 PC
    Likes ricevuti
    895
    Likes dati
    184

    Re: Problema funzione Cella Vuota con Indice e Confronta

    ciao
    un'altro approccio potrebbe essere, in N36:
    =SCARTO($N6;;CERCA(2;1/($N6:$AY6<>"");RIF.COLONNA($N$6:$AY$6)-RIF.COLONNA($N$6)+1-COLONNE($N$36:N36));)
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  10. #8
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    203

    Re: Problema funzione Cella Vuota con Indice e Confronta

    Ciao a tutti

    riprendo la soluzione proposta da Gerardo:

    =INDICE($N6:$AY6;AGGREGA(14;6;RIF.COLONNA($N$6:$AY$6)-RIF.COLONNA($N$6)+1)/($N6:$AY6<>"");N$35))

    oppure

    =INDICE($N6:$AY6;AGGREGA(14;6;RIF.COLONNA($A:$AL)/($N6:$AY6<>"");N$35))

    copiando verso destra ottieni gli ultimi sei risultati a partire dal più recente.

    Saluti

  11. #9
    L'avatar di davide574
    Clicca e Apri
    Data Registrazione
    Aug 2016
    Località
    Milano
    Messaggi
    65
    Versione Office
    Office 2010/16
    Likes ricevuti
    0
    Likes dati
    4

    Re: Problema funzione Cella Vuota con Indice e Confronta

    grazie molto a tutti voi e ora sono fuori, quando sarò a casa e li proverò tutte le soluzioni. e vi farò sapere poi.

  12. #10
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Problema funzione Cella Vuota con Indice e Confronta

    Ciao a tutti
    Da quello che ho capito li vorrebbe visualizzati dalla sest'ultima (piena) fino all'ultima (piena) e non viceversa (forse)



    in N36 da confermare con CTRL+SHIFT+ENTER
    =INDICE(6:6;GRANDE(SE($N6:$AY6<>"";RIF.COLONNA($N6:$AY6));7-N$35))

    Oppure con L'AGGREGA visto che hai excel 2010 solo copia ed incolla
    =INDICE(6:6;AGGREGA(14;6;(RIF.COLONNA($N6:$AY6))/($N6:$AY6<>"");7-N$35))

    Davide fai sapere
    ciao

    EDIT praticamente la stessa formula di canapone ma ho modificato l'argomento (k) vedi modifica in rosso
    in pratica 7-1=6 (mi restituisce la sest'ultima colonna nella matrice)
    7-2=5 ( mi restituisce la quint'ultima colonna nella matrice ) e cosi via praticamente il (K) in questo modo mi inverte l'ordine anziche 1.2.3.4.5.6 (canapone) divenetrà 6.5.4.3.2.1

    Saluti








    Ultima modifica fatta da:Gerardo Zuccalà; 24/08/16 alle 14:27

  13. #11
    L'avatar di davide574
    Clicca e Apri
    Data Registrazione
    Aug 2016
    Località
    Milano
    Messaggi
    65
    Versione Office
    Office 2010/16
    Likes ricevuti
    0
    Likes dati
    4

    Re: Problema funzione Cella Vuota con Indice e Confronta

    Ciao a tutti

    Ho provato ad utilizzare tutte le vostre formule.
    Berna: rimane ancora sempre alcune celle vuote

    Ninai: non funziona cioè non estrae tutti i punteggi ma sballati tutti.

    Canapone: non so perché ma mi da gli errori #valore, mi piacerebbe a sapere perché mi da l’errore? Dove ho sbagliato? Perché mi interessa anche le tue formule per il futuro che mi potrebbe servire.

    Gerardo: perfetto , proprio come volevo.

    In excel, ho imparato qualcosa ma con grande fatica. Poi ho visto il VBA è ancora più difficile e complicato da imparare.
    Purtroppo sono negato a tutti e due perché se leggo e faccio fatica a capire ed invece se uno mi sta vicino e mi spiega davanti al monitor mi facilita a capire tutto.
    Negli ultimi mesi ho cercato qualcuno che mi potesse insegnare il VBA ma purtroppo non ci sono riuscito a trovare qualcuno.
    Ah dimenticavo, come avrete notato che non scrivo molto bene. Sono italianissimo ma solo che sono un sordo.
    Grazie ancora a tutti voi per la disponibilità a risolvere i miei problemi.
    ciao
    davide

  14. #12
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Problema funzione Cella Vuota con Indice e Confronta

    Grazie Davide per il riscontro e torna quando vuoi

    Un Saluto

Discussioni Simili

  1. Indice e confronta co SE(E(O(rif,rig(rrf.col))))
    Di Amerigo nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 21/09/16, 00:21
  2. Funzione indice/confronta all'interno della Funzione "O" ed "E"
    Di Rosaria79 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 28/06/16, 20:57
  3. Formule orari min e max in indice(confronta)
    Di Sasyjoe nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 15/03/16, 13:01
  4. Indice + Confronta con tre criteri non funziona
    Di MarcoM nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 09/10/15, 19:03
  5. Risposte: 16
    Ultimo Messaggio: 25/08/15, 10:05

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •