Risultati da 1 a 17 di 17

Discussione: MATR.SOMMA.PRODOTTO(INDICE;CONFRONTA) su un'unica cella con formula matriciale



  1. #1
    L'avatar di Beppe
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Brescia
    Età
    37
    Messaggi
    78
    Versione Office
    2010 Win
    Likes ricevuti
    1

    MATR.SOMMA.PRODOTTO(INDICE;CONFRONTA) su un'unica cella con formula matriciale

    Ciao a tutti i membri del Forum. Titolo forse un pò sviante,me ne scuso.
    Devo estrarre un valore da una cella ed ho usato senza problemi le funzioni INDICE-CONFRONTA(Grande accoppiata :98:)
    La formula, dato un valore di testo, mi restituisce un numero. Quello che mi interessa è il totale di questi numeri.
    Sul file allegato ho creato una tabella speculare dove ho estratto i numeri.Alla fine di ogni riga c'è il totale.
    DOMANDA: esiste una formula da mettere in AH2 e trascinare in basso che mi dia lo stesso risultato della cella AG2?
    Grazie. Ciao
    Ultima modifica fatta da:Gerardo Zuccalà; 24/08/15 alle 13:10
    Windows 7
    Office 2010

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    199
    Ciao

    in AG2 da copiare in basso

    =MATR.SOMMA.PRODOTTO(($AJ$2:$AJ$6=B2:AF2)*$AK$2:$AK$6)

    La formula è una specie di conta.se.

    Spero sia d'aiuto

  3. #3
    L'avatar di Beppe
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Brescia
    Età
    37
    Messaggi
    78
    Versione Office
    2010 Win
    Likes ricevuti
    1
    Grazie mille!
    Questa formulame la conservo gelosamente!!!!!!!
    Ultima modifica fatta da:Canapone; 06/02/17 alle 17:36
    Windows 7
    Office 2010

  4. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Ciao a tutti

    =MATR.SOMMA.PRODOTTO(CONTA.PIÙ.SE(B20:AF20;$AJ$2:$AJ$6);$AK$2:$AK$6)

    Giusto per condividere una alternativa alla ottima soluzione di Canapone (molto simile)
    Questa formula è un mio vero cavallo di battaglia anche se normalmente la uso solo per Contare le stringhe uguali (lettere)
    :166:

  5. #5

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1011
    Versione Office
    .
    Likes ricevuti
    364
    Likes dati
    0
    @Gerardo: essendoci una sola condizione basterebbe il CONTA.SE

    =MATR.SOMMA.PRODOTTO(CONTA.SE(B2:AF2;$AJ$2:$AJ$6);$AK$2:$AK$6)
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  6. #6

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1011
    Versione Office
    .
    Likes ricevuti
    364
    Likes dati
    0
    E una soluzione con CERCA.VERT() qualcuno ce l'ha? :288:
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  7. #7
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Citazione Originariamente Scritto da scossa Visualizza Messaggio
    @Gerardo: essendoci una sola condizione basterebbe il CONTA.SE

    =MATR.SOMMA.PRODOTTO(CONTA.SE(B2:AF2;$AJ$2:$AJ$6);$AK$2:$AK$6)
    Ciao Scossa
    Si si lo so....
    ho preso questa brutta abitudine sopratutto con la sorella SOMMA.PIU.SE che ha una sintassi più intuitiva =SOMMA.PIÙ.SE(int_somma; intervallo_criteri1; criteri1)

    però giustamente questa funzione è più adatta per i criteri (E) e quindi per non rendere questa formula ambigua da ora in avanti userò la funzione CONTA.SE o SOMMA.SE se il criterio è di tipo (O)
    Grazie Scossa

    PS ho provato con il CERCA.VERT ma è impossibile perchè non sopporta le matrici
    Dovrei fare 31 volte CERCA.VERT per poi sommare il tutto.......... ma non mi sembra il caso
    Ciao
    Ultima modifica fatta da:Gerardo Zuccalà; 24/08/15 alle 15:47

  8. #8
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    199
    Ciao a tutti,

    dopo avere ordinato la legenda in ordine alfabetico (#D M N P), CERCA può essere d'aiuto


    =MATR.SOMMA.PRODOTTO(CERCA(B2:AF2;AJ$2:AJ$6;AK$2:AK$6))


    Giusto per condividere altre soluzioni

  9. #9

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1011
    Versione Office
    .
    Likes ricevuti
    364
    Likes dati
    0
    PS ho provato con il CERCA.VERT ma è impossibile perchè non sopporta le matrici Dovrei fare 31 volte CERCA.VERT per poi sommare il tutto..........
    Hai provato poco o con poca convinzione :127:

    @Canapone: senza ordinare la legenda ed usando Cerca.Vert; è concessa una colonna di appoggio! :288:
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  10. #10
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Citazione Originariamente Scritto da scossa Visualizza Messaggio
    Hai provato poco o con poca convinzione :127:
    Mi arrendo :226:

  11. #11
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    199
    Ciao Scossa,

    mi arrendo anch'io.

  12. #12

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1011
    Versione Office
    .
    Likes ricevuti
    364
    Likes dati
    0
    Mi arrendo
    Eppure scommetto che ci siete andati molto vicino!

    In realtà non volevo sfidare nessuno ma volevo cogliere l'occasione per presentare una soluzione piuttosto "insolita", infatti il tipo di formula che propongo è nota anche come ISC (Insolita Somma Condizionale) ovvero, in inglese UCS (Unusual Conditional Sum) ed è una formula matriciale da confermare con ctrl+maiusc+invio

    =SOMMA(CERCA.VERT($B2:$AF2;$AJ$2:$AK$6;2;0))

    solo che ha un peculiarità: per fornire il risultato corretto deve essere inserita in due celle contigue, quindi selezioniamo AG2:AH2 digitiamo (o incolliamo) la formula e premiamo ctrl+maius+invio, et-voilà il risultato corretto ..... la colonna AH possiamo eventualmente nasconderla.

    P.S.: le ICS/UCS sono molto apprezzate dal nostro ninai :90:
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  13. #13
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    199
    Grazie Scossa,

    veramente interessante: è la prima volta che ne sento parlare.

    Saluti

  14. #14

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296
    Citazione Originariamente Scritto da scossa Visualizza Messaggio
    ..... volevo cogliere ....
    Nuova anche per me, grazie di avercela illustrata! :90:
    Ultima modifica fatta da:Canapone; 16/05/17 alle 16:11
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  15. #15
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    Le 'apprezzo" così tanto che me ne dimentico sempre l esistenza. Come di mediana(), frequenza(), spazio intersezione ecc.

  16. #16
    L'avatar di Beppe
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Brescia
    Età
    37
    Messaggi
    78
    Versione Office
    2010 Win
    Likes ricevuti
    1
    Citazione Originariamente Scritto da scossa Visualizza Messaggio
    Eppure scommetto ...
    non è che esiste una soluzione del genere anche con indice-confronta?
    Simpatica questa USC!!!
    Ultima modifica fatta da:Canapone; 16/05/17 alle 16:11
    Windows 7
    Office 2010

  17. #17

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1011
    Versione Office
    .
    Likes ricevuti
    364
    Likes dati
    0
    Citazione Originariamente Scritto da beppe
    non è che esiste una soluzione del genere anche con indice-confronta?
    Sì, ma devi usare Matr.Somma.Prodotto:
    Codice: 
    =MATR.SOMMA.PRODOTTO(INDICE($AK$2:$AK$6;CONFRONTA(B2:AF2;$AJ$2:$AJ$6;0)))
    sempre ICS, da inserire in due celle contigue e da confermare con ctrl+maiusc+invio.
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

Discussioni Simili

  1. [Risolto] Indice Confronta Aggrega matr.somma.prodotto in base a molteplici criteri
    Di Amerigo nel forum Domande su Excel in generale
    Risposte: 72
    Ultimo Messaggio: 05/02/17, 21:48
  2. Controllo formula MATR.SOMMA.PRODOTTO bis
    Di G.Bove nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 26/06/16, 08:06
  3. Controllo formula MATR.SOMMA.PRODOTTO
    Di G.Bove nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 21/06/16, 09:57
  4. =matr.somma.prodotto()
    Di marigenny nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 11/11/15, 12:59
  5. matr.somma.prodotto
    Di Alessandro nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 19/10/15, 17:52

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •