Risultati da 1 a 19 di 19

Discussione: Come usare bene la funzione Conta.se



  1. #1
    L'avatar di Sandler
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    italia
    Messaggi
    18
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0

    Come usare bene la funzione Conta.se

    Ciao a tutti...
    voi come fareste a contare quante celle della colonna Vendite ci sono che superano (come valore) quelle della colonna Target subito a destra?

    ho provato così: =INDICE($D$8:$D$19;CONFRONTA(CONTA.SE(E8:E19;">=E8,>=E9");0))

    sulla base di quanto appreso nel post precendete, ma non funziona...


    C
    D
    E
    7
    Mese Vendite Target
    8
    Gennaio 90 50
    9
    Febbraio 120 50
    10
    Marzo 25 50
    11
    Aprile 30 50
    12
    Maggio 67 50
    13
    Giugno 50 50
    14
    Luglio 68 50
    15
    Agosto 45 50
    16
    Settembre 80 50
    17
    Ottobre 35 50
    18
    Novembre 22 50
    19
    Dicembre 43 50
    Sheet: Foglio1

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1678
    Versione Office
    2010 PC
    Likes ricevuti
    895
    Likes dati
    184

    Re: Come usare bene la funzione Conta.se

    Sono al tel. Io userei matr
    Somma.prodotto(--((d8:d19)>(e8:e19)))
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. I seguenti 2 utenti hanno dato un "Like" a ninai per questo post:


  4. #3
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    2076
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117

    Re: Come usare bene la funzione Conta.se

    Ciao

    =SOMMA(SE(D8:D19>E8:E19;1;0))

    matriciale

    Ninai

    somma.prodotto io no lo trovo

    =SOMMA(--((D8:D19)>(E8:E19)))
    matriciale

    funziona

  5. I seguenti utenti hanno dato un "Like"


  6. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301

    Re: Come usare bene la funzione Conta.se

    Ciao,
    visto che MATR.SOMMA.PRODOTTO è stato già bruciato da ninai, che saluto, propongo questa:

    =SOMMA(SE(C2:C13>D2:D13;C2:C13))

    Matriciale

    EDIT: Gianfranco (un saluto) mi ha anticipato ... col cell sono più lento .. so usare un solo dito!
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  7. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301

    Re: Come usare bene la funzione Conta.se

    Citazione Originariamente Scritto da gianfranco55 Visualizza Messaggio
    ...
    Ninai

    somma.prodotto io no lo trovo

    ..a
    =matr.somma.prodotto((c2:c13>d2:d13)*(c2:c13))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  8. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301

    Re: Come usare bene la funzione Conta.se

    Se invece di sommare i numeri si vuole contare quanti valori della colonna C sono maggiori di quelli della colonna D, allora:

    =MATR.SOMMA.PRODOTTO((C2:C13>D2:D13)*1)

    oppure

    =CONTA.SE(C2:C13;">"&D2:D13)

    Edit: scusate se ho risposto in più messaggi ... sono col cell. e sono un poco impedito!
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  9. I seguenti utenti hanno dato un "Like"


  10. #7
    L'avatar di Sandler
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    italia
    Messaggi
    18
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Come usare bene la funzione Conta.se

    @ges
    La prima funziona, la seconda (conta.se) che è quella che mi interessa, no....

  11. #8

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4025
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923

    Re: Come usare bene la funzione Conta.se

    Citazione Originariamente Scritto da Sandler Visualizza Messaggio
    @ges
    La prima funziona, la seconda (conta.se) che è quella che mi interessa, no....
    Probabilmente la formula funziona nel file in cui è stata testata.
    Non avendo allegato alcun file d'esempio, sta a te adattare le formule per la tua situazione reale, oppure (cosa che avresti dovuto fare sin dall'inizio) allega il tuo file per poter testare le formule.

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  12. #9

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1022
    Versione Office
    .
    Likes ricevuti
    366
    Likes dati
    0

    Re: Come usare bene la funzione Conta.se

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    =CONTA.SE(C2:C13;">"&D2:D13)
    Ciao ges,

    dubito che il Conta.Se() funzioni correttamente ....

    In alternativa propongo:

    =SOMMA(INDICE(--(C2:C13>D2:D13);))
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  13. #10

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1022
    Versione Office
    .
    Likes ricevuti
    366
    Likes dati
    0

    Re: Come usare bene la funzione Conta.se

    Qui la spiegazione del perché Conta.Se() non funziona:

    F
    G
    H
    I
    J
    K
    L
    M
    N
    O
    P
    Q
    R
    S
    T
    U
    V
    1
    =CONTA.SE({1.1.1.1.1.1.7.8.9.10.11.12};">"&{0.6.6.6.6.6.6.6.6.6.6.6})
    2
    7
    12
    3
    0
    6
    6
    6
    6
    6
    6
    6
    6
    6
    6
    6
    4
    1
    0
    1
    1
    0
    0
    0
    0
    0
    0
    0
    0
    0
    0
    0
    1
    5
    1
    6
    1
    1
    0
    0
    0
    0
    0
    0
    0
    0
    0
    0
    0
    1
    6
    1
    6
    1
    1
    0
    0
    0
    0
    0
    0
    0
    0
    0
    0
    0
    1
    7
    1
    6
    1
    1
    0
    0
    0
    0
    0
    0
    0
    0
    0
    0
    0
    1
    8
    1
    6
    1
    1
    0
    0
    0
    0
    0
    0
    0
    0
    0
    0
    0
    1
    9
    1
    6
    1
    1
    0
    0
    0
    0
    0
    0
    0
    0
    0
    0
    0
    1
    10
    7
    6
    7
    1
    1
    1
    1
    1
    1
    1
    1
    1
    1
    1
    1
    12
    11
    8
    6
    8
    1
    1
    1
    1
    1
    1
    1
    1
    1
    1
    1
    1
    12
    12
    9
    6
    9
    1
    1
    1
    1
    1
    1
    1
    1
    1
    1
    1
    1
    12
    13
    10
    6
    10
    1
    1
    1
    1
    1
    1
    1
    1
    1
    1
    1
    1
    12
    14
    11
    6
    11
    1
    1
    1
    1
    1
    1
    1
    1
    1
    1
    1
    1
    12
    15
    12
    6
    12
    1
    1
    1
    1
    1
    1
    1
    1
    1
    1
    1
    1
    12
    16
    12
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  14. #11

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301

    Re: Come usare bene la funzione Conta.se

    Ciao scossa,
    hai ragione ... come ho detto sopra la formula l'avevo scritta dal cellulare e non ho avuto modo di testarla.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  15. #12

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1022
    Versione Office
    .
    Likes ricevuti
    366
    Likes dati
    0

    Re: Come usare bene la funzione Conta.se

    Citazione Originariamente Scritto da scossa Visualizza Messaggio
    F
    G
    H
    I
    J
    K
    L
    M
    N
    O
    P
    Q
    R
    S
    T
    U
    V
    1
    =CONTA.SE({1.1.1.1.1.1.7.8.9.10.11.12};">"&{0.6.6.6.6.6.6.6.6.6.6.6})
    Ovviamente:
    F
    G
    H
    I
    J
    K
    L
    M
    N
    O
    P
    Q
    R
    S
    T
    U
    V
    1
    '=CONTA.SE({1.1.1.1.1.1.7.8.9.10.11.12};{">0".">6".">6".">6".">6".">6".">6".">6".">6".">6".">6".">6"})
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  16. #13
    L'avatar di Sandler
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    italia
    Messaggi
    18
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Come usare bene la funzione Conta.se

    @cromagno
    non ho messo il file perchè ho usato il tool del forum per le tabelle....e poi sono in grado di modificare eventuali riferimenti diversi dal mio esempio...ma non era quello il problema come vedi.

    @scossa
    grazie del tuo aiuto.
    fermo restando che non ho capito il messaggio #10... a meno che il perchè riguardi il fatto che nella formula non è indicato il segno maggiore per ogni valore....
    a quel punto mi domando però se e come si possa fare indicando o l'intervallo e se non si può con conta.se capirne il motivo...anche con altri esempi volendo...

    grazie..

  17. #14

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1022
    Versione Office
    .
    Likes ricevuti
    366
    Likes dati
    0

    Re: Come usare bene la funzione Conta.se

    Citazione Originariamente Scritto da Sandler Visualizza Messaggio
    @scossa
    ...se non si può con conta.se capirne il motivo...
    il motivo mi sembrava fosse chiaro guardando la tabella riportata nel post #10: ho evidenziato su sfondo arancione il risultato che restituisce Conta.Se.

    Mentre
    Codice: 
    =SOMMA(INDICE(--(F4:F15>G4:G15);))
    equivale a
    Codice: 
    =SOMMA(INDICE({1.0.0.0.0.0.1.1.1.1.1.1};))
    e restituisce la somma dei valori della matrice;

    la formula con Conta.Se
    Codice: 
    =CONTA.SE(F4:F15;">"&G4:G15)
    equivale a
    Codice: 
    =CONTA.SE({1.1.1.1.1.1.7.8.9.10.11.12};{">0".">6".">6".">6".">6".">6".">6".">6".">6".">6".">6".">6"})
    ma restituisce solo la somma del confronto tra tutti i valori della matrice del primo parametro ({1.1.1.1.1.1.7.8.9.10.11.12}) con il primo valore del secondo parametro (">0"); in pratica equivale a:
    Codice: 
    =CONTA.SE(F4:F15;">"&G4)
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  18. #15
    L'avatar di Sandler
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    italia
    Messaggi
    18
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Come usare bene la funzione Conta.se

    Ok, deduco quindi che conta.se non fa quello che pensavo....
    Allora se i valori dell'intervallo G4:G15 sono popolati automaticamente come posso confrontarli e contare quindi quante volte un determinato valore è superiore rispetto ad un altro intervallo (ad es. F4:F15) se la
    funzione conta.se non va bene?

    al momento quelle funzionanti sono

    #messaggio 6
    =MATR.SOMMA.PRODOTTO((C2:C13>D2:D13)*1)

    e la tua del messaggio#9
    =SOMMA(INDICE(--(C2:C13>D2:D13);))

    sono le uniche vie, o ce ne possono essere altre ?

  19. #16

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1022
    Versione Office
    .
    Likes ricevuti
    366
    Likes dati
    0

    Re: Come usare bene la funzione Conta.se

    Citazione Originariamente Scritto da Sandler Visualizza Messaggio
    sono le uniche vie, o ce ne possono essere altre ?
    Sicuramente ce sono altre; "complicando" a piacere la formula ce ne possono essere infinite , ma che abbiano un senso - al momento - mi viene in mente solo:
    =CONTA.NUMERI(1/(F4:F15>G4:G15))
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  20. #17
    L'avatar di Sandler
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    italia
    Messaggi
    18
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Come usare bene la funzione Conta.se

    applicata al #1 non funziona...
    comunque ti ringrazio per l'aiuto...

    ciao

  21. #18

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1022
    Versione Office
    .
    Likes ricevuti
    366
    Likes dati
    0

    Re: Come usare bene la funzione Conta.se

    Citazione Originariamente Scritto da Sandler Visualizza Messaggio
    applicata al #1 non funziona...
    Ho dimenticato di precisare che è matriciale, devi confermarla con Ctrl+Maiusc+Invio anziché col solo invio.
    Ultima modifica fatta da:scossa; 27/08/16 alle 12:19 Motivo: editor
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  22. #19
    L'avatar di Sandler
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    italia
    Messaggi
    18
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Come usare bene la funzione Conta.se

    Funziona!

    uesta non la sapevo proprio...grazie!
    Ultima modifica fatta da:Canapone; 14/07/17 alle 14:39

Discussioni Simili

  1. [Risolto] CONTA.SE() e funzione E()
    Di marcob33 nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 02/02/17, 21:33
  2. [Risolto] Usare la Funzione Max() con Valori #N/D
    Di Allocco nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 18/01/17, 17:26
  3. usare funzione "giorno lavorativo" con frazioni di giorno
    Di CaesarIII nel forum Domande su Excel in generale
    Risposte: 16
    Ultimo Messaggio: 25/09/16, 00:23
  4. @licia da PM "Che funzione devo usare per calcolare la colonna guadagno?"
    Di aldomattana nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 01/02/16, 09:56
  5. usare una serie di celle come termine di una funzione (=, <, > ....)
    Di Serena nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 04/01/16, 08:31

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •