Risultati da 1 a 11 di 11

Discussione: Analisi dati



  1. #1
    L'avatar di ziolardo
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    roma
    Messaggi
    5
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    0

    Analisi dati

    Ciao a tutti,

    il mio quesito è il seguente: ho 10000 celle in una colonna, ogni cella ha uno di questi tre valori 1, 0 o -1, vorrei sapere se c'è una formula o un modo per sapere quante volte di seguito (intendo nella cella successiva) uno stesso valore si ripete per due volte, per tre volte, per quattro volte e via di seguito. Esempio, nella colonna A partendo da A2 ho: 1,1,0,0,-1,-1,-1,0,1,-1,-1,0,0,0,1...A10000 0, vorrei sapere quante volte il valore 1 è seguito dal valore 1 (nell'esempio una sola volta), quante volte il valore 0 è seguito dal valore 0 e quante volte dopo due 0 ce ne è un terzo 0 (nell'es una volta due 0 consecutivi e una volta tre 0 consecutivi).

    Grazie in anticipo, spero di essere stato chiaro.

  2. #2
    L'avatar di Marius44
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Catania
    Età
    73
    Messaggi
    3208
    Versione Office
    Excel2010
    Likes ricevuti
    625
    Likes dati
    155

    Re: Analisi dati

    Ciao
    Visto che sei nuovo del Forum, è gradita una presentazione QUI.
    Ti consiglio anche di leggere il “Regolamento” e di visitare la sezione “Annunci dello staff”.
    Buona permanenza.

    Sarebbe interessante "vedere" il tuo file (magari con poche righe/colonne per capirne la struttura) senza dati sensibili.
    Ciao,
    Mario

  3. #3
    L'avatar di ziolardo
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    roma
    Messaggi
    5
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    0

    Re: Analisi dati

    Ciao, scusa per l'errore, cercherò di seguire le regole.

    Ciao, Giulio.

  4. #4
    L'avatar di ziolardo
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    roma
    Messaggi
    5
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    0

    Re: Analisi dati

    Come da suggerimento di Marius44, allego il file xlsx.

    Ciao e grazie, Giulio.
    File Allegati File Allegati

  5. #5
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5

    Re: Analisi dati

    Ciao a tutti!

    Prima di tutto, non sono sicuro perché stai generando stringhe di testo dalle formule nella colonna B, invece di numerici, che rende le cose complicate.

    In primo luogo ti consiglio di cambiare queste formule, cioè in B2:

    =SE(A2>A3;1;SE(A2<A3;-1;SE(A2=A3;0)))

    invece di:

    =SE(A2>A3;"1";SE(A2<A3;"-1";SE(A2=A3;"0")))

    e copiare giù.

    Poi, se metti la sequenza desiderata (diciamo fino a una lunghezza massima di 5) nelle cellule D2:D5 (non e necessario che tutte queste cellule contengono un valore). Per esempio, in D2 1, in D3 0 e in D4 1.

    Allora, formula matriciale**

    =SOMMA(0+(MATR.PRODOTTO(0+(IDENTICO(NUM(SCARTO(B2;MATR.TRASPOSTA(RIF.RIGA(D2:D6)-1)+RIF.RIGA(B2:B51)-MIN(RIF.RIGA(B2:B51));));MATR.TRASPOSTA(D2:D6)));RIF.RIGA(D2:D6)^0)=CONTA.NUMERI(D2:D6)))

    File allegato.

    Saluti
    File Allegati File Allegati
    Advanced Excel Techniques: http://excelxor.com/

  6. I seguenti 5 utenti hanno dato un "Like" a Jos per questo post:


  7. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7125
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1298

    Re: Analisi dati

    Grande Jos
    Piacere di rileggerti!
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  8. #7
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5

    Re: Analisi dati

    Ciao, Ges!

    Sono contento di essere tornato!
    Advanced Excel Techniques: http://excelxor.com/

  9. I seguenti utenti hanno dato un "Like"


  10. #8
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5

    Re: Analisi dati

    Citazione Originariamente Scritto da Jos Visualizza Messaggio
    =SOMMA(0+(MATR.PRODOTTO(0+(IDENTICO(NUM(SCARTO(B2;MATR.TRASPOSTA(RIF.RIGA(D2:D6)-1)+RIF.RIGA(B2:B51)-MIN(RIF.RIGA(B2:B51));));MATR.TRASPOSTA(D2:D6)));RIF.RIGA(D2:D6)^0)=CONTA.NUMERI(D2:D6)))
    Infatti la parte in rosso non era accurata.

    È meglio:

    =SOMMA(0+(MATR.PRODOTTO(0+(IDENTICO(NUM(SCARTO(B2;MATR.TRASPOSTA(RIF.RIGA(D2:D6)-MIN(RIF.RIGA(D2:D6)))+RIF.RIGA(B2:B51)-MIN(RIF.RIGA(B2:B51));));MATR.TRASPOSTA(D2:D6)));RIF.RIGA(D2:D6)^0)=CONTA.NUMERI(D2:D6)))

    Saluti.
    Advanced Excel Techniques: http://excelxor.com/

  11. I seguenti 4 utenti hanno dato un "Like" a Jos per questo post:


  12. #9
    L'avatar di ziolardo
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    roma
    Messaggi
    5
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    0

    Re: Analisi dati

    Citazione Originariamente Scritto da Jos Visualizza Messaggio
    Infatti la parte in rosso non era accurata.

    È meglio:

    =SOMMA(0+(MATR.PRODOTTO(0+(IDENTICO(NUM(SCARTO(B2;MATR.TRASPOSTA(RIF.RIGA(D2:D6)-MIN(RIF.RIGA(D2:D6)))+RIF.RIGA(B2:B51)-MIN(RIF.RIGA(B2:B51));));MATR.TRASPOSTA(D2:D6)));RIF.RIGA(D2:D6)^0)=CONTA.NUMERI(D2:D6)))

    Saluti.
    Ciao,

    come prima cosa grazie per l'aiuto Jos, come avrai intuito ho conoscenze molto basiche di excel! volevo chiedere un paio di cose se posso approfittare del tuo aiuto, 1) cambiando la formula matriciale corretta da te nel file che hai allegato Ziolardo_Jos mi da #valore; 2) se volessi aumentare la sequenza a 6,7,8...100 cosa devo cambiare? il rif.riga da D2:D6 a D2:D101 se volessi verificare una sequenza di 100?

    Grazie ancora.

  13. #10
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5

    Re: Analisi dati

    Ciao, Giulio.

    Citazione Originariamente Scritto da ziolardo Visualizza Messaggio
    1) cambiando la formula matriciale corretta da te nel file che hai allegato Ziolardo_Jos mi da #valore
    Ti sei ricordato di (ri)confermarla con CTRL+MAIUSC+INVIO? Ogni volta che si cambia una formula matriciale si deve fare cosi.

    Citazione Originariamente Scritto da ziolardo Visualizza Messaggio
    2) se volessi aumentare la sequenza a 6,7,8...100 cosa devo cambiare? il rif.riga da D2:D6 a D2:D101 se volessi verificare una sequenza di 100?
    Precisamente.

    Saluti
    Advanced Excel Techniques: http://excelxor.com/

  14. I seguenti utenti hanno dato un "Like"


  15. #11
    L'avatar di ziolardo
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    roma
    Messaggi
    5
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    0

    Re: Analisi dati

    Grazie ancora,

    un saluto.

Discussioni Simili

  1. Procedura analisi dati
    Di Saymon nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 12/12/16, 20:13
  2. Analisi dei dati
    Di undiva nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 12/07/16, 09:59
  3. Analisi e Estrazione dati dinamica
    Di iea76 nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 02/05/16, 19:52
  4. Importazione file ed analisi dati
    Di G.Bove nel forum Domande su Excel in generale
    Risposte: 20
    Ultimo Messaggio: 13/12/15, 07:42
  5. Analisi dati
    Di Emanuele nel forum Domande su Excel in generale
    Risposte: 18
    Ultimo Messaggio: 18/08/15, 13:24

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •