Risultati da 1 a 13 di 13

Discussione: Tabella risultati test



  1. #1
    L'avatar di Ziamiki
    Clicca e Apri
    Data Registrazione
    Sep 2016
    LocalitÓ
    roma
    Messaggi
    5
    Versione Office
    Office 2016
    Likes ricevuti
    0
    Likes dati
    4

    Tabella risultati test

    Ciao, ho una tabella di risultati di un test, suddivisi per etÓ. Vorrei riuscire a immettere etÓ e risultato e ottenere il livello. Saprei farlo se ad ogni livello corrispondesse un solo valore, ma, ad esempio, a 15 anni il livello 2 corrisponde a tutti i valori tra 1180 e 1449. Potete aiutarmi,per favore?


  2. #2
    L'avatar di Irclen
    Clicca e Apri
    Data Registrazione
    Jul 2016
    LocalitÓ
    Quarrata
    EtÓ
    48
    Messaggi
    165
    Versione Office
    Office2016
    Likes ricevuti
    5
    Likes dati
    7

    Re: Tabella risultati test

    Benvenuta Ziamiki, hai illustrato bene il tuo quesito.
    Comunque ti consiglio di aggiungere un'immagine avatar al tuo profilo,
    prima che te lo facciano notare i moderatori. :)
    Buon proseguimento sul forum, vedrai che qualche esperto ti aiuta.
    "Tutto ci˛ che la tua mano trova da fare, fallo con la tua medesima potenza, poichÚ non cĺŔ lavoro nÚ disegno nÚ conoscenza nÚ sapienza nello Sceol, il luogo al quale vaiö (Dio)

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Milano
    EtÓ
    54
    Messaggi
    781
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1

    Re: Tabella risultati test

    Buon Giorno


    Allega il file non immagini.






    Indica il risultato che vuoi ottenere.






    Saluti
    Window 8.1 Excel 2013/2016

  5. #4
    L'avatar di Cuc¨^_^
    Clicca e Apri
    Data Registrazione
    Jun 2016
    LocalitÓ
    TrentoGallipoliTaranto
    EtÓ
    46
    Messaggi
    311
    Versione Office
    2010
    Likes ricevuti
    57
    Likes dati
    18

    Re: Tabella risultati test

    Tanto per diletto, scomodando VBA

    Codice: 
    Option Explicit
    Private Sub Worksheet_Change(ByVal Target As Range)
    Dim E As Variant, R As Variant
    Dim IE As Integer, Ur As Long
    Dim Cel As Range
    
    
    If Not Intersect(Target, Range("K3:K4")) Is Nothing And [K3] <> "" And [K4] <> "" Then
    [K5] = "NOT FOUND"
        E = [K3]
        R = [K4]
            Set Cel = Range("A1:G1").Find(E, LookIn:=xlValues, lookat:=xlWhole)
                If Not Cel Is Nothing Then
                    IE = Cel.Column
                    Ur = Cells(Rows.Count, IE).End(xlUp).Row
                        For Each Cel In Range(Cells(2, IE), Cells(Ur, IE))
                            If Cel.Value <= R And (Cel.Offset(1, 0).Value > R Or Cel.Offset(1, 0).Value = "") Then
                                [K5] = Cells(Cel.Row, 8).Value
                                Exit For
                            End If
                        Next Cel
                End If
    End If
    
    
    End Sub

  6. I seguenti 2 utenti hanno dato un "Like" a Cuc¨^_^ per questo post:


  7. #5

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Sardegna
    EtÓ
    37
    Messaggi
    4019
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923

    Re: Tabella risultati test

    Ciao a tutti,

    lato formule, nella cella K5:

    =SE((K3="")+(K4="");"";CERCA(SE(K4<500;500;K4);INDIRETTO(INDIRIZZO(2;CONFRONTA(K3;A1:G1;0))&":"&INDIRIZZO(5;CONFRONTA(K3;A1:G1;0)));H2:H5))


    allego il file (visto che la richiedente non si fa viva) per chi si vuole cimentare in altre soluzioni...
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno pu˛ immaginare."

  8. I seguenti 3 utenti hanno dato un "Like" a cromagno per questo post:


  9. #6
    L'avatar di Ziamiki
    Clicca e Apri
    Data Registrazione
    Sep 2016
    LocalitÓ
    roma
    Messaggi
    5
    Versione Office
    Office 2016
    Likes ricevuti
    0
    Likes dati
    4

    Re: Tabella risultati test

    Grazie a tutti, e scusate se non mi sono fatta viva prima... mi piacciono molto entrambe le soluzioni, , ora provo a studiarle per bene ;-)

  10. #7

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    LocalitÓ
    Cosenza
    EtÓ
    45
    Messaggi
    2808
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979

    Re: Tabella risultati test

    Giusto per partecipare:
    =SE(O(K3="";K4="");"";CONFRONTA(K4;SCARTO(A2;0;CONFRONTA(K3;A1:G1;0)-1;4);0))

  11. I seguenti 2 utenti hanno dato un "Like" a Rubik72 per questo post:


  12. #8
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Tabella risultati test

    Ciao a tutti
    Anch' io voglio partecipare

    =INDICE(H2:H5;CONFRONTA(K
    4;INDICE(A2:G5;;CONFRONTA(K3;A1:G1;0));1))

    B
    C
    D
    E
    F
    G
    H
    I
    J
    K
    1
    13
    14
    15
    16
    17
    18
    LIVELLO
    2
    500
    500
    500
    500
    500
    500
    1
    3
    1100
    1130
    1180
    1200
    1250
    1275
    2
    EtÓ
    18
    4
    1320
    1340
    1450
    1480
    1500
    1520
    3
    Risultato
    500
    5
    1540
    1550
    1600
    1650
    1670
    1700
    4
    Livello
    1



    EDIT
    In rosso

    Sono sicuro che ci sono altre soluzioni
    un saluto

  13. I seguenti 4 utenti hanno dato un "Like" a Gerardo ZuccalÓ per questo post:


  14. #9
    L'avatar di Ziamiki
    Clicca e Apri
    Data Registrazione
    Sep 2016
    LocalitÓ
    roma
    Messaggi
    5
    Versione Office
    Office 2016
    Likes ricevuti
    0
    Likes dati
    4

    Re: Tabella risultati test

    Wow! Grazie, siete fantastici!

  15. #10
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Tabella risultati test

    Citazione Originariamente Scritto da Ziamiki Visualizza Messaggio
    Wow! Grazie, siete fantastici!
    Grazie a te
    Ritorna quando vuoi, Ciao

  16. #11
    L'avatar di Ziamiki
    Clicca e Apri
    Data Registrazione
    Sep 2016
    LocalitÓ
    roma
    Messaggi
    5
    Versione Office
    Office 2016
    Likes ricevuti
    0
    Likes dati
    4

    Re: Tabella risultati test

    Ciao Rubik72, grazie per l'aiuto, forse per˛ ho sbagliato qualcosa perchŔ la formula mi restituisce #N/D

  17. #12

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Sardegna
    EtÓ
    37
    Messaggi
    4019
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923

    Re: Tabella risultati test

    Citazione Originariamente Scritto da Ziamiki Visualizza Messaggio
    Ciao Rubik72, grazie per l'aiuto, forse per˛ ho sbagliato qualcosa perchŔ la formula mi restituisce #N/D
    Ciao a tutti,

    provo a risponderti io....

    Nella formula di Rubik:
    =SE(O(K3="";K4="");"";CONFRONTA(K4;SCARTO(A2;0;CONFRONTA(K3;A1:G1;0)-1;4);0))

    devi cancellare lo 0 (zero) finale - lo zero sserve per cercare una corrispondenza esatta:
    =SE(O(K3="";K4="");"";CONFRONTA(K4;SCARTO(A2;0;CONFRONTA(K3;A1:G1;0)-1;4)))

    oppure sostituirlo con un 1 (uno) - se si omette lo zero, di default la funzione esegue una ricerca per "Minore di..." (cioŔ 1):
    =SE(O(K3="";K4="");"";CONFRONTA(K4;SCARTO(A2;0;CONFRONTA(K3;A1:G1;0)-1;4);1))

    Inoltre, (anche nella formula di Gerardo) sarebbe da implementare la situazione in cui il valore "Risultato" sia minore di 500, altrimenti non troverebbe la corrispondenza.
    Quindi, la formula di Rubik diventerebbe:
    =SE(O(K3="";K4="");"";CONFRONTA(SE(K4<500;500;K4);SCARTO(A2;0;CONFRONTA(K3;A1:G1;0)-1;4)))

    quelle di Gerardo:
    =INDICE(H2:H5;CONFRONTA(SE(K4<500;500;K4);INDICE(A2:G5;;CONFRONTA(K3;A1:G1;0));1))

    Ti riallego il file con le soluzioni...
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno pu˛ immaginare."

  18. I seguenti 2 utenti hanno dato un "Like" a cromagno per questo post:


  19. #13
    L'avatar di Ziamiki
    Clicca e Apri
    Data Registrazione
    Sep 2016
    LocalitÓ
    roma
    Messaggi
    5
    Versione Office
    Office 2016
    Likes ricevuti
    0
    Likes dati
    4

    Re: Tabella risultati test

    Grazie mille, sei gentilissimo!

Discussioni Simili

  1. Tabella risultati serie a
    Di Maurantz nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 15/03/17, 22:25
  2. [Risolto] Estrarre da una tabella risultati tramite 2 menu a tendina.
    Di svizzera nel forum Domande su Excel VBA e MACRO
    Risposte: 3
    Ultimo Messaggio: 26/01/17, 22:26
  3. Estrarre da una tabella risultati tramite 2 menu a tendina.
    Di svizzera nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 25/01/17, 14:14
  4. macro per creare una tabella dei risultati in funzione di due variabili
    Di kebenaz nel forum Domande su Excel VBA e MACRO
    Risposte: 1
    Ultimo Messaggio: 28/09/16, 16:48
  5. Variazione dei risultati da tabella a tabella...!?
    Di GioPL nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 28/12/15, 12:43

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •