Risultati da 1 a 11 di 11

Discussione: Ore settimanali con variante



  1. #1
    L'avatar di maxcerba
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    PADOVA
    Età
    44
    Messaggi
    24
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    2

    Ore settimanali con variante

    Ciao,
    anche grazie a questo forum sto perfezionando il mio modello excel per gli orari aziendali.
    Tutto fila liscio tranne che quando invece delle ore che ogni dipendente deve svolgere io inserisco M di malattia. Alla fine, il risultato della cella predisposta
    al calcolo delle ore mi restituisce # cioè un errore. Sto cercando di formattare le celle come numeri, come testo, come tutto ma dà sempre errore...
    Per esempio Mario rossi lunedì fa 6 ore, mercoledì 6 giovedì 5 e quindi il totale settimanale è 17.
    Luca che invece è in malattia, quindi metto M, M, M,M,M nel totale vedo #.
    Come posso ovviare?
    Grazie

    Max

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301

    Re: Ore settimanali con variante

    Ciao,
    che formula usi per sommare le ore?
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di maxcerba
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    PADOVA
    Età
    44
    Messaggi
    24
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    2

    Re: Ore settimanali con variante

    Codice HTML: 
    =AG14+AH14+AI14+AJ14+AK14+AL14+AM14+AN14+AO14+AP14+AQ14+AR14+AS14+AT14
    Eccolo qua

  4. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301

    Re: Ore settimanali con variante

    Ecco,
    cambiala con questa:

    =SOMMA(AG14:AT14)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  5. #5
    L'avatar di D@nilo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Età
    45
    Messaggi
    1170
    Versione Office
    Excel 2010
    Likes ricevuti
    509
    Likes dati
    572

    Re: Ore settimanali con variante

    Il file che ti allego a cui ho tolto tutte le macro e la formattazione condizionale lo uso per scrivere gli orari e avere la possibilità di inserire del testo nelle celle senza influire sul calcolo delle ore .....comunque ipotizzando in C6=in1 D6=out1
    C7=in2 D7=out2 (Entrata/Uscita esempio di lunedi) e cosi via per giorni della settimana nella cella dove calcoli il totale delle ore metti :
    Codice: 
    =SOMMA(SE(VAL.NUMERO(C6*D6*C7*D7)=VERO;RESTO(D6-C6+D7-C7;1);0);SE(VAL.NUMERO(E6*F6*E7*F7)=VERO;RESTO(F6-E6+F7-E7;1);0);SE(VAL.NUMERO(G6*H6*G7*H7)=VERO;RESTO(H6-G6+H7-G7;1);0);SE(VAL.NUMERO(I6*J6*I7*J7)=VERO;RESTO(J6-I6+J7-I7;1);0);SE(VAL.NUMERO(K6*L6*K7*L7)=VERO;RESTO(L6-K6+L7-K7;1);0);SE(VAL.NUMERO(M6*N6*M7*N7)=VERO;RESTO(N6-M6+N7-M7;1);0);SE(VAL.NUMERO(O6*P6*O7*P7)=VERO;RESTO(P6-O6+P7-O7;1);0))
    da modifcare se la griglia è strutturata diversamente


    ciao Ges non ti avevo letto
    File Allegati File Allegati

  6. #6
    L'avatar di maxcerba
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    PADOVA
    Età
    44
    Messaggi
    24
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    2

    Re: Ore settimanali con variante

    Quella formula funziona Ges, ma il cancelletto rimane. E Danilo, ti ringrazio ma quel file è troppo per me, almeno per ora.

  7. #7
    L'avatar di D@nilo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Età
    45
    Messaggi
    1170
    Versione Office
    Excel 2010
    Likes ricevuti
    509
    Likes dati
    572

    Re: Ore settimanali con variante

    non devi usare il file era solo un esempio... ma se vuoi calcolare ore e avere comunque la possibilità di scrivere orari o testo nelle stesse celle senza influire sul risultato (####) devi usare VALNUMERO se no allega un tuo file di esempio

  8. #8
    L'avatar di maxcerba
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    PADOVA
    Età
    44
    Messaggi
    24
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    2

    Re: Ore settimanali con variante

    Ok, eccolo qui il mio superbolide! Insomma il mio file...grazie per l'aiuto!
    File Allegati File Allegati

  9. #9

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301

    Re: Ore settimanali con variante

    Non capisco cosa vuoi ottenere con tutte quelle operazioni nelle righe nascoste.

    In ogni caso siccome in diverse occasioni sottrai le ore inserisci tu stesso le formule adatte facendo riferimento a QUESTA spiegazione, così almeno impari qualcosa.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  10. #10
    L'avatar di maxcerba
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    PADOVA
    Età
    44
    Messaggi
    24
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    2

    Re: Ore settimanali con variante

    In realtà il file è quello che mi ha dato l'azienda, sto cercando di pulirlo ma evidentemente non ho ancora finito..
    Ok do un occhio a quella pagina, grazie

  11. #11
    L'avatar di D@nilo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Età
    45
    Messaggi
    1170
    Versione Office
    Excel 2010
    Likes ricevuti
    509
    Likes dati
    572

    Re: Ore settimanali con variante

    Io cambierei la struttura inserendo gli orari con i due punti per togliere anche tutte quelle colonne nascoste comunque se lo devi lasciare cosi metti in AG10 =SE(VAL.NUMERO(D10*E10)=VERO;E10-D10;0)
    In AH10 =SE(VAL.NUMERO(F10*G10)=VERO;SE(G10<F10;G10+24-F10;G10-F10);0) e cosi via per tutti i giorni della settimana....guarda il file..


    P.S.in AF20 devi cambiare da =SOMMA(AG20:AT120) a =SOMMA(AG20:AT20)
    File Allegati File Allegati

Discussioni Simili

  1. [Risolto] variante raggruppa righe
    Di marco71 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 05/01/17, 13:07
  2. Problema sistema calcolo ore settimanali
    Di jacobrs nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 01/06/16, 18:15
  3. ottenere un database da classifiche settimanali
    Di morganaeuropa nel forum Domande su Excel in generale
    Risposte: 0
    Ultimo Messaggio: 02/02/16, 01:45
  4. Calendario Visualizza dati settimanali
    Di Allocco nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 26/01/16, 17:56
  5. Calcolo Ore Lavorative Mensili date le Ore Settimanali
    Di Pizzetto nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 15/10/15, 02:11

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •