Risultati da 1 a 5 di 5

Discussione: Ricerca dato in una colonna specifica tramite 2 condizioni



  1. #1
    L'avatar di Barchetta
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    51013
    Età
    45
    Messaggi
    80
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    8

    Ricerca dato in una colonna specifica tramite 2 condizioni

    Ciao a tutti,

    ho un file che mi arriva in automatico con 20 colonne e quasi 21000 righe (l'esempio in alleato ne ha meno per poterlo allegare) dove devo cercare un dato di una colonna specifica (la O) in base a due criteri, la colonna del cod (la A) e la colonna del MAG (la S). Avevo pensato di fare tutto tramite "indice" e "confronta" ma come al solito affogo in un bicchiere d'acqua.
    Allego esempio con la formula nel foglio 2 che errata tranne in B4 e non capisco perché.

    Mi potete aiutare a capire dove sbaglio?
    Grazie
    File Allegati File Allegati

  2. #2
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    2071
    Versione Office
    2016
    Likes ricevuti
    552
    Likes dati
    117

    Re: Ricerca dato in una colonna specifica tramite 2 condizioni

    ciao

    o
    Codice: 
    =MATR.SOMMA.PRODOTTO(--(Foglio1!$A$2:$A$46=A2);--(Foglio1!$S$2:$S$46=C2);(Foglio1!$O$2:$O$46))
    matriciale
    o
    Codice: 
    =INDICE(Foglio1!$O$2:$O$46;CONFRONTA(A2 &C2;INDICE(Foglio1!$A$2:$A$46& Foglio1!$S$2:$S$46;0);0))
    spero ti vadano bene

    io opterei per il secondo

  3. I seguenti utenti hanno dato un "Like"


  4. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7124
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1298

    Re: Ricerca dato in una colonna specifica tramite 2 condizioni

    Ciao a tutti,
    oltre alla soluzione di Gianfranco (che saluto), in maniera più semplice:

    =SOMMA.PIÙ.SE(Foglio1!O2:$O$46;Foglio1!A2:A46;A2;Foglio1!S2:S46;Foglio2!C2)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  5. I seguenti 2 utenti hanno dato un "Like" a ges per questo post:


  6. #4
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    2071
    Versione Office
    2016
    Likes ricevuti
    552
    Likes dati
    117

    Re: Ricerca dato in una colonna specifica tramite 2 condizioni

    Ges
    mi hai convertito al MAT.SOMMA.PRODOTTO
    e ora mi freghi il mio amato SOMMA.PIU.SE ?

    Ah! sai se a Ischia piove ancora?
    sono dispiaciuto per AL

  7. I seguenti utenti hanno dato un "Like"


  8. #5
    L'avatar di Barchetta
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    51013
    Età
    45
    Messaggi
    80
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    8

    Re: Ricerca dato in una colonna specifica tramite 2 condizioni

    Ciao, volevo ringraziare Gianfranco e Ges, per le loro soluzioni,GRAZIE INFINITE!
    Per la cronoca ho oprato per la indice e confronta.
    Grazie

Discussioni Simili

  1. Sommare valori in base a dato in colonna
    Di BaldoGiovane nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 14/03/17, 09:17
  2. [Risolto] Estrazione dato da colonna se soddisfa condizione in altra colonna
    Di bartolgi nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 13/03/17, 09:13
  3. [Risolto] ricerca ed inserimento dato
    Di stefanoste78 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 18/02/17, 02:37
  4. Risposte: 7
    Ultimo Messaggio: 12/11/16, 16:14
  5. Risposte: 11
    Ultimo Messaggio: 03/11/16, 16:54

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •