Risultati da 1 a 12 di 12

Discussione: Ricerca due condizioni nella medesima colonna e restituzione del dato presente in un'altra colonna



  1. #1
    L'avatar di Daniela
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    sondrio
    Messaggi
    49
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    15

    Ricerca due condizioni nella medesima colonna e restituzione del dato presente in un'altra colonna

    Buongiorno a tutti,
    avrei necessità di compilare i campi "DI CUI A", "DI CUI B" e "DI CUI C" della tabella riepilogativa presente sul foglio "RIEPILOGO" del file d'esempio allegato, i dati della tabella di riepilogo puntano tutti a una tabella pivot che viene aggiornata giornalmente a seguito dell'aggiornamento del foglio "DATI", di lato alla pivot in colonna E ho calcolato delle percentuali (non sono riuscita a farlo fare alla pivot perché non sono capace di bloccare il dato dei divisori B4-B8-B12 nel campo calcolato della pivot) che sono appunto i valori che dovrei ricercare.
    La formula dovrebbe ricercare nella tabella pivot ad esempio TOPOLINIA e A e restituirmi il valore presente nella colonna E e così per B e per C e per le altre città, ma non so proprio come fare, mi date qualche suggerimento per favore?
    Grazie mille!
    File Allegati File Allegati

  2. #2
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61

    Re: Ricerca due condizioni nella medesima colonna e restituzione del dato presente in un'altra colonna

    io la butto la...non ho ben capito...ma ci provo.
    in E2: =INDICE(PIVOT!$E$4:$E$15;CONFRONTA($A2;PIVOT!$A$4:$A$12;0)+1;)
    in F2: =INDICE(PIVOT!$E$4:$E$15;CONFRONTA($A2;PIVOT!$A$4:$A$12;0)+2;)
    in G2: =INDICE(PIVOT!$E$4:$E$15;CONFRONTA($A2;PIVOT!$A$4:$A$12;0)+3;)
    e trascini in giu.
    ciao
    ale

  3. #3
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Ricerca due condizioni nella medesima colonna e restituzione del dato presente in un'altra colonna

    Ciao Daniela
    senza usare la tua ottima pivot, ho fatto tutto con le formule

    in B2 del foglio "riepilogo" metti questa formula trascinala a destra e poi in basso fino alla bisogna
    =SOMMA.SE(DATI!$A$2:$A$10;$A2;DATI!C$2:C$10)


    in E2 del foglio "Riepilogo" metti questa formula e trascinala a destra ed in basso fino alla bisogna
    =SOMMA(MATR.SOMMA.PRODOTTO(--(DATI!$A$2:$A$10=$A2);--(DATI!$B$2:$B$10=DESTRA(E$1;1));DATI!$C$2:$C$10);MATR.SOMMA.PRODOTTO(--(DATI!$A$2:$A$10=$A2);--(DATI!$B$2:$B$10=DESTRA(E$1;1));DATI!$D$2:$D$10))


    in D2 metti questa formula e trascina in basso
    =C2/B2


    Fai sapere, ciao

    A
    B
    C
    D
    E
    F
    G
    1
    CITTA'
    Z
    K
    % RAGGIUNGIMENTO
    DI CUI A
    DI CUI B
    DI CUI C
    2
    TOPOLINIA
    137.461
    36.388
    26%
    75706,99
    8369,414
    89772,7
    3
    PAPEROPOLI
    942.456
    41.102
    4%
    583558,8
    127725,7
    272273,3
    4
    OCOPOLI
    417.297
    -7.757
    -2%
    292936,5
    11781,61
    104822,6

  4. #4
    L'avatar di Daniela
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    sondrio
    Messaggi
    49
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    15

    Re: Ricerca due condizioni nella medesima colonna e restituzione del dato presente in un'altra colonna

    Bello grazie funziona, non ci sarei mai arrivata, se ho capto giusto di fatto non gli fai ricercare due condizioni, ma gli dici di restituirti il valore del campo successivo, di due campi successivi e di 3, corretto?
    Citazione Originariamente Scritto da Alessandro Visualizza Messaggio
    io la butto la...non ho ben capito...ma ci provo.
    in E2: =INDICE(PIVOT!$E$4:$E$15;CONFRONTA($A2;PIVOT!$A$4:$A$12;0)+1;)
    in F2: =INDICE(PIVOT!$E$4:$E$15;CONFRONTA($A2;PIVOT!$A$4:$A$12;0)+2;)
    in G2: =INDICE(PIVOT!$E$4:$E$15;CONFRONTA($A2;PIVOT!$A$4:$A$12;0)+3;)
    e trascini in giu.
    ciao
    ale

  5. #5
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Ricerca due condizioni nella medesima colonna e restituzione del dato presente in un'altra colonna

    Ciao Daniela
    Giusto per curiosità hai provato le mie formule senza l'appoggio delle tabelle Pivot? credo che non le hai viste
    Un Saluto

  6. #6
    L'avatar di Daniela
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    sondrio
    Messaggi
    49
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    15

    Re: Ricerca due condizioni nella medesima colonna e restituzione del dato presente in un'altra colonna

    Eccomi, non ancora, ma voglio provare anche la tua proposta, soprattutto per imparare ad evitare di avere mille fogli concatenati tra di loro, adesso cerco di capire la logica delle tue formule perché devo apprendere altrimenti il vostro aiuto va perso ;-)Per ora grazie mille, poi ti faccio sapere se sono riuscita a far funzionare tutto
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    Ciao DanielaGiusto per curiosità hai provato le mie formule senza l'appoggio delle tabelle Pivot? credo che non le hai visteUn Saluto

  7. #7
    L'avatar di Daniela
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    sondrio
    Messaggi
    49
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    15

    Re: Ricerca due condizioni nella medesima colonna e restituzione del dato presente in un'altra colonna

    Ciao Gerardo, per quanto riguarda la tua prima formula "Somma.Se" è perfetta per evitare di fare la pivot e poi puntare alla pivot come facevo io, ma poi ho cercato di studiarmi la formula che mi hai proposto per recuperare i dati "di cui A", "di cui B" e "di cui C", ma credo sia impostata per fare una cosa diversa da quello che serve a me, nel senso che io voglio calcolare in quei campi la quota di "% raggiungimento" di A, di B e di C, per intenderci nella prima riga dove il raggiungimento è 26%, devono uscire 23% per A, 2% per B e 2% per C (il totale fa 27 per via degli arrotondamenti), come posso procedere? mi spiegheresti anche a cosa servono nella formula "--"? Grazie comunque per il tuo aiuto [QUOTE=Gerardo Zuccalà;39514]Ciao Danielasenza usare la tua ottima pivot, ho fatto tutto con le formule[/COLOR]in E2 del foglio "Riepilogo" metti questa formula e trascinala a destra ed in basso fino alla bisogna=SOMMA(MATR.SOMMA.PRODOTTO(--(DATI!$A$2:$A$10=$A2);--(DATI!$B$2:$B$10=DESTRA(E$1;1));DATI!$C$2:$C$10);MATR.SOMMA.PRODOTTO(--(DATI!$A$2:$A$10=$A2);--(DATI!$B$2:$B$10=DESTRA(E$1;1));DATI!$D$2:$D$10))in D2 metti questa formula e trascina in basso=C2/B2 Fai sapere, ciao]

  8. #8
    L'avatar di Daniela
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    sondrio
    Messaggi
    49
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    15

    Re: Ricerca due condizioni nella medesima colonna e restituzione del dato presente in un'altra colonna

    Buongiorno a tutti, qualcuno riesce a darmi un'indicazione su come posso risolvere il quesito sopra esposto per evitare di avere la pivot? Grazie mille!

  9. #9
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61

    Re: Ricerca due condizioni nella medesima colonna e restituzione del dato presente in un'altra colonna

    ciao dany,
    mi permetto di rispondere prima di gerardo (ciao, io ho aspettato).
    ho preso spunto dalla sua ritoccandola...
    Cmq prova questa sempre in E2 e poi trascini giu e a dx quanto basta.
    Codice: 
    =MATR.SOMMA.PRODOTTO(--(DATI!$A$2:$A$10=$A2);--(DATI!$B$2:$B$10=DESTRA(E$1;1));DATI!$D$2:$D$10)/SOMMA(MATR.SOMMA.PRODOTTO(--(DATI!$A$2:$A$10=$A2);DATI!$C$2:$C$10))
    sempre matriciale.
    ciao
    ale

  10. I seguenti utenti hanno dato un "Like"


  11. #10
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61

    Re: Ricerca due condizioni nella medesima colonna e restituzione del dato presente in un'altra colonna

    oppure,
    volendo farla non matriciale e accorciandola togliendo quei meno meno
    Codice: 
    =MATR.SOMMA.PRODOTTO((DATI!$A$2:$A$10=$A2)*(DATI!$B$2:$B$10=DESTRA(E$1;1))*DATI!$D$2:$D$10)/MATR.SOMMA.PRODOTTO((DATI!$A$2:$A$10=$A2)*(DATI!$C$2:$C$10))
    ciao
    ale

  12. I seguenti utenti hanno dato un "Like"


  13. #11
    L'avatar di Daniela
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    sondrio
    Messaggi
    49
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    15

    Re: Ricerca due condizioni nella medesima colonna e restituzione del dato presente in un'altra colonna

    Ottimo grazie, funziona! Mi spieghi però la logica delle "--"?
    Citazione Originariamente Scritto da Alessandro Visualizza Messaggio
    Cmq prova questa sempre in E2 e poi trascini giu e a dx quanto basta.
    Codice: 
    =MATR.SOMMA.PRODOTTO(--(DATI!$A$2:$A$10=$A2);--(DATI!$B$2:$B$10=DESTRA(E$1;1));DATI!$D$2:$D$10)/SOMMA(MATR.SOMMA.PRODOTTO(--(DATI!$A$2:$A$10=$A2);DATI!$C$2:$C$10))
    sempre matriciale.ciaoale

  14. #12
    L'avatar di Daniela
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    sondrio
    Messaggi
    49
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    15

    Re: Ricerca due condizioni nella medesima colonna e restituzione del dato presente in un'altra colonna

    Ho un'ultima domanda, ora che ho eliminato la pivot compilando la tabella direttamente con le formule suggerite (somma.se, somma.più.se....) è normale che quando ordino la tabella le formule si scombinino e così anche i risultati?

Discussioni Simili

  1. [Risolto] Estrazione dato da colonna se soddisfa condizione in altra colonna
    Di bartolgi nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 13/03/17, 09:13
  2. Risposte: 2
    Ultimo Messaggio: 30/01/17, 16:19
  3. Risposte: 9
    Ultimo Messaggio: 30/12/16, 19:41
  4. [Risolto] Ricerca ( e restituzione ) di un dato da due variabili nella stessa riga
    Di MaxMan nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 03/11/16, 22:44
  5. Ricerca dato in una colonna specifica tramite 2 condizioni
    Di Barchetta nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 08/09/16, 23:19

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •