Risultati da 1 a 6 di 6

Discussione: Conteggio con dei criteri in range parziali



  1. #1
    L'avatar di Tony70
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    gaeta
    Messaggi
    13
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    7

    Conteggio con dei criteri in range parziali

    Buongiorno a tutti i componenti del forum,
    Ho necessita di trovare una formula che mi conteggi i giorni, solo se nella colonna trova acquista o vendi, il ciclo deve essere continuo.
    Esempio
    se un ciclo di 10 giorni di acquista viene interrotto nel mezzo da un vendi il conteggio si deve interrompere e ricomiciare da zero.
    Allego un file forse è più semplice che spiegare.
    File Allegati File Allegati

  2. #2
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    863
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    63

    Re: Trading

    in F2 prova questa:
    =SE(D2=D1;"";SE(D2="Vendi";SE.ERRORE(CONFRONTA("Acquista";D2:D46;0)-1;CONTA.SE(D2:D46;"Vendi"));SE(D2="Acquista";SE.ERRORE(CONFRONTA("Vendi";D2:D46;0)-1;CONTA.SE(D2:D46;"Vendi")))))
    ciao
    ale

  3. I seguenti 4 utenti hanno dato un "Like" a Alessandro per questo post:


  4. #3
    L'avatar di Tony70
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    gaeta
    Messaggi
    13
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    7

    Re: Trading

    Grazie mille Ale, ho provato la formula e funziona benissimo senza alcun problema. Saluti.
    Ultima modifica fatta da:Canapone; 15/06/17 alle 08:07

  5. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1342

    Re: Trading

    Ciao a tutti

    Se vogliamo accorciare la formula possiamo fare cosi!

    in E2 metti questa formula matriciale*** e copiala in basso


    =SE(D2<>D1;CONFRONTA(VERO;D2:D1000<>D2;0)-1;"")




    *** le formule matriciali devono essere inserite utilizzando la combinazione della tastiera
    premendo CTRL, MAIUSC, INVIO (e non solo INVIO). Tenere premuto sia il tasto CTRL e il tasto MAIUSC poi premi INVIO.

    Fai Sapere
    Un Saluto
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  6. I seguenti 4 utenti hanno dato un "Like" a Gerardo Zuccalà per questo post:


  7. #5
    L'avatar di Tony70
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    gaeta
    Messaggi
    13
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    7

    Re: Trading

    Grazie Maestro e Complimenti per il forum, Ottimo forum molto utile per chi come me vuole imparare qualcosa su excel.
    Ho provato la formula matricale che mi hai indicato, sinceramente ho provato più volte ad inserirla ma per la mia poca attenzione dopo aver digitato la formula premevo invia e mi dava sempre errore N/D.
    Infine ci sono riuscito, la formula funziona perfettamente e senza intoppi.
    Unica cosa mi piacerebbe capirci qualcosa in più su queste formule un pò più complesse per me, se tante volte avete pubblicato qualche video inerente queste formule matricali se è possibile indicarle
    Grazie e Saluti
    Ultima modifica fatta da:Canapone; 15/06/17 alle 08:07

  8. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1342

    Re: Trading

    Citazione Originariamente Scritto da Tony70 Visualizza Messaggio
    Grazie Maestro e Complimenti per il forum, Ottimo forum molto utile per chi come me vuole imparare qualcosa su excel.
    Ho provato la formula matricale che mi hai indicato, sinceramente ho provato più volte ad inserirla ma per la mia poca attenzione dopo aver digitato la formula premevo invia e mi dava sempre errore N/D.
    Infine ci sono riuscito, la formula funziona perfettamente e senza intoppi.
    Unica cosa mi piacerebbe capirci qualcosa in più su queste formule un pò più complesse per me, se tante volte avete pubblicato qualche video inerente queste formule matricali se è possibile indicarle
    Grazie e Saluti
    Ciao Tony sono da cellulare
    Se fai una ricerca nel mio Canale YouTube sicuramente trovi qualcosa
    un salute
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

Discussioni Simili

  1. [Tutorial VBA] Range.End() - Range.OffSet() - Come operare sulle tabelle di dati
    Di dracoscrigno nel forum Imparando Excel & VBA - Tutorial di Excel-
    Risposte: 3
    Ultimo Messaggio: 29/03/17, 21:30
  2. [Risolto] Conteggio turni
    Di Red65 nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 05/01/17, 21:57
  3. [Risolto] Dichiarazione Range (Dim as range)
    Di camoncino nel forum Domande su Excel VBA e MACRO
    Risposte: 18
    Ultimo Messaggio: 08/11/16, 12:10
  4. Aggiornamento dati parziali in un foglio generale
    Di giesa15 nel forum Domande su Excel in generale
    Risposte: 36
    Ultimo Messaggio: 05/03/16, 18:59
  5. Conteggio Km
    Di claudiopsr nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 10/01/16, 16:56

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •