Risultati da 1 a 6 di 6

Discussione: Allineamento ad esclusione delle celle vuote



  1. #1
    L'avatar di BRAZ66
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    MILANO
    EtÓ
    51
    Messaggi
    172
    Versione Office
    Excel 2013
    Likes ricevuti
    5
    Likes dati
    53

    Allineamento ad esclusione delle celle vuote

    Buona serata a tutto il forum, mi ritrovo con questo problema :da una tabella di dati dovrei poter escludere le righe vuote ed partendo dal basso inserire tutte le righe con dati ....COMUNQUE HO MESSO UN FILE CHE MEGLIO SPIEGA L'ARCANO. Devo dire che la tabella diventerÓ dinamica e quindi soggetta a variazioni di celle piene e vuote,quidi avrei bisogno di una formula che funzioni per tutte le possibilitÓ. Rimango a vostra disposizione e vi ringrazio della vostra grande disponibilitÓ.
    File Allegati File Allegati

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Sardegna
    EtÓ
    38
    Messaggi
    4754
    Versione Office
    2013
    Likes ricevuti
    1502
    Likes dati
    1053

    Re: Allineamento ad esclusione delle celle vuote

    Ciao Braz,

    ho ancora qualche dubbio, comunque prova a mettere questa formula (matriciale) nella cella K92 (da copiare poi in basso e a destra..per tutte le tabelle):

    =SE.ERRORE(INDICE($K$57:$AG$86;CONFRONTA(GRANDE(SE.ERRORE(INDICE($K$57:$AG$86;;(MATR.SOMMA.PRODOTTO(--(RESTO(RIF.COLONNA($A$1:A1);8)=1))-1)*8+1);1*10^10);RIF.RIGA(A1));INDICE($K$57:$AG$86;;(MATR.SOMMA.PRODOTTO(--(RESTO(RIF.COLONNA($A$1:A1);8)=1))-1)*8+1);0);RIF.COLONNA(A1));"")


    ti riallego il file...
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno pu˛ immaginare."

  3. I seguenti 5 utenti hanno dato un "Like" a cromagno per questo post:


  4. #3
    L'avatar di BRAZ66
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    MILANO
    EtÓ
    51
    Messaggi
    172
    Versione Office
    Excel 2013
    Likes ricevuti
    5
    Likes dati
    53

    Re: Allineamento ad esclusione delle celle vuote

    Ciao CROMAGNO funziona perfettamente ,Ŕ quello che volevo ottenere. GRAZIE MILLE

  5. #4

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Sardegna
    EtÓ
    38
    Messaggi
    4754
    Versione Office
    2013
    Likes ricevuti
    1502
    Likes dati
    1053

    Re: Allineamento ad esclusione delle celle vuote

    Citazione Originariamente Scritto da BRAZ66 Visualizza Messaggio
    Ciao CROMAGNO funziona perfettamente ,Ŕ quello che volevo ottenere. GRAZIE MILLE
    Allora, meglio cosý....

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno pu˛ immaginare."

  6. #5
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    LocalitÓ
    Reggio Calabria
    EtÓ
    58
    Messaggi
    1375
    Versione Office
    Office 2013
    Likes ricevuti
    1419
    Likes dati
    2520

    Re: Allineamento ad esclusione delle celle vuote

    Ciao BRAZ66, un altro modo, alternativo alla proposta ottima e fulminea!!!!!! di Cromagno, che saluto calorosamente, potrebbe essere la seguente:

    In K92:
    =SE.ERRORE(AGGREGA(15;6;$K$57:$K$86;RIGHE($K92:$K$121));#NUM!)

    In S92:
    =SE.ERRORE(AGGREGA(15;6;$S$57:$S$86;RIGHE($K92:$K$121));#NUM!)

    In AA92:
    =SE.ERRORE(AGGREGA(15;6;$AA$57:$AA$86;RIGHE($K92:$K$121));#NUM!)
    tutte e tre da tirare gi¨.

    In L92:
    =SE.ERRORE(INDICE($K$6:$K$53;AGGREGA(15;6;(RIF.RIGA($L$6:$L$53)-RIF.RIGA($L$6)+1)/($L$6:$L$53=$K92);COLONNE($L$92:L$92)));"")

    In T92:
    =SE.ERRORE(INDICE($S$6:$S$53;AGGREGA(15;6;(RIF.RIGA($S$6:$S$53)-RIF.RIGA($S$6)+1)/($T$6:$T$53=$S92);COLONNE($T$92:T$92)));"")

    In AB92:
    =SE.ERRORE(INDICE($AA$6:$AA$53;AGGREGA(15;6;(RIF.RIGA($AA$6:$AA$53)-RIF.RIGA($AA$6)+1)/($AB$6:$AB$53=$AA92);COLONNE($AB$92:AB$92)));"")
    tutte e tre da trascinare verso destra e successivamente da tirare gi¨.

    Di nuovo saluti a tutti.

  7. I seguenti 5 utenti hanno dato un "Like" a pkrome59 per questo post:


  8. #6
    L'avatar di BRAZ66
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    MILANO
    EtÓ
    51
    Messaggi
    172
    Versione Office
    Excel 2013
    Likes ricevuti
    5
    Likes dati
    53

    Re: Allineamento ad esclusione delle celle vuote

    Un saluto PKROME59.....ho provato le tue formule e alla fine ho deciso di usarle sulle 49 tabelle che devo fare....GRAZIE A TE E CROMAGNO.

Discussioni Simili

  1. [Risolto] non conteggiare le celle vuote
    Di nick0573 nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 06/02/17, 23:48
  2. [Risolto] Allineamento posizione celle formula
    Di Samuela nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 11/10/16, 16:24
  3. [Risolto] Spostare valori su celle vuote
    Di Samuela nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 07/10/16, 14:42
  4. Come calcolare la media delle prime n celle non vuote in un intervallo?
    Di franzo62 nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 31/10/15, 08:06
  5. Dati nelle celle vuote
    Di nick0573 nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 02/08/15, 15:01

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •