Risultati da 1 a 6 di 6

Discussione: Ordinare in modo automatico ed in tempo reale



  1. #1
    L'avatar di Multicentrum
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Benevento
    Messaggi
    2
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    4

    Ordinare in modo automatico ed in tempo reale

    Ciao a tutti ragazzi! Scrivo il quesito risolto in parte: In excel nella colonna T voglio visualizzare, in tempo reale, i risultati della colonna D in modo decrescente dal più grande al più piccolo che, a sua volta, deve restare invariata nell'ordine. Questo come base, OK! Poi, se si può abbinare anche il cognome, all'ordine abbinato alla colonna T, male non è.
    Quello che sono riuscito a realizzare va bene, solo che il cursore dopo inserito il dato invece di andare avanti torna sempre nella cella D6. Vi allego il file con il database in questione, spero possiate delucidarmi, grazie mille!
    File Allegati File Allegati

  2. #2
    L'avatar di Catwoman
    Clicca e Apri
    Data Registrazione
    Aug 2016
    Località
    Tenerife
    Messaggi
    762
    Versione Office
    2013
    Likes ricevuti
    131
    Likes dati
    701

    Re: Ordinare in modo automatico ed in tempo reale

    Benvenuto Multicentrum ,
    i ragazzi sicuramente ti daranno una mano appena potranno.
    In attesa potresti passare a presentarti QUI e raccontarci un pò di te.
    Sii gentile quando possibile. È sempre possibile
    (Dalai Lama)

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: Ordinare in modo automatico ed in tempo reale

    Ciao Multicentrum, se ho capito bene, copia la seguente:

    In T6:
    =SE($D6=0;"";GRANDE($D$6:$D$86;RIGHE($T$6:$T6)))
    da tirare giù alla bisogna.
    Ciao.

  5. I seguenti utenti hanno dato un "Like"


  6. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: Ordinare in modo automatico ed in tempo reale

    Ciao, e un saluto a Dilly e a Pkrome,
    io ho inteso in un modo differente e cioè che serve una classifica con i nomi e pertanto ho messo questa due matriciali (si attivano con CTRL+Maiusc+INVIO):

    In T6:

    =INDICE($B$6:$B$86&" "&$C$6:$C$86;CONFRONTA(GRANDE(($K$6:$K$86+$P$6:$P$86)+($K$6:$K$86+$P$6:$P$86)/100;RIGHE($A$1:A1));($K$6:$K$86+$P$6:$P$86)+($K$6:$K$86+$P$6:$P$86)/100;0))

    In U6

    =SE.ERRORE(INDICE($K$6:$K$86+$P$6:$P$86;CONFRONTA(T6;$B$6:$B$86&" "&$C$6:$C$86;0));"")
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  7. I seguenti 3 utenti hanno dato un "Like" a ges per questo post:


  8. #5
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: Ordinare in modo automatico ed in tempo reale

    Ciao a tutti, altro modo per risolvere il problema, potrebbe essere il seguente:

    In U6:
    =SE(D6=0;"";GRANDE($D$6:$D$86;RIGHE($D$6:$D6)))

    In T6:
    =SE.ERRORE(INDICE($B$6:$B$86&" "&$C$6:$C$86;AGGREGA(14;6;(RIF.RIGA($B$6:$B$86)-RIF.RIGA($B$6)+1)/($D$6:$D$86=$U6);CONTA.SE($U$6:$U6;$U6)));"")

    entrambe da tirare giù alla bisogna.
    Allego il file di prova, fa sapere.
    Ciao a tutti.
    File Allegati File Allegati

  9. I seguenti 3 utenti hanno dato un "Like" a pkrome59 per questo post:


  10. #6
    L'avatar di Multicentrum
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Benevento
    Messaggi
    2
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    4

    Post Re: Ordinare in modo automatico ed in tempo reale

    Ciao! Ho risolto tramite la risposta di ges, funziona proprio come volevo! Grazie a tutti per le risposte!

Discussioni Simili

  1. Risposte: 6
    Ultimo Messaggio: 29/09/16, 23:54
  2. modo migliore per calcoli con if
    Di HelpMePlease nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 23/06/16, 13:58
  3. Inserire in modo automatico una Tabella dati excell in Outlook
    Di Emanuele nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 03/06/16, 19:30
  4. Una userform che popoli celle in tempo reale, non predeterminate
    Di nedevil nel forum Domande su Excel VBA e MACRO
    Risposte: 12
    Ultimo Messaggio: 25/02/16, 11:36
  5. ordinare in alfabetico in modo dinamico
    Di gigia2 nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 21/01/16, 15:36

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •