Risultati da 1 a 5 di 5

Discussione: raggruppa codici uguali



  1. #1
    L'avatar di Mauro L
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    torino
    Messaggi
    11
    Versione Office
    13
    Likes ricevuti
    0
    Likes dati
    2

    raggruppa codici uguali

    Mi piacerebbe che il file in automatico raggruppasse i codici uguali magari con l'aiuto di vba con un bel tasto
    grazie per il vs. aiuto
    File Allegati File Allegati
    Ultima modifica fatta da:cromagno; 18/09/16 alle 10:57

  2. #2

    L'avatar di alfrimpa
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Napoli
    Età
    64
    Messaggi
    6840
    Versione Office
    2013
    Likes ricevuti
    721
    Likes dati
    166

    Re: raggruppa codici uguali

    Un bel CONTA.SE?

    In I3

    Codice: 
    =CONTA.SE($B$3:$B$7;G3)
    .
    e ricopi in I4
    Alfredo

    "Non esistono cose facili o difficili; esistono cose che si sanno e cose che non si sanno"

    "Solo due cose sono infinite: l'universo e la stupidità umana; riguardo l'universo ho ancora dei dubbi" (Albert Einstein)

  3. I seguenti utenti hanno dato un "Like"


  4. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7183
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2067
    Likes dati
    1308

    Re: raggruppa codici uguali

    Ciao,
    lo faremo anche col vba con un bel tasto (come vuoi tu), intanto ti propongo una soluzione con le formule:

    in G3 da tirare in basso:

    =SE.ERRORE(INDICE($B$3:$B$1000;CONFRONTA(0;INDICE(CONTA.SE($G$2:G2;$B$3:$B$1000&""););0));"")

    EDIT: Ciao Alfredo non ti avevo visto.

    Dimenticavo, in I3 da tirare in basso:

    =CONTA.SE($B$3:$B$1000;G3)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  5. I seguenti 2 utenti hanno dato un "Like" a ges per questo post:


  6. #4
    L'avatar di Mauro L
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    torino
    Messaggi
    11
    Versione Office
    13
    Likes ricevuti
    0
    Likes dati
    2

    Re: raggruppa codici uguali

    direi come al solito perfetto e puntuale, complimenti e grazie delle tue formule, direi magiche!

  7. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7183
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2067
    Likes dati
    1308

    Re: raggruppa codici uguali

    Grazie del riscontro, a presto.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

Discussioni Simili

  1. [Risolto] codici a barre
    Di pagui nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 11/01/17, 19:40
  2. [Risolto] variante raggruppa righe
    Di marco71 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 05/01/17, 13:07
  3. [Risolto] Ottimizzazioni codici VBA
    Di G.Bove nel forum Domande su Excel VBA e MACRO
    Risposte: 26
    Ultimo Messaggio: 12/11/16, 16:41
  4. Raggruppa struttura
    Di broadband nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 12/03/16, 18:22
  5. [Risolto] codici unici
    Di Stefano nel forum Domande su Excel in generale
    Risposte: 17
    Ultimo Messaggio: 26/10/15, 15:42

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •