Risultati da 1 a 5 di 5

Discussione: Somma condizionata a certi valori in una cella



  1. #1
    L'avatar di andre
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Napoli
    Età
    29
    Messaggi
    33
    Versione Office
    Excel 2010
    Utile ricevuti
    1

    Somma condizionata a certi valori in una cella

    Ciao a tutti

    Ho di fronte a me una tabella (tabella 1) con valori in colonne D,E,F che dovranno essere sommati se, i dati presenti nelle celle in colonne B,C della Tabella 2 sono uguali a quelli della Tabella 1, la tabella guida o di controllo. La tabella 1, però come vedete, per i dati in Colonna A, si parla solo per la prima parte di essi con quella della Tabella 2, nel senso che, soltanto la prima parte dei dati presenti nella cella è utile mentre la colonna B non ha problemi con il numero di caratteri.

    Pensavo di seguire una via, tramite delle Pivot e poi cercare di chiudere con dei SUMIFs, o agire direttamente con i SUMIFs, voi cosa ne pensate ?
    File Allegati File Allegati

  2. #2

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2180
    Versione Office
    Excel 2013
    Utile ricevuti
    826
    Utile dati
    726

    Re: Somma condizionata a certi valori in una cella

    se ho capito bene:
    per sommare le colonne D:E
    =SOMMA(($B$3:$B$10=A15)*($D$3:$E$10))

    per sommare la colonna F
    =SOMMA(($B$3:$B$10=A15)*($F$3:$F$10))

    da inserire con CTRL+SHIFT+ENTER

  3. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    4885
    Versione Office
    2011MAC 2016WIN
    Utile ricevuti
    1615
    Utile dati
    1020

    Re: Somma condizionata a certi valori in una cella

    Ciao,
    vedo che hai messo in I14, I15 e I16 la somma solo delle colonne D ed E e a parte la somma dell'ultima colonna F, se è così:

    in I14, la seguente formula da trascinare in basso:

    =MATR.SOMMA.PRODOTTO(($B$3:$B$10=A15)*($C$3:$C$10=B15)*($D$3:$E$10))

    in J4:

    =MATR.SOMMA.PRODOTTO(($B$3:$B$10=A15)*($C$3:$C$10=B15)*($F$3:$F$10))

    Se invece, come hai scritto nella richiesta vuoi la somma delle tre colonne (D,E,F), allora in I14, questa:

    =MATR.SOMMA.PRODOTTO(($B$3:$B$10=A15)*($C$3:$C$10=B15)*($D$3:$F$10))


    EDIT: Ciao Rubik, scusa, non avevo visto la tua risposta
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  4. #4
    L'avatar di andre
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Napoli
    Età
    29
    Messaggi
    33
    Versione Office
    Excel 2010
    Utile ricevuti
    1

    Re: Somma condizionata a certi valori in una cella

    Grazie molte per il vostro contributo . Sopratutto per la repentinità. Che esiste.

  5. #5

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2180
    Versione Office
    Excel 2013
    Utile ricevuti
    826
    Utile dati
    726

    Re: Somma condizionata a certi valori in una cella

    Grazie del riscontro (non ci speravo più).
    Torna quando vuoi.

Discussioni Simili

  1. VBA Colorazione righe condizionata a valori testuali da colonna
    Di capibomb nel forum Domande su Excel VBA e MACRO
    Risposte: 14
    Ultimo Messaggio: 11/02/17, 01:32
  2. Somma valori per colore della cella.
    Di mauri73 nel forum Domande su Excel VBA e MACRO
    Risposte: 9
    Ultimo Messaggio: 15/01/17, 14:58
  3. estrazione condizionata dati e somma valori per ogni singolo cliente
    Di GioPL nel forum Domande su Excel VBA e MACRO
    Risposte: 4
    Ultimo Messaggio: 19/07/16, 14:26
  4. MACRO: una somma "dinamica" in una cella che mi salvi tale somma ogni 24 ore
    Di armandino nel forum Domande su Excel VBA e MACRO
    Risposte: 7
    Ultimo Messaggio: 15/10/15, 20:36
  5. Somma condizionata
    Di Sasyjoe nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 22/09/15, 18:01

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •