Risultati da 1 a 13 di 13

Discussione: Come scorrere le celle di excel data una somma, facendo un incremento



  1. #1
    L'avatar di rossgu94
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Bologna
    Età
    22
    Messaggi
    6
    Versione Office
    excel 2007
    Mi Piace ricevuti
    1

    Exclamation Come scorrere le celle di excel data una somma, facendo un incremento

    Ciao a tutti!
    Sto cercando una formula di excel per poter scorrere le celle con un incremento a partire da una somma! Cioè data una somma, per esempio "=somma(c10:c20)", come faccio a scorrere in basso la casella in modo tale che la somma aumenti sempre di una costante, per esempio di 100? Cioè data la prima casella "=somma(c10:c20)", che la seconda casella sia "=somma(c121:c131)", che la terza sia "=somma(c232:c242)", che la quarta sia "=somma(c343:c353)" ecc semplicemente scorrendo verso il basso le celle? (Senza quindi scrivere volta per volta la formula)
    Grazie preventivamente! :)

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    48
    Messaggi
    5128
    Versione Office
    Office 2013
    Mi Piace ricevuti
    828
    Mi Piace dati
    805

    Re: Come scorrere le celle di excel data una somma, facendo un incremento

    Ciao Rossgu94, benvenuto in forumexcel.it
    Prova ad inserire un piccolo allegato (senza dati sensibili) cosi da poterci lavorare direttamente, e poi se puoi scrivere il risultato a mano cosi da avere la tua domanda inequivocabile..

    Ross
    Essendo questa la tua prima volta che scrivi in questo forum ti consiglio di leggerti il “Regolamento” e a visitare la sezione “Annunci dello staff”, in ultimo ti consiglio di mettere una immagine avatar (quadrata) che meglio ti identifica
    Cordiali saluti e buona continuazione nel forum!.

    Non mandate messaggi privati per problemi di excel, usate il forum per rishieste di aiuto
    Scarica il nuovo Add-ins per inserire griglie ed intervalli di Excel con il BBCode Clicca qui

  3. #3
    L'avatar di rossgu94
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Bologna
    Età
    22
    Messaggi
    6
    Versione Office
    excel 2007
    Mi Piace ricevuti
    1

    Re: Come scorrere le celle di excel data una somma, facendo un incremento

    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    Ciao Rossgu94, benvenuto in forumexcel.it
    Prova ad inserire un piccolo allegato (senza dati sensibili) cosi da poterci lavorare direttamente, e poi se puoi scrivere il risultato a mano cosi da avere la tua domanda inequivocabile..

    Ross
    Essendo questa la tua prima volta che scrivi in questo forum ti consiglio di leggerti il “Regolamento” e a visitare la sezione “Annunci dello staff”, in ultimo ti consiglio di mettere una immagine avatar (quadrata) che meglio ti identifica
    Cordiali saluti e buona continuazione nel forum!.
    Grazie del benvenuto! scrivo la domanda in modo più specifico mettendo anche l'allegato e vi ringrazio intanto per l'aiuto.

    Allora intanto si tratta di dati riguardanti la popolazione del Friuli-Venezia Giulia, che devo aggregare in base al codice del comune di appartenenza. Le prime aggregazioni le ho scritte a mano ma poi mi sono resa conto che fatte così il lavoro è molto lungo e soprattutto rischio di cadere in errore. (in più casi mi è capitato infatti di dover correggere o cancellare e quindi perdere tempo).

    In sostanza devo aggregare la popolazione di 65 anni e più suddivisi per sesso (maschi, femmine e totale). La prima somma che conta la popolazione maschile di 65 anni e più del comune 30001 è dato da "=SOMMA(C8:C43)".
    La seconda somma dei dati, che si riferiscono al comune 30002, è dato da "=SOMMA(C109:C144)" (quindi è dato dalla formula precedentemente scritta aumenatate le coordinate di 101) e cosi via via le altre celle.

    Esiste un modo veloce per farlo senza scrivere la somma formula per formula? (come potete vedere il file è molto grande e impazzirei a farlo a mano) Il file che ho inserito qui è circa la metà del file originale che era troppo grande per poterlo inserire tutto. (in più ho utilizzato un filtro che mi faccia vedere i dati che parto dal 1950 o prima in modo tale da visualizzare solamente chi ha più di 65 anni di età)

    Vi ringrazio!
    File Allegati File Allegati

  4. #4
    L'avatar di Dillina
    Clicca e Apri
    Data Registrazione
    Aug 2016
    Località
    Tenerife
    Messaggi
    1165
    Versione Office
    2013
    Mi Piace ricevuti
    143
    Mi Piace dati
    592

    Re: Come scorrere le celle di excel data una somma, facendo un incremento

    Benvenuta Rossgu!
    Normalmente ci si presenta in QUESTA sezione.
    Ti aspetto cos¡ ci racconti qualcosa di te!
    Sii gentile quando possibile. È sempre possibile
    (Dalai Lama)

  5. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    3977
    Versione Office
    2011/2016MAC
    Mi Piace ricevuti
    1252
    Mi Piace dati
    752

    Re: Come scorrere le celle di excel data una somma, facendo un incremento

    Ciao Ross (e un saluto a Dilly),
    invece che le somme per celle alterne, se ho capito bene la tua richiesta, ti suggerisco questa formula, da mettere in B8 trascinandola a destra e in basso:

    =MATR.SOMMA.PRODOTTO((C$8:C$4891)*($A$8:$A$4891=$G8)*(--ANNO(OGGI())-$B$8:$B$4891>65))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. I seguenti 3 utenti hanno dato un MI Piace a ges per questo post:


  7. #6
    L'avatar di rossgu94
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Bologna
    Età
    22
    Messaggi
    6
    Versione Office
    excel 2007
    Mi Piace ricevuti
    1

    Re: Come scorrere le celle di excel data una somma, facendo un incremento

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ciao Ross (e un saluto a Dilly),
    invece che le somme per celle alterne, se ho capito bene la tua richiesta, ti suggerisco questa formula, da mettere in B8 trascinandola a destra e in basso:

    =MATR.SOMMA.PRODOTTO((C$8:C$4891)*($A$8:$A$4891=$G8)*(--ANNO(OGGI())-$B$8:$B$4891>65))
    Ti ringrazio tantissimo! Non sarei mai arrivata ad una formula del genere da sola!
    Ne approfitto per un'altra piccola domanda: nel caso in cui volessi trovare anche le persone di 95 anni e più basta che cambi la formula sostituendo >65 con >95? Grazie mille per la disponibilità.

    Comunque ho scritto nell'area di presentazione, mi fa piacere conoscervi!

  8. I seguenti utenti hanno dato un "Mi Piace"


  9. #7
    L'avatar di Powerwin
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Milano
    Messaggi
    514
    Versione Office
    2010
    Mi Piace ricevuti
    79
    Mi Piace dati
    32

    Re: Come scorrere le celle di excel data una somma, facendo un incremento

    Citazione Originariamente Scritto da rossgu94 Visualizza Messaggio
    Ti ringrazio tantissimo! Non sarei mai arrivata ad una formula del genere da sola!
    Ne approfitto per un'altra piccola domanda: nel caso in cui volessi trovare anche le persone di 95 anni e più basta che cambi la formula sostituendo >65 con >95? Grazie mille per la disponibilità.

    Comunque ho scritto nell'area di presentazione, mi fa piacere conoscervi!
    sì, basta quella modifica ricordati che se vuoi anche quelli di 95 anni devi aggiungere l'operatore = altrimenti ti prende da 96 in su oppure mettere il >94
    Flavio
    Non scrivetemi in MP per risolvere i problemi ed un grazie è sempre ben accetto quando ricevete degli aiuti

  10. #8

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    3977
    Versione Office
    2011/2016MAC
    Mi Piace ricevuti
    1252
    Mi Piace dati
    752

    Re: Come scorrere le celle di excel data una somma, facendo un incremento

    Un saluto a Flavio,
    o come dice lui metti

    =MATR.SOMMA.PRODOTTO((C$8:C$4891)*($A$8:$A$4891=$G8)*(--ANNO(OGGI())-$B$8:$B$4891>94))

    oppure maggiore/uguale


    =MATR.SOMMA.PRODOTTO((C$8:C$4891)*($A$8:$A$4891=$G8)*(--ANNO(OGGI())-$B$8:$B$4891>=95))

    Con l'occasione preciso che si possono anche togliere i due trattini iniziali che avevo messo davanti ANNO per trovare il VERO visto che già specifico la condizione >

    quindi le due formule si possono scrivere anche così:

    =MATR.SOMMA.PRODOTTO((C$8:C$4891)*($A$8:$A$4891=$G8)*(ANNO(OGGI())-$B$8:$B$4891> 65))

    =MATR.SOMMA.PRODOTTO((C$8:C$4891)*($A$8:$A$4891=$G8)*(ANNO(OGGI())-$B$8:$B$4891>=95))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  11. I seguenti 3 utenti hanno dato un MI Piace a ges per questo post:


  12. #9
    L'avatar di rossgu94
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Bologna
    Età
    22
    Messaggi
    6
    Versione Office
    excel 2007
    Mi Piace ricevuti
    1

    Re: Come scorrere le celle di excel data una somma, facendo un incremento

    Citazione Originariamente Scritto da Powerwin Visualizza Messaggio
    sì, basta quella modifica ricordati che se vuoi anche quelli di 95 anni devi aggiungere l'operatore = altrimenti ti prende da 96 in su oppure mettere il >94
    Grazie mille!! Avrei fatto l'errore di non mettere l'uguale infatti! Ti ringrazio tantissimo! Mi hai velocizzato il lavoro di molto!

  13. #10
    L'avatar di Powerwin
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Milano
    Messaggi
    514
    Versione Office
    2010
    Mi Piace ricevuti
    79
    Mi Piace dati
    32

    Re: Come scorrere le celle di excel data una somma, facendo un incremento

    Tutto merito di Ges io ho solo integrato una piccola informazione

    Inviato dal mio SM-G920F utilizzando Tapatalk
    Flavio
    Non scrivetemi in MP per risolvere i problemi ed un grazie è sempre ben accetto quando ricevete degli aiuti

  14. #11
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    53
    Messaggi
    459
    Versione Office
    WIN , 2013
    Mi Piace ricevuti
    187
    Mi Piace dati
    1

    Re: Come scorrere le celle di excel data una somma, facendo un incremento

    Buon Giorno

    In alternativa alle formule propongo una tavola pivot

    La somma per eta e' >=

    https://dropfile.to/uPsmQJC

    Saluti
    Window 7 Excel 2013

  15. #12
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    57
    Messaggi
    597
    Versione Office
    Office 2013
    Mi Piace ricevuti
    594
    Mi Piace dati
    1256

    Re: Come scorrere le celle di excel data una somma, facendo un incremento

    Ciao rossgu94, e un saluto agli amici del forum, un altro modo di affrontare il problema con le formule, potrebbe essere il seguente:

    In H8: per gli over 65
    =SOMMA.PIÙ.SE(C$8:C$4891;$A$8:$A$4891;$G8;$B$8:$B$4891;"<"&ANNO(OGGI())-65)
    da trascinare verso destra e successivamente da tirare giù alla bisogna.

    Per la ricerca dei 95 in su, compresi i 95, copia la seguente:

    =SOMMA.PIÙ.SE(C$8:C$4891;$A$8:$A$4891;$G8;$B$8:$B$4891;"<="&ANNO(OGGI())-95)
    da trascinare verso destra e successivamente da tirare giù alla bisogna.
    Ciao e buona domenica a tutti.

  16. I seguenti 4 utenti hanno dato un MI Piace a pkrome59 per questo post:


  17. #13
    L'avatar di rossgu94
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Bologna
    Età
    22
    Messaggi
    6
    Versione Office
    excel 2007
    Mi Piace ricevuti
    1

    Re: Come scorrere le celle di excel data una somma, facendo un incremento

    Citazione Originariamente Scritto da pkrome59 Visualizza Messaggio
    Ciao rossgu94, e un saluto agli amici del forum, un altro modo di affrontare il problema con le formule, potrebbe essere il seguente:

    In H8: per gli over 65
    =SOMMA.PIÙ.SE(C$8:C$4891;$A$8:$A$4891;$G8;$B$8:$B$4891;"<"&ANNO(OGGI())-65)
    da trascinare verso destra e successivamente da tirare giù alla bisogna.

    Per la ricerca dei 95 in su, compresi i 95, copia la seguente:

    =SOMMA.PIÙ.SE(C$8:C$4891;$A$8:$A$4891;$G8;$B$8:$B$4891;"<="&ANNO(OGGI())-95)
    da trascinare verso destra e successivamente da tirare giù alla bisogna.
    Ciao e buona domenica a tutti.
    Grazie mille! anche questa formula funziona bene!

Discussioni Simili

  1. [Risolto] somma condizionale per data e valore
    Di -Matteo- nel forum Domande su Excel in generale
    Risposte: 15
    Ultimo Messaggio: 21/11/16, 22:01
  2. [Risolto] Aggiornare somma in base a data
    Di lizz1183 nel forum Domande su Excel VBA e MACRO
    Risposte: 3
    Ultimo Messaggio: 19/10/16, 13:08
  3. Somma per data - combobox
    Di bopo57 nel forum Domande su Excel VBA e MACRO
    Risposte: 20
    Ultimo Messaggio: 31/08/16, 17:31
  4. Somma celle e risultato in celle unite
    Di jigen nel forum Domande su Excel VBA e MACRO
    Risposte: 10
    Ultimo Messaggio: 14/07/16, 09:48
  5. Download file facendo il login
    Di Berna11 nel forum Problemi, suggerimenti e Novità del forum
    Risposte: 2
    Ultimo Messaggio: 30/05/16, 18:27

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •