Risultati da 1 a 12 di 12

Discussione: Cerca Verticale con Vincolo



  1. #1
    L'avatar di Deeevil86
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Bologna
    Messaggi
    162
    Versione Office
    2016
    Likes ricevuti
    3
    Likes dati
    37

    Cerca Verticale con Vincolo

    Difficilmente riuscirò a esprimere la mia richiesta senza esempio, quindi allego file contenente 2 fogli: 1° = esempio SEMPLICE e 2° esempio COMPLESSO.

    Io vorrei capire come adoperare la funzione CERCA VERTICALE per un certo tipo di operazione:
    Es. ho 4 colonne di valori (Es. A, B, C e D), in A1 inserisco uno dei valori presenti nella restante colonna A (es. A41), in B1,C1 e D1 devono uscire i valori corrispondenti a B41, C41 e D41. E se in A1 metto un valore non presente nella colonna A, in B1, C1 e D1 dovrebbe uscire errore.

    Spero di essermi spiegato in modo chiaro, sicuramente gli esempi sono molto semplici da capire, che la mia spiegazione.




    Esempio SEMPLICE:
    Inserisco valore in A2, C2 e E2, ed ottengo il corrispondente in F2; es. 85-2-3 -à 85%
    In A2 sono consentiti solo i seguenti valori: 80-85-110-115, i restanti danno errore!
    In C2, tutti i valori superiori a 2 si comportano allo stesso modo di 2; es. 80-3-2 à 20%
    In C3, tutti i valori superiori a 3 si comportano allo stesso modo di 3; es. 110-1-4 -à 85%

    Mi descrivete, se possibile in sintesi, come si articola il comando in questione? Vorrei imparare ad usarlo..



    Esempio COMPLESSO:
    Le colonne A, B, C, D ed E appartengono al 1° livello, le colonne F, G, H, I, L ed M appartengono al 2° livello.
    Prima bisogna risolvere la tabella del 1° livello e poi quella del secondo livello.

    Inserisco codice esatto in B5, e mi escono conseguentemente A5, C5, D5 ed E5.
    In B5 sono consentiti solo i seguenti valori: 80-85-110-115, i restanti danno errore! E fin qui, io ci avevo provato, ma, inserendo valori differenti di B5, mi da comunque dei risultati, e non dovrebbe darli!

    Il problema vero e proprio sta nel completare il secondo livello, che è legato al primo.
    Cioè:
    Se in B5 inserisco valore appartenente alla tabella in alto del primo livello, devo poter inserire in H5 SOLO valori appartenenti alla tabella in alto del secondo livello.
    Es.: In B5 inserisco S6325, in H5 posso inserire solo uno tra i seguenti valori: S6147, S6152, S6259, S6162 ed S6167, altrimenti mi deve dare errore!
    B5: S6325 H5: S6162 OK
    B5: S6030 H5: s4627 NO
    E analogamente per la parte inferiore dei due livelli!
    Ovviamente, come prima, inserito il valore in H5, mi deve dare i corrispondenti valori in I5, L5 ed M5.

    GRAZIE
    File Allegati File Allegati
    Ultima modifica fatta da:Gerardo Zuccalà; 21/09/16 alle 10:26

  2. #2
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    1539
    Versione Office
    2016
    Likes ricevuti
    397
    Likes dati
    92

    Re: Cerca Verticale con Vincolo

    Ciao
    questa in F2
    dell'esempio semplice

    Inserisco valore in A2, C2 e E2, ed ottengo il corrispondente in F2; es. 85-2-3 -à 85%
    Codice: 
    =SE(O(CONTA.SE(A4:A19;A2)<1;CONTA.SE(C4:C19;C2)<1;CONTA.SE(E4:E19;E2)<1);"ERRORE";MATR.SOMMA.PRODOTTO((A4:A19=A2)*(C4:C19=C2)*(E4:E19=E2)*F4:F19))
    che però non corrisponde con

    in A1 inserisco uno dei valori presenti nella restante colonna A (es. A41), in B1,C1 e D1 devono uscire i valori corrispondenti a B41, C41 e D41
    mi dici esattamente che risultato vuoi?

    per il complesso ora vedo se capisco
    In B5 sono consentiti solo i seguenti valori: 80-85-110-115,
    ma in B5 non ci vanno i codici?
    è in A5 che vanno i valori e sono irrintracciabili senza codice visto che non sono univoci.

    parti dal codice o da cosa

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di Deeevil86
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Bologna
    Messaggi
    162
    Versione Office
    2016
    Likes ricevuti
    3
    Likes dati
    37

    Re: Cerca Verticale con Vincolo

    Citazione Originariamente Scritto da Gianfranco55 Visualizza Messaggio
    Ciao
    questa in F2
    dell'esempio semplice


    Codice: 
    =SE(O(CONTA.SE(A4:A19;A2)<1;CONTA.SE(C4:C19;C2)<1;CONTA.SE(E4:E19;E2)<1);"ERRORE";MATR.SOMMA.PRODOTTO((A4:A19=A2)*(C4:C19=C2)*(E4:E19=E2)*F4:F19))
    che però non corrisponde con



    mi dici esattamente che risultato vuoi?

    per il complesso ora vedo se capisco


    ma in B5 non ci vanno i codici?
    è in A5 che vanno i valori e sono irrintracciabili senza codice visto che non sono univoci.

    parti dal codice o da cosa
    Per il SEMPLICE, la formula va quasi bene, cioè va bene, ma se inserisco nella cella C2 il valore 3, non vorrei che uscisse errore, ma che fosse considerato come 2 ed analogamente per la cella E2 con il valore 4, vorrei che fosse considerato come 3.
    Non so se sia possibile una cosa del genere.

    Per il COMPLESSO, si, in B5 va inserito il codice (lo chiamavo valore erroneamente).

    Grazie

  5. #4
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    1539
    Versione Office
    2016
    Likes ricevuti
    397
    Likes dati
    92

    Re: Cerca Verticale con Vincolo

    Ciao
    prova ora
    metti numeri superiori sulle celle incriminate
    vedi anche la prima parte del foglio complicato

    ti ho messo le formule
    sia cerca verticale che indice confronta( sulla colonna di sinistra)

    ora vediamo il resto
    File Allegati File Allegati

  6. I seguenti 2 utenti hanno dato un "Like" a Gianfranco55 per questo post:


  7. #5
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    1539
    Versione Office
    2016
    Likes ricevuti
    397
    Likes dati
    92

    Re: Cerca Verticale con Vincolo

    ho usato uno stratagemma per la seconda parte

    ho messo delle convalide (tabella1 e tabella 2)
    che si attivano quando scrivi un codice
    nella cella di ricerca. F5

    vicino vedi che si scrivono
    o tabella1 o tabella 2

    non eliminarlo è quello che determina la convalida.
    al limite metti colore carattere bianco


    prova e fammi sapere

    ci sono ancora gli errori da gestire ma quello sei capace.

    nb

    il cerca verticale deve avere FALSO per avere il valore esatto
    tu non l'hai mai messo per quello le tue formule non funzionavano

    ho messo delle macro elementari
    una per gestire il foglio 1 ( se la cella è superiore a 2=2 per capirci)

    nel foglio2
    la macro azzera la convalida se cambi il valore in F5
    File Allegati File Allegati

  8. I seguenti utenti hanno dato un "Like"


  9. #6
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    57
    Messaggi
    1000
    Versione Office
    Office 2013
    Likes ricevuti
    983
    Likes dati
    1770

    Re: Cerca Verticale con Vincolo

    Ciao Deeevil86, per quanto riguarda il caso semplice, se ho capito bene, proporrei la seguente:

    In F2:
    =INDICE($F$4:$F$19;AGGREGA(15;6;(RIF.RIGA($A$4:$A$19)-RIF.RIGA($A$4)+1)/(($A$4:$A$19=$A$2)*($C$4:$C$19=SE($C$2>=2;2;$C$2))*($E$4:$E$19=SE($E$2>=3;3;$E$2)));1))
    fa sapere se va bene, ciao.

  10. I seguenti utenti hanno dato un "Like"


  11. #7
    L'avatar di Deeevil86
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Bologna
    Messaggi
    162
    Versione Office
    2016
    Likes ricevuti
    3
    Likes dati
    37

    Re: Cerca Verticale con Vincolo

    Citazione Originariamente Scritto da pkrome59 Visualizza Messaggio
    Ciao Deeevil86, per quanto riguarda il caso semplice, se ho capito bene, proporrei la seguente:

    In F2:
    =INDICE($F$4:$F$19;AGGREGA(15;6;(RIF.RIGA($A$4:$A$19)-RIF.RIGA($A$4)+1)/(($A$4:$A$19=$A$2)*($C$4:$C$19=SE($C$2>=2;2;$C$2))*($E$4:$E$19=SE($E$2>=3;3;$E$2)));1))
    fa sapere se va bene, ciao.
    Ciao!

    La formula funziona benissimo!

  12. #8
    L'avatar di Deeevil86
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Bologna
    Messaggi
    162
    Versione Office
    2016
    Likes ricevuti
    3
    Likes dati
    37

    Re: Cerca Verticale con Vincolo

    Citazione Originariamente Scritto da Gianfranco55 Visualizza Messaggio
    Ciao
    prova ora
    metti numeri superiori sulle celle incriminate
    vedi anche la prima parte del foglio complicato

    ti ho messo le formule
    sia cerca verticale che indice confronta( sulla colonna di sinistra)

    ora vediamo il resto

    Si, ora la formula SEMPLICE funziona..
    TI aggiorno sulla COMPLESSA!

  13. #9
    L'avatar di Deeevil86
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Bologna
    Messaggi
    162
    Versione Office
    2016
    Likes ricevuti
    3
    Likes dati
    37

    Re: Cerca Verticale con Vincolo

    Citazione Originariamente Scritto da Gianfranco55 Visualizza Messaggio
    Ciao
    prova ora
    metti numeri superiori sulle celle incriminate
    vedi anche la prima parte del foglio complicato

    ti ho messo le formule
    sia cerca verticale che indice confronta( sulla colonna di sinistra)

    ora vediamo il resto
    Relativamente alla parte COMPLESSA:

    1) Vorrei far sì che anche la riga 6, 7 e 8 funzioni come la 5.
    La prima parte, cioè quella a dx (celle D6-D7-D8, C6-C7-C8, D6-D7-D8 e E6-E7-E8), le ho copia incollate e aggiustate e funzionano.
    Il problema è con la parte a sx (celle I6-I7-I8, L6-L7-L8 e M6-M7-M8), più precisamente con la cella in cui deve essere inserito il codice vincolato (H6-H7-H8). Non mi funziona il vincolo, sai come mai?

    2) Ho spostato il foglio contenente la parte COMPLESSA in un altro documento e facendo salva (con attivazione di macro excel) mi dice: "attenzione in alcune parti del documento potrebbero essere presenti informazioni personali" e non mi fa salvare.. come mai?


    GRAZIE

  14. #10
    L'avatar di Deeevil86
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Bologna
    Messaggi
    162
    Versione Office
    2016
    Likes ricevuti
    3
    Likes dati
    37

    Re: Cerca Verticale con Vincolo

    Per la parte SEMPLICE, seppur entrambe le formulazioni sono corrette, senza togliere nulla a Gianfranco55, quella di pkrome59 è un pelino migliore poichè, seppur lasciando invariato il valore inserito (es. maggiore di 2 nella colonna C e maggiore di 3 nella colonna E), tale valore viene comunque considerato al massimo 2 e 3 rispettivamente, invece di ridurlo automaticamente a 2 o 3.

    Grazie ad entrambi!!

  15. #11
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    1539
    Versione Office
    2016
    Likes ricevuti
    397
    Likes dati
    92

    Re: Cerca Verticale con Vincolo

    Ciao
    è questione do dollari $

    Codice: 
    =CERCA.VERT($F$5;$F$10:$J$68;3;FALSO)
    cambia $F$5 in $F5

    Codice: 
    =INDICE(D10:D68;CONFRONTA(F5;F10:F68;0))
    diventa
    Codice: 
    =INDICE($D$10:$D$68;CONFRONTA($F5;$F$10:$F$68;0))
    se li trascini in giù devi bloccare i range
    attenzione in alcune parti del documento potrebbero essere presenti informazioni personali"
    sai una cosa viene anche a me delle volte ma onestamente
    me ne sono sempre fregato

    per la formula di Pkrome l'avrei scelta anch'io
    non sarei stato capace di farla ma ti elimina il vba

  16. #12
    L'avatar di Deeevil86
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Bologna
    Messaggi
    162
    Versione Office
    2016
    Likes ricevuti
    3
    Likes dati
    37

    Re: Cerca Verticale con Vincolo

    Citazione Originariamente Scritto da Gianfranco55 Visualizza Messaggio
    ...
    Ho seguito la correzione e funziona benissimo! OTTIMO!

    GRAZIE!
    Ultima modifica fatta da:Canapone; 14/03/17 alle 10:42

Discussioni Simili

  1. [Risolto] Richiamare valori colonna tramite una combobox
    Di max72 nel forum Domande su Microsoft Access
    Risposte: 32
    Ultimo Messaggio: 10/07/17, 17:12
  2. [Risolto] Cerca Verticale
    Di Deeevil86 nel forum Domande su Excel in generale
    Risposte: 38
    Ultimo Messaggio: 19/09/16, 15:35
  3. Cerca Verticale su più fogli.
    Di Giuseppe Zammuto nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 26/02/16, 12:15
  4. Cerca Verticale
    Di Il Pirata nel forum Domande su Excel in generale
    Risposte: 17
    Ultimo Messaggio: 23/11/15, 17:41
  5. Cerca verticale
    Di giackko86 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 08/09/15, 22:48

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •