Risultati da 1 a 6 di 6

Discussione: CONTA.SE su molte righe >=2



  1. #1
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    640
    Versione Office
    Excel 2010
    Mi Piace ricevuti
    322
    Mi Piace dati
    123

    CONTA.SE su molte righe >=2

    Buonasera a tutti.
    volevo chiedervi un'alternativa alla formula qui sotto ( per ora non mi vengono ho provato MATR.SOMMA.PRODOTTO ma, mi da il totale forse l'ho impostata male
    quella che stavo provando ora è:

    =SE(CONTA.SE($B$4:$P$4;R4)-CONTA.SE($K$4:$M$4;R4)>1;1;0)+SE(CONTA.SE($B$5:$P$5;R4)-CONTA.SE($K$5:$M$5;R4)>1;1;0)..............fino a SE(CONTA.SE($B$34:$P$34;R4)-CONTA.SE($K$34:$M$34;R4)>1;1;0)

    In pratica vorrei contare quante volte in una singola riga del range (B4:P34) (non considerando le colonne K-L-M) è presente la sigla R4 dell'esempio + di una volta.

    Nel file allegato in colonna T ho messo la formula (solo per le prime due righe) se la continuo fino alla fine mi darà risultato 2 infatti la sigla BE è presente nella riga 4 e riga 9 x 2 volte mentre in riga 8 è presente solo 1 volta e non va contata.
    Ho conteggiato solo 3 sigle quelle colorate.
    Grazie per la collaborazione.
    File Allegati File Allegati
    Ultima modifica fatta da:ges; 21/09/16 alle 21:28
    <--- Se ti piace la risposta di qualcuno, oltre a ringraziarlo, puoi cliccare su "Mi Piace" in basso a sinistra del loro messaggio.

  2. I seguenti utenti hanno dato un "Mi Piace"


  3. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    3977
    Versione Office
    2011/2016MAC
    Mi Piace ricevuti
    1252
    Mi Piace dati
    752

    Re: CONTA.SE su molte righe >=2

    Ciao Berna,
    così?

    =MATR.SOMMA.PRODOTTO((B4:P4=R4)*1)-MATR.SOMMA.PRODOTTO((K4:M4=R4)*1)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  4. I seguenti 4 utenti hanno dato un MI Piace a ges per questo post:


  5. #3

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    36
    Messaggi
    2733
    Versione Office
    2016
    Mi Piace ricevuti
    778
    Mi Piace dati
    665

    Re: CONTA.SE su molte righe >=2

    Ciao Berna,

    sempre che abbia capito bene il problema....
    nella cella T4 (da copiare poi in basso) potresti usare questa formula:

    =MATR.SOMMA.PRODOTTO(--((CONTA.SE(INDIRETTO("B"&RIF.RIGA($B$4:$P$33)&":P"&RIF.RIGA($B$4:$P$33));R4)-CONTA.SE(INDIRETTO("K"&RIF.RIGA($B$4:$P$33)&":M"&RIF.RIGA($B$4:$P$33));R4))>1))
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  6. I seguenti 5 utenti hanno dato un MI Piace a cromagno per questo post:


  7. #4

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    36
    Messaggi
    2733
    Versione Office
    2016
    Mi Piace ricevuti
    778
    Mi Piace dati
    665

    Re: CONTA.SE su molte righe >=2

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ciao Berna,
    così?

    =MATR.SOMMA.PRODOTTO((B4:P4=R4)*1)-MATR.SOMMA.PRODOTTO((K4:M4=R4)*1)
    Ciao ges,
    non avevo visto la tua risposta (e al momento non posso provarla...devo scappare) ma come sempre

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  8. #5
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    672
    Versione Office
    2010 x WIN
    Mi Piace ricevuti
    315
    Mi Piace dati
    122

    Re: CONTA.SE su molte righe >=2

    Ciao a tutti

    risultati uguali alla formula proposta da Cromagno:

    =SOMMA(--(MATR.PRODOTTO(--(B$4:P$34=R4);MATR.TRASPOSTA(RIF.COLONNA(B:P)^0))-MATR.PRODOTTO(--(K$4:M$34=R4);MATR.TRASPOSTA(RIF.COLONNA(K:M)^0))>1))

    va però confermata come matrice

    Saluti

  9. I seguenti 4 utenti hanno dato un MI Piace a Canapone per questo post:


  10. #6
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    640
    Versione Office
    Excel 2010
    Mi Piace ricevuti
    322
    Mi Piace dati
    123

    Re: CONTA.SE su molte righe >=2

    ciao a tutti,
    Scusate il ritardo .... vedo che vi siete dati da fare...

    Rispondo alle vostre soluzioni:

    @ Ges la tua soluzione va bene se calcolata riga per riga ma mi serviva il totale di tutta la tabella in unica cella.

    @ Cromagno si hai capito bene era quello che chiedevo.

    @ Canapone anche la tua da il risultato che chiedevo ma, è fantascientifica.

    Bravi grazie a tutti per il vostro contributo potete segnare la discussione con RISOLTO.
    <--- Se ti piace la risposta di qualcuno, oltre a ringraziarlo, puoi cliccare su "Mi Piace" in basso a sinistra del loro messaggio.

Discussioni Simili

  1. Risposte: 6
    Ultimo Messaggio: 23/10/16, 17:02
  2. Risposte: 3
    Ultimo Messaggio: 12/05/16, 20:53
  3. come eliminare righe vuote, tra righe di testo in una pagina excel
    Di francesco71 nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 08/05/16, 13:13
  4. formula su molte celle non adiacenti
    Di bolomanonbolo nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 25/03/16, 12:59
  5. Consolidare molte tabelle. PowerQuery non aggancia tutti i record
    Di MarcoM nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 18/10/15, 08:50

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •