Risultati da 1 a 7 di 7

Discussione: Creare preventivo in automatico da compilazione listino



  1. #1
    L'avatar di fra.morelli
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Pisa
    Età
    30
    Messaggi
    4
    Versione Office
    Home & busi2013
    Likes ricevuti
    0
    Likes dati
    3

    Creare preventivo in automatico da compilazione listino

    Salve a tutti,

    avrei necessità di riuscire a far creare in automatico un preventivo basandomi su riempimento di un listino in formato excel.
    Mi spiego meglio:
    dal foglio 1 dove ho il listino completo elencato per articolo (codice/descrizione/prezzo) inserisco le quantità ed in automatico nel foglio 2 mi si compila preventivo con l'elenco SOLTANTO degli articoli per i quali ho inserito le quantità nel foglio 1 con codice/descrizione/prezzo e totale.

    Sapreste molto gentilmente aiutarmi? Sono riuscito ad arrivare con il SE alla selezione solo degli articoli per i quali inserisco le quantità ma non riesco nella compilazione automatica del preventivo.

    Grazie mille a tutti

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    6379
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    1895
    Likes dati
    1207

    Re: Creare preventivo in automatico da compilazione listino

    Ciao,
    ti aiutiamo volentieri ma dovresti allegare un file di esempio, evitandoci di crearlo noi magari in modo non conforme a quello che tu indenti.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di Catwoman
    Clicca e Apri
    Data Registrazione
    Aug 2016
    Località
    Tenerife
    Messaggi
    737
    Versione Office
    2013
    Likes ricevuti
    127
    Likes dati
    666

    Re: Creare preventivo in automatico da compilazione listino

    Benvenuto nelForum Fra.morelli
    Quando hai due minuti ti aspetto QUI così ti presenti e ci dici qualcosa di te.

    Per mettere una simpatica foto dell'avatar potrai trovare le istruzioni QUI

    Ti aspetto, grazie
    Sii gentile quando possibile. È sempre possibile
    (Dalai Lama)

  4. I seguenti utenti hanno dato un "Like"


  5. #4
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    1852
    Versione Office
    Excel 2010
    Likes ricevuti
    746
    Likes dati
    399

    Re: Creare preventivo in automatico da compilazione listino

    Un saluto a tutti,
    @ frA.morelli, fermo restando di attenersi a quanto detto sopra da Ges e da Dilly
    (un saluto) avendo qualcosa di simile ho adattato un piccolo file che ti allego dal quale prendere spunto.
    con questa formula ricavi i codici che hanno una quantità inserita nel foglio Articoli e li riporta nel foglio2
    =SE.ERRORE(INDICE(Articoli!$A$2:$A$7;AGGREGA(15;6;RIF.RIGA(Articoli!$E$2:$E$7)-RIF.RIGA(Articoli!$E$1)/(Articoli!$E$2:$E$7<>"");RIGHE(Articoli!$E$2:$E2)));"")
    P
    oi con delle formule di cerca.vert. è semplice ottenere il resto.

    File Allegati File Allegati
    <--- Se ti piace la risposta di qualcuno, oltre a ringraziarlo, puoi cliccare su "Like" in basso a sinistra del loro messaggio.

  6. I seguenti utenti hanno dato un "Like"


  7. #5
    L'avatar di D@nilo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Età
    44
    Messaggi
    1096
    Versione Office
    Excel 2010
    Likes ricevuti
    458
    Likes dati
    539

    Re: Creare preventivo in automatico da compilazione listino

    Ciao,ho fatto un piccolo listino con 9 prodotti in B1 codice in C1 descrizione D1 prezzo E1 quantità poi ho poceduto cosi:
    Foglio1 nella colonna A (da nascondere):
    1°in A1 ho messo una X
    2°in A2 da tirare giù fino a A10 =SOMMA(E2<>"";A1)
    Foglio2 in F6 =SE.ERRORE(CERCA.VERT(RIGHE(Foglio1!A$2:A2);Foglio1!$A$2:$E$10;2;0);"")
    in G6 =SE.ERRORE(CERCA.VERT(RIGHE(Foglio1!B$2:B2);Foglio1!$A$2:$E$10;3;0);"")
    in H6 =SE.ERRORE(CERCA.VERT(RIGHE(Foglio1!C$2:C2);Foglio1!$A$2:$E$10;4;0);"")
    in I6 =SE.ERRORE(CERCA.VERT(RIGHE(Foglio1!A$2:A2);Foglio1!$A$2:$E$10;5;0);"") tutte da tirare giù fino a riga 14
    e per il totale in I15 =MATR.SOMMA.PRODOTTO(H6:H14;I6:I14)
    File Allegati File Allegati

  8. I seguenti utenti hanno dato un "Like"


  9. #6
    L'avatar di fra.morelli
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Pisa
    Età
    30
    Messaggi
    4
    Versione Office
    Home & busi2013
    Likes ricevuti
    0
    Likes dati
    3

    Re: Creare preventivo in automatico da compilazione listino

    Ringrazio tutti per la vostra enorme disponibilità. Problema risolto grazie a voi.
    Mi manca tutta la parte sulle formule in forma di matrice e in questi casi è ovviamente fondamentale.
    Non mancherà di presentarmi appena riesco.

    Ringrazio ancora tutti e vi auguro una buona serata
    Un saluto

  10. #7
    L'avatar di Catwoman
    Clicca e Apri
    Data Registrazione
    Aug 2016
    Località
    Tenerife
    Messaggi
    737
    Versione Office
    2013
    Likes ricevuti
    127
    Likes dati
    666

    Re: Creare preventivo in automatico da compilazione listino

    Citazione Originariamente Scritto da fra.morelli Visualizza Messaggio
    Ringrazio tutti per la vostra enorme disponibilità. Problema risolto grazie a voi.
    Mi manca tutta la parte sulle formule in forma di matrice e in questi casi è ovviamente fondamentale.
    Non mancherà di presentarmi appena riesco.

    Ringrazio ancora tutti e vi auguro una buona serata
    Un saluto
    Ciao fra.morelli,
    ho visto che ancora non sei passato dal VIA a presentarti
    Per mettere una simpatica foto dell'avatar ti ricordo che potrai trovare le istruzioni QUI
    Sii gentile quando possibile. È sempre possibile
    (Dalai Lama)

Discussioni Simili

  1. Preventivatore automatico da listino
    Di fra.morelli nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 24/02/17, 09:17
  2. Creare interfaccia utente per compilazione foglio
    Di IEUSUNTU nel forum Domande su Excel VBA e MACRO
    Risposte: 3
    Ultimo Messaggio: 04/02/17, 18:02
  3. compilazione di caselle in automatico
    Di Paolabrikko nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 07/01/17, 20:08
  4. [Risolto] Come creare foglio modulo d'ordine da foglio listino (Calc)
    Di WARMACHINE nel forum Foglio di calcolo su altre Piattaforme
    Risposte: 9
    Ultimo Messaggio: 23/09/16, 18:59
  5. Sostituire e unire dati listino 2015 con nuovo listino 2016
    Di ste196free nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 12/01/16, 15:45

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •