Risultati da 1 a 5 di 5

Discussione: compilazione automatica celle



  1. #1
    L'avatar di ilbarbadatre
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Firenze
    Età
    36
    Messaggi
    2
    Versione Office
    Office 2013
    Likes ricevuti
    0
    Likes dati
    0

    compilazione automatica celle

    Buongiorno a tutti,
    vi espongo il problema.

    Ho due fogli di lavoro; il primo è un database: contiene nominativi, indirizzi, telefoni e una colonna con una numerazione univoca ("tessera socio").
    Nel secondo foglio ho esattamente le stesse colonne e vorrei che inserendo solo i dati nella colonna "tessera socio" mi si compilassero in automatico tutte le altre colonne.

    Ho provato con cerca.vert ma la cella dove vado a leggere il valore deve far parte della matrice (foglio 1), mentre la mia cella di origine è nel foglio 2.

    Probabilmente è una cosa semplicissima per voi; sarei grato se potessi ricevere aiuto.

    Allego un file di esempio (ho messo la colonna "tessera socio" come prima colonna per il cerca.vert ma è possibile anche spostarla?)

    Se servono altri chiarimenti dite pure.
    File Allegati File Allegati

  2. #2

    L'avatar di alfrimpa
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Napoli
    Età
    63
    Messaggi
    4896
    Versione Office
    2007 - 2013
    Likes ricevuti
    537
    Likes dati
    93

    Re: compilazione automatica celle

    prova con questa formula sul foglio2

    Codice: 
    =CERCA.VERT(A3;'Foglio 1'!$A$4:$G$6;2;FALSO)
    Poi la copi nelle altre celle variando i riferimenti.
    Alfredo

    "Non esistono cose facili o difficili; esistono cose che si sanno e cose che non si sanno"

    "Solo due cose sono infinite: l'universo e la stupidità umana; riguardo l'universo ho ancora dei dubbi" (Albert Einstein)

  3. #3
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    44
    Messaggi
    681
    Versione Office
    2010 64 bit
    Likes ricevuti
    100
    Likes dati
    52

    Re: compilazione automatica celle

    prova ad inserire questa in B2
    Codice: 
    =CERCA.VERT($A3;'Foglio 1'!$A$4:$G$19;RIF.COLONNA();FALSO)
    e trascini a dx e in basso quanto vuoi...
    oppure
    Codice: 
    =CERCA.VERT($A3;'Foglio 1'!$A$4:$G$19;RIF.COLONNA();FALSO)
    cambiando l'indice RIF.COLONNA() in 2 3 4...7
    e quindi avrai
    Codice: 
    =CERCA.VERT($A3;'Foglio 1'!$A$4:$G$19;2;FALSO)
    ...
    Codice: 
    =CERCA.VERT($A3;'Foglio 1'!$A$4:$G$19;7;FALSO)
    ciao
    ale

  4. #4
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    53
    Messaggi
    612
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    255
    Likes dati
    1

    Re: compilazione automatica celle

    Buon Giorno

    Foglio 2

    b3=SE.ERRORE(CERCA.VERT('Foglio 2'!$A3;'Foglio 1'!$A$4:$G$6;CONFRONTA('Foglio 2'!B$1;'Foglio 1'!$A$2:$G$2;0);FALSO);"") copia a destra e in basso

    Saluti
    Window 8.1 Excel 2013/2016

  5. #5
    L'avatar di ilbarbadatre
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Firenze
    Età
    36
    Messaggi
    2
    Versione Office
    Office 2013
    Likes ricevuti
    0
    Likes dati
    0

    Re: compilazione automatica celle

    grande, così sono riuscito, c'ero quasi arrivato da solo ma evidentemente qualcosa sbagliavo

    grazie mille dell'aiuto

Discussioni Simili

  1. Compilazione automatica colonne...
    Di angelix nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 15/11/16, 23:18
  2. [Risolto] Compilazione automatica campi
    Di solenero nel forum Domande su Microsoft Access
    Risposte: 5
    Ultimo Messaggio: 19/07/16, 13:55
  3. Compilazione automatica di celle dopo confronto valori
    Di max.lotti nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 04/06/16, 14:38
  4. compilazione automatica
    Di cicciopuzzo nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 05/02/16, 13:12
  5. Compilazione automatica
    Di Alberto71 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 02/11/15, 22:51

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •