Risultati da 1 a 13 di 13

Discussione: Trovare il cliente ed il prodotto "migliore" con Excel



  1. #1
    L'avatar di dade92
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Milano
    Età
    25
    Messaggi
    57
    Versione Office
    mac 2016
    Utile ricevuti
    0
    Utile dati
    0

    Trovare il cliente ed il prodotto "migliore" con Excel

    Buona sera!

    Ho intenzione di creare un piccolo file Excel che mi faccia capire come stanno procedendo le mie "vendite" simulate.

    Ho allegato il file Excel di esempio.

    Vorrei sapere:

    - quale cliente ha acquistato più prodotti;
    - quale prodotto è stato acquistato più volte;
    - quali prodotti sono stati acquistati da un determinato cliente che seleziono da una casella di convalida dati.




    Ho fatto un po' di tentativi con il cerca.vert, indice e confronta ma non sono riuscito a trovare una soluzione.

    Mi sembra di ricordare che Gerardo Zuccalà in uno dei suoi video su YT abbia spiegato il modo per risolvere questo tipo di problema ma non ricordo come e in quale video ne parlava :(

    Chi mi può dare una mano?

    Grazie mille!
    File Allegati File Allegati

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    4885
    Versione Office
    2011MAC 2016WIN
    Utile ricevuti
    1615
    Utile dati
    1020

    Re: Trovare il cliente ed il prodotto "migliore" con Excel

    Ciao,
    ti propongo le seguenti formule:

    cliente ha acquistato più prodotti;

    =INDICE(Tabella1[ACQUIRENTE];MAX(CONTA.SE(Tabella1[PRODOTTO];Tabella1[PRODOTTO])))

    prodotto è stato acquistato più volte

    =INDICE(Tabella1[PRODOTTO];CONFRONTA(MAX(Tabella1[PREZZO]);Tabella1[PREZZO];0))

    prodotti sono stati acquistati da un determinato cliente

    =SE.ERRORE(INDICE(Tabella1[PRODOTTO];AGGREGA(15;6;(RIF.RIGA(Tabella1[PRODOTTO])-3)/(Tabella1[ACQUIRENTE]=$B$22);RIGHE(A1:$A$1)));"")
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. I seguenti 2 utenti hanno dato un "Utile" a ges per questo post:


  4. #3
    L'avatar di dade92
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Milano
    Età
    25
    Messaggi
    57
    Versione Office
    mac 2016
    Utile ricevuti
    0
    Utile dati
    0

    Re: Trovare il cliente ed il prodotto "migliore" con Excel

    Ciao, grazie mille per la pronta risposta!

    Ho controllato il file però ho visto che non dà i giusti risultati.

    Il cliente che ha acquistato di più non è Antonello ma sono, in egual misura, Lucio e Francesco.
    Inoltre, il prodotto più venduto non è D ma, in egual misura, A e B.
    Probabilmente dà risultati a caso perché non sono numeri ma lettere

    Ottima invece la tabellina che mi dà più risultati quando cerco chi ha acquistato cosa :D

    Grazie ancora!

  5. #4
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    53
    Messaggi
    534
    Versione Office
    WIN , 2013
    Utile ricevuti
    230
    Utile dati
    1

    Re: Trovare il cliente ed il prodotto "migliore" con Excel

    Buona Sera


    Allego tabelle pivot per analisi vendita


    Saluti
    File Allegati File Allegati
    Window 7 Excel 2013

  6. I seguenti 2 utenti hanno dato un "Utile" a Pitagora per questo post:


  7. #5
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    57
    Messaggi
    853
    Versione Office
    Office 2013
    Utile ricevuti
    874
    Utile dati
    1649

    Re: Trovare il cliente ed il prodotto "migliore" con Excel

    Ciao a tutti, se ho capito bene, copia le seguenti:

    In E16:
    =SE.ERRORE(INDICE(Tabella1[ACQUIRENTE];AGGREGA(14;6;(RIF.RIGA(Tabella1[PRODOTTO])-3)/(FREQUENZA(CONFRONTA(Tabella1[ACQUIRENTE];Tabella1[ACQUIRENTE];0);RIF.RIGA(Tabella1[PRODOTTO])-3)>1);RIGHE($C$4:$C5)));"")

    In E19:
    =SE.ERRORE(INDICE(Tabella1[PRODOTTO];AGGREGA(14;6;(RIF.RIGA(Tabella1[PRODOTTO])-3)/(FREQUENZA(CONFRONTA(Tabella1[PRODOTTO];Tabella1[PRODOTTO];0);RIF.RIGA(Tabella1[PRODOTTO])-3)>1);RIGHE($C$4:$C4)));"")

    In D25:
    =SE.ERRORE(INDICE(Tabella1[PRODOTTO];AGGREGA(14;6;(RIF.RIGA(Tabella1[PRODOTTO])-3)/(Tabella1[ACQUIRENTE]=$B$25);RIGHE($C$4:$C4)));"")
    Ciao allego il file di prova, fa sapere se va bene, ciao.
    File Allegati File Allegati

  8. I seguenti 4 utenti hanno dato un "Utile" a pkrome59 per questo post:


  9. #6
    L'avatar di mb63
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Torino
    Età
    54
    Messaggi
    337
    Versione Office
    2007/10/13
    Utile ricevuti
    11
    Utile dati
    70

    Re: Trovare il cliente ed il prodotto "migliore" con Excel

    Ciao a tutti

    nella pivot clienti se non interessa l'importo ma solo quante volte i può sostituire il somma cliente con la funzione conta

    ciao

    bella impostazione a prescindere della soluzione proposta. le altre soluzione per me sono ottime ma molto complesse per le mie conoscenze

    complimenti a tutti

  10. #7
    L'avatar di dade92
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Milano
    Età
    25
    Messaggi
    57
    Versione Office
    mac 2016
    Utile ricevuti
    0
    Utile dati
    0

    Re: Trovare il cliente ed il prodotto "migliore" con Excel

    Grazie mille a tutti, ho tenuto sia le pivot che possono sempre servire sia tutte le formule che mi avete consigliato.

  11. #8
    L'avatar di Danilo Fiorini
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Età
    44
    Messaggi
    874
    Versione Office
    Excel 2007
    Utile ricevuti
    346
    Utile dati
    447

    Re: Trovare il cliente ed il prodotto "migliore" con Excel

    ci avevo perso un po di tempo... (per diletto) posto il file che è più esplicativo....
    File Allegati File Allegati

  12. I seguenti 3 utenti hanno dato un "Utile" a Danilo Fiorini per questo post:


  13. #9
    L'avatar di dade92
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Milano
    Età
    25
    Messaggi
    57
    Versione Office
    mac 2016
    Utile ricevuti
    0
    Utile dati
    0

    Re: Trovare il cliente ed il prodotto "migliore" con Excel

    Oggi ho riguardato i vari files che mi sono arrivati ed in effetti ho notato che non viene messo un ordine ai vari clienti e prodotti.

    Ottima la formula GRANDE.

    Grazie :D

  14. #10
    L'avatar di Danilo Fiorini
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Età
    44
    Messaggi
    874
    Versione Office
    Excel 2007
    Utile ricevuti
    346
    Utile dati
    447

    Re: Trovare il cliente ed il prodotto "migliore" con Excel

    nel file postato #8 ci sono i clienti che hanno acquistato di più e i prodotti più venduti....

  15. #11
    L'avatar di dade92
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Milano
    Età
    25
    Messaggi
    57
    Versione Office
    mac 2016
    Utile ricevuti
    0
    Utile dati
    0

    Re: Trovare il cliente ed il prodotto "migliore" con Excel

    Citazione Originariamente Scritto da Danilo Fiorini Visualizza Messaggio
    nel file postato #8 ci sono i clienti che hanno acquistato di più e i prodotti più venduti....
    Sì, mi riferivo al tuo file ma ho sbagliato a cliccare il tasto per rispondere XD

    Se volessi invece trovare i clienti che hanno acquistato meno ed i prodotti meno venduti che formule potrei usare?

  16. #12
    L'avatar di Danilo Fiorini
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Età
    44
    Messaggi
    874
    Versione Office
    Excel 2007
    Utile ricevuti
    346
    Utile dati
    447

    Re: Trovare il cliente ed il prodotto "migliore" con Excel

    ciao, devi cambiare il valore del cercaverticale da GRANDE a PICCOLO....per capire meglio ti allego file con entrambe le variabili....
    File Allegati File Allegati

  17. #13
    L'avatar di dade92
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Milano
    Età
    25
    Messaggi
    57
    Versione Office
    mac 2016
    Utile ricevuti
    0
    Utile dati
    0

    Re: Trovare il cliente ed il prodotto "migliore" con Excel

    Citazione Originariamente Scritto da Danilo Fiorini Visualizza Messaggio
    ciao, devi cambiare il valore del cercaverticale da GRANDE a PICCOLO....per capire meglio ti allego file con entrambe le variabili....
    Grazie!

    Ci gioco un po' :D

Discussioni Simili

  1. [Risolto] Ottenere il primo valore "vero" di una matrice somma prodotto
    Di Maurantz nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 08/02/17, 21:51
  2. [Risolto] Ordinare con la funzione "piccolo"..ma "portandosi dietro" anche altri dati affiancati
    Di mauri73 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 05/02/17, 12:57
  3. [Risolto] Come leggere la seguente formula =SE.ERRORE(INDIRETTO("'"&A1&"'!K1";1);""))
    Di sitolofi nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 20/12/16, 12:54
  4. >Come estrappolare la somma "automatica" di un DB con funzione "FILTRO"<
    Di tk71 nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 11/06/16, 09:44
  5. [Risolto] Codice non funzionante dopo il passaggio da "Windows" a "Mac"...
    Di joondeep nel forum Foglio di calcolo su altre Piattaforme
    Risposte: 13
    Ultimo Messaggio: 12/03/16, 19:09

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •