Risultati da 1 a 7 di 7

Discussione: Somma con singolo criterio su fogli multipli



  1. #1
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Somma con singolo criterio su fogli multipli

    Ciao a tutti
    In allegato troverete un foglio "Risultato" e li dovete fare la somma di tutti fogli solo se soddisfa il Criterio che è nella cella C2
    Buon divertimento
    Ultima modifica fatta da:Gerardo Zuccalà; 08/09/15 alle 02:19
    Invia MPPM 

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204
    Ciao Gerardo,

    un modo potrebbe essere questo:

    =MATR.SOMMA.PRODOTTO(SOMMA.SE(INDIRETTO("'"&A2:A4&"'!G2:G5");C2;INDIRETTO("'"&A2:A4&"'!H2:H5")))

    Ho lasciato gli apicetti nella formula: nel file che hai condiviso non servirebbero.

    Saluti
    Invia MPPM 

  3. #3

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4024
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Dopo le formule di "Canapone","ninai" o "scossa", di solito mi astengo dal fare figuracce, ma ultimamente ho a che fare con formule "normali" da rendere matriciali e spesso la "forma matrice" non viene considerata nella formula, sfalsando il risultato...
    Si, potrei trovare delle alternative, ma quello che mi preme è capire il perchè non diventino matriciali.
    In questo esercizio avrei proposto una variante tipo questa:

    =SOMMA.SE(INDIRETTO("data"&{1.2.3}&"!$G$2:$G$5");C2;INDIRETTO("data"&{1.2.3}&"!$H$2:$H$5"))

    ma naturalmente prende in considerazione solo il primo foglio....
    Mi aiutereste a capire come prendere in considerazione anche gli altri fogli e soprattutto a capire perchè la formula scritta prima non li considera?

    Grazie a chi risponde e a chi propone i quiz che a loro volta fanno nascere domande nuove... :246:

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."
    Invia MPPM 

  4. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da cromagno Visualizza Messaggio
    Mi aiutereste a capire come prendere in considerazione anche gli altri fogli e soprattutto a capire perchè la formula scritta prima non li considera?

    Grazie a chi risponde e a chi propone i quiz che a loro volta fanno nascere domande nuove... :246:

    Ciao
    la ua frmula va benissimo deve solo essere completata per sommare il contenuto della matrice

    =MATR.SOMMA.PRODOTTO(SOMMA.SE(INDIRETTO("data"&{1.2.3}&"!$G$2:$G$5");C2;INDIRETTO("data"&{1.2.3}&"!$H$2:$H$5")))

    La tua formula ti restituiva correttamente una matrice, che però aveva bisogno di essere sommata alla fine

    Comunque visto il tuo buon livello di Excel non so se posso permettermi di suggerirti di Usare molto il Tasto F9 sopratutto alla fine della formula infatti potrai notare che la tua formula ti restituiva questa matrice qui ={50.65.35} che aspettava di essere sommata
    =MATR.SOMMA.PRODOTTO({50.65.35})
    Avrei potuto anteporre il SOMMA() ma avrei dovuto fare CTRL+SHIFT+ENTER (Visto che è una matrice) ma la funzione MATR.SOMMA.PRODOTTO sopporta bene le matrici senza fare CTRL+SHIFT+ENTER.
    Fammi sapere!
    Invia MPPM 

  5. #5

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4024
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Grazie Gerardo,
    si, uso spesso sia F9 che il "valuta formule", specialmente da quando ho iniziato a frequentare i forum ed ho visto che alcune formule MERITANO di essere analizzate...
    Per il fatto della conoscenza di excel, beh, tutto è relativo... Io so quello che già mi è capitato di usare ;)

    P.S.
    nella mia "formula alternativa" volevo evitare di usare le varie funzioni "Matr."...
    Ultima modifica fatta da:cromagno; 09/09/15 alle 01:38

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."
    Invia MPPM 

  6. #6
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204
    Ciao Cromagno,

    riprendo il ragionamento di Gerardo: alla formula esplosiva manca solo il detonatore.

    Puoi evitare l'uso di matr.somma.prodotto usando somma(indice(....;0)).

    Il risultato sarebbe:

    =SOMMA(INDICE(SOMMA.SE(INDIRETTO("data"&RIF.RIGA(1:3)&"!$G$2:$G$5");C2;INDIRETTO("data"&RIF.RIGA(1:3)&"!$H$2:$H$5"));0))

    Cambia poco.

    Saluti
    Ultima modifica fatta da:Canapone; 09/09/15 alle 07:45
    Invia MPPM 

  7. #7

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4024
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Thanks a lot Canapone :222:

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."
    Invia MPPM 

Discussioni Simili

  1. [Risolto] Collegare celle di fogli multipli
    Di Skoalforfun nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 11/11/16, 01:20
  2. estrazione condizionata dati e somma valori per ogni singolo cliente
    Di GioPL nel forum Domande su Excel VBA e MACRO
    Risposte: 4
    Ultimo Messaggio: 19/07/16, 16:26
  3. Conta su più Fogli con un criterio
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 18/09/15, 08:17
  4. Somma con doppio Criterio
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 15
    Ultimo Messaggio: 11/07/15, 23:58
  5. Somma con criterio parziale
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 01/07/15, 09:03

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •