Risultati da 1 a 10 di 10

Discussione: Estrarre valori univoci da elenco



  1. #1
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    51
    Messaggi
    847
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    175

    Estrarre valori univoci da elenco

    Ciao a tutti,
    ho usato questa formula:
    Codice: 
    =INDICE(Lista_RIF;PICCOLO(SE(VAL.NUMERO(CONFRONTA(RIF.RIGA(Lista_RIF)-1;CONFRONTA(Lista_RIF;Lista_RIF;0);0));CONFRONTA(Lista_RIF;Lista_RIF;0);""); RIF.RIGA(A2)))
    ma non ottengo quanto desiderato ossia una lista con valori univoci e possibilmente secondo questa sequenza:
    Lavoratore
    Impiegato
    Preposto
    Dirigente


    PS. La formula dovrebbe darmi solo l'elenco dei valori unici mentre NON saprei come fare e se è possibile, ordinarli secondo la sequenza sopraindicata.

    Grazie per l'aiuto

    Gene
    File Allegati File Allegati

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1596
    Versione Office
    2010 PC
    Likes ricevuti
    849
    Likes dati
    169

    Re: Estrarre valori univoci da elenco

    ciao
    presumo che tu abbia inserito una nuova riga (prima della tabella) senza aggiornare alcuni riferimenti nella formula:

    =INDICE(Lista_RIF;PICCOLO(SE(VAL.NUMERO(CONFRONTA(RIF.RIGA(Lista_RIF)-2;CONFRONTA(Lista_RIF;Lista_RIF;0);0));CONFRONTA(Lista_RIF;Lista_RIF;0);""); RIF.RIGA(A1)))

    si può "blindare" un tantino la formula, con qualche modifica, ma vistoche ti serve un ordinamento particolare, la dovrai cambiare....., al momento non posso continuare


    oppure
    giusto per prenderlo in giro, visto che li estrae in ordine di apparizione, iniziare la lista con la sequenza desiderata
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. #3
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    51
    Messaggi
    847
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    175

    Re: Estrarre valori univoci da elenco

    Ciao Ninai,
    grazie per la correzione.

    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    oppure
    giusto per prenderlo in giro, visto che li estrae in ordine di apparizione, iniziare la lista con la sequenza desiderata
    Purtroppo non posso usare questo escamotage perchè i dati di riferimento sono importati e quindi in "testa" al foglio non posso aggiungere nulla.

    Aspetto a chiederti di mettere [RISOLTO]....sperando nella tua mente vulcanica

    Gene

  4. #4
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1596
    Versione Office
    2010 PC
    Likes ricevuti
    849
    Likes dati
    169

    Re: Estrarre valori univoci da elenco

    ciao
    scusa ma prima di andare a trovare un eventuale formula, vorrei capire meglio lo scopo.
    Se già sai quale è la lista dei valori che desideri:
    Lavoratore
    Impiegato
    Preposto
    Dirigente
    perchè andare ad estrapolarli dalla lista????
    se il problema è che potrebbero non esserci tutti, si può risolvere diversamente
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  5. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    6379
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    1895
    Likes dati
    1207

    Re: Estrarre valori univoci da elenco

    Ciao Gene,
    Come giustamente dice Ninai, che saluto, se sai già la lista che vuoi avere e si tratta di poni nomi perché usare una formula?
    Non capisco a che scopo ti serva quanto chiedi.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. #6
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    57
    Messaggi
    1103
    Versione Office
    Office 2013
    Likes ricevuti
    1112
    Likes dati
    1982

    Re: Estrarre valori univoci da elenco

    Ciao G.Bove e buona domenica a tutti, se ho capito bene, utilizzando una colonna d'appoggio, la "C", all'occorrenza da nascondere, una possibile soluzione potrebbe essere la seguente:

    In C4:
    =SE.ERRORE(INDICE($A$3:$A$94;AGGREGA(15;6;(RIF.RIGA($A$3:$A$94)-RIF.RIGA($A$3)+1)/(FREQUENZA(CONFRONTA($A$3:$A$94;$A$3:$A$94;0);RIF.RIGA($A$3:$A$94)-RIF.RIGA($A$3)+1)>0);RIGHE($C$4:$C4)));"")
    da trascinare giù fino a C7;

    In E4:
    =INDICE($C$4:$C$7;CONFRONTA(SINISTRA(INDICE($A$3:$A$94;AGGREGA(15;6;(RIF.RIGA($A$3:$A$94)-RIF.RIGA($A$3)+1)/(FREQUENZA(CONFRONTA($A$3:$A$94;$A$3:$A$94;0);RIF.RIGA($A$3:$A$94)-RIF.RIGA($A$3)+1)>0);RIGHE($E$4:$E4)));1);{"L"."I"."P"."D"};0))
    da trascinare giù fino a E7.
    Fa sapere se va bene, ciao.

  7. #7
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    57
    Messaggi
    1103
    Versione Office
    Office 2013
    Likes ricevuti
    1112
    Likes dati
    1982

    Re: Estrarre valori univoci da elenco

    Ciao G.Bove, leggera modifica per la formula in E4, nell'eventualità della presenza di errore:

    In E4:
    =SE.ERRORE(INDICE($C$4:$C$7;CONFRONTA(SINISTRA(INDICE($A$3:$A$94;AGGREGA(15;6;(RIF.RIGA($A$3:$A$94)-RIF.RIGA($A$3)+1)/(FREQUENZA(CONFRONTA($A$3:$A$94;$A$3:$A$94;0);RIF.RIGA($A$3:$A$94)-RIF.RIGA($A$3)+1)>0);RIGHE($E$4:$E4)));1);{"L"."I"."P"."D"};0));"")
    da trascinare giù fino a E7.
    Fa sapere se va bene, ciao.

  8. I seguenti utenti hanno dato un "Like"

    ges

  9. #8
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    51
    Messaggi
    847
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    175

    Re: Estrarre valori univoci da elenco

    Ciao a tutti.

    @ Ges e Ninai
    Principalmente era per imparare.
    In ogni caso è diventato un "pezzettino" del file allegato (utilizzo formula in Legenda e "collegamento a tendina" in D5 del foglio "Report").

    @ PKrome
    Grazie. Domani lo testo nel master.



    Buona domenica a tutti

    Gene
    File Allegati File Allegati

  10. #9
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    57
    Messaggi
    1103
    Versione Office
    Office 2013
    Likes ricevuti
    1112
    Likes dati
    1982

    Re: Estrarre valori univoci da elenco

    Ciao G.Bove, radicale modifica della formula, molto versatile per cui copia la seguente:

    In E4:
    =SE.ERRORE(INDICE($A$3:$A$94;INDICE(CONFRONTA({"Lavoratore"."Impiegato"."Preposto"."Dirigente"};$A$3:$A$94;0);RIGHE($A$3:$A3)));"")
    da tirare giù fino ad E7.
    fa sapere se va bene, ciao e buona domenica.

  11. I seguenti 4 utenti hanno dato un "Like" a pkrome59 per questo post:


  12. #10
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    51
    Messaggi
    847
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    175

    Re: Estrarre valori univoci da elenco

    Eccezzzionale veramente

    Grazie e buona domenica.

    Gene

  13. I seguenti utenti hanno dato un "Like"


Discussioni Simili

  1. [Risolto] Generare Colonna con valori univoci da una lista
    Di Domynix nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 05/01/17, 14:01
  2. [Risolto] Conta numero di valori univoci - qui,qui,quo,qua,quo,qua,qui=3
    Di aldomattana nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 09/12/16, 19:17
  3. [Tutorial VBA] Oggetto Dictionary - valori univoci
    Di Rubik72 nel forum Imparando Excel & VBA - Tutorial di Excel-
    Risposte: 14
    Ultimo Messaggio: 10/10/16, 20:52
  4. estrarre valori univoci
    Di BRAZ66 nel forum Domande su Excel in generale
    Risposte: 0
    Ultimo Messaggio: 24/09/16, 20:26
  5. [Risolto] Conteggio valori univoci con una condizione
    Di mattegem nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 30/08/16, 08:49

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •