Risultati da 1 a 8 di 8

Discussione: Quiz - Calcola la media escludendo gli zeri



  1. #1

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    54
    Messaggi
    9969
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2568
    Likes dati
    1546

    Quiz - Calcola la media escludendo gli zeri

    Vorrei una formula in C2 che mi calcoli la media delle vendite escludendo gli zeri

    A
    B
    C
    1
    Venditori
    Vendite
    Media esclusi gli 0
    2
    Pippo
    7
    8
    3
    Pluto
    7
    4
    Paperino
    0
    5
    Paperina
    9
    6
    Topolino
    0
    7
    Minni
    8
    8
    Gastone
    9


    Buon divertimento.
    Invia MPPM 

  2. #2
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    Ciao ges!

    =AGGREGA(16;6;B2:B8/(B2:B8<>0);1/2)

    Saluti.
    Ultima modifica fatta da:Jos; 08/09/15 alle 14:34
    Advanced Excel Techniques: http://excelxor.com/
    Invia MPPM 

  3. #3
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    994
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    395
    Likes dati
    1
    Buongiorno

    =MEDIA(SE(B2:B8<>0;B2:B8)) Premere CTRL+MAIUSC+INVIO

    Saluti
    Window 8.1 Excel 2013/2016
    Invia MPPM 

  4. #4
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1124
    Versione Office
    2010 su Win
    Likes ricevuti
    642
    Likes dati
    224
    Ciao a tutti

    giusto per accorciare un po' la formula:

    =MEDIA(SE(B2:B8;B2:B8))

    sempre da confermare con il control+maiusc+invio

    Anche MEDIA.SE

    =MEDIA.SE(B2:B8;"<>0";B2:B8)

    credo si ricordi bene.
    Invia MPPM 

  5. #5

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    58
    Messaggi
    1206
    Versione Office
    .
    Likes ricevuti
    447
    Likes dati
    0
    Ciao,

    =somma(b2:b8)/conta.se(b2:b8;"<>0")
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)
    Invia MPPM 

  6. #6
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    2141
    Versione Office
    2010 PC
    Likes ricevuti
    1180
    Likes dati
    238
    ciao
    complimenti per l'originale soluzione di XOR LX

    si può anche:
    =MEDIA.SE(B2:B8;"<>"&0;B2:B8)

    o

    =MATR.SOMMA.PRODOTTO((B2:B8<>0)*B2:B8)/MATR.SOMMA.PRODOTTO(--(B2:B8<>0))
    Invia MPPM 

  7. #7

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    54
    Messaggi
    9969
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2568
    Likes dati
    1546
    Woww ... quante soluzioni!!! :255:
    Complimenti ragazzi.

    Citazione Originariamente Scritto da XOR LX Visualizza Messaggio
    Ciao ges!

    =AGGREGA(16;6;B2:B8/(B2:B8<>0);1/2)

    Saluti.
    AGGREGA non ci avevo pensato, ottima XOR LX!

    Citazione Originariamente Scritto da Pitagora Visualizza Messaggio
    Buongiorno

    =MEDIA(SE(B2:B8<>0;B2:B8)) Premere CTRL+MAIUSC+INVIO

    Saluti
    Questa era la mia soluzione, bruciata! Ottimo Pitagora.

    Citazione Originariamente Scritto da Canapone Visualizza Messaggio
    Ciao a tutti

    giusto per accorciare un po' la formula:

    =MEDIA(SE(B2:B8;B2:B8))

    sempre da confermare con il control+maiusc+invio

    Anche MEDIA.SE

    =MEDIA.SE(B2:B8;"<>0";B2:B8)

    credo si ricordi bene.
    Soluzioni impeccabili! Ottimo!

    Citazione Originariamente Scritto da scossa Visualizza Messaggio
    Ciao,

    =somma(b2:b8)/conta.se(b2:b8;"<>0")
    Soluzione originale ed eccellente!
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    ciao
    complimenti per l'originale soluzione di XOR LX

    si può anche:
    =MEDIA.SE(B2:B8;"<>"&0;B2:B8)

    o

    =MATR.SOMMA.PRODOTTO((B2:B8<>0)*B2:B8)/MATR.SOMMA.PRODOTTO(--(B2:B8<>0))
    Ottime anche queste!

    Che dire, ancora complimenti a tutti!
    Alla prossima.:299:
    Invia MPPM 

  8. #8
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5386
    Versione Office
    office 365/2016
    Likes ricevuti
    1272
    Likes dati
    1339
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Woww ... quante soluzioni!!! :255:
    Complimenti ragazzi.
    Ciao ges da qualche giorno ho inserito un nuovo tool disponibile a tutti gli utenti, questo tool serve a far si che se la tua domanda è stata risolta, segna questa discussione come [RISOLTO]
    Nella barra dei menu, situata all’inizio di questa discussione, troverai il menu “Strumenti Discussione” quindi scegliere “Segna questo Thread come risolto”
    Grazie Ges e ti aspettiamo alla prossima domanda
    Ultima modifica fatta da:Gerardo Zuccalà; 09/09/15 alle 00:02
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein
    Invia MPPM 

Discussioni Simili

  1. [Risolto] Come posso eliminare gli zeri in una matrice
    Di Pietro733 nel forum Domande su Excel in generale
    Risposte: 20
    Ultimo Messaggio: 23/11/16, 15:38
  2. Zeri dopo la virgola
    Di nicocaporale nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 07/03/16, 17:01
  3. nascondere gli zeri dal risultato di una formula
    Di Raffaele Esposito nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 15/02/16, 17:35
  4. calcola numero celle
    Di BRAZ66 nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 21/07/15, 11:23
  5. [Risolto] Tabella calcola tempi per corridori.
    Di GioGio nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 14/06/15, 07:49

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •