Risultati da 1 a 3 di 3

Discussione: Nome Foglio come variabile in una cella



  1. #1
    L'avatar di Edoardo91
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Milano
    Messaggi
    2
    Versione Office
    2013
    Likes ricevuti
    1

    Nome Foglio come variabile in una cella

    Buonasera a tutti!
    E' il mio primo post in questo forum molto interessante, da cui in passato ho trovato spunto.
    Non so se esiste già una discussione simile. Se così fosse, mi scuso per la ripetizione.




    Vi riporto la bozza del mio lavoro.
    Come potete vedere, all'interno della cella E4 ho un SOMMA.PIU'.SE(...) con varie condizioni.
    In realtà tutte le celle vuote (- €) presentano una funzione simile.
    La discriminante è il NOME DEL FOGLIO.
    In particolare questa formula si riferisce ogni volta ad un paese diverso (nell'esempio GERMANIA).




    Attualmente, ho selezionato manualmente il foglio "GERMANIA".
    Come posso evitare questo scomodo passaggio, facendo invece riferimento alla cella E1, in cui è inserito il testo "GERMANIA"?




    In pratica, quello che vorrei ottenere è:
    =SOMMA.PIÙ.SE(E1$F:$F;E1$I:$I;A1;E1$B:$B;$B4)




    ...ma ovviamente la formula qui riportata non è corretta.
    So che c'entra la funzione INDIRIZZO.
    Ci ho provato, ma non sono riuscito a trovare una soluzione!




    Potete gentilmente aiutarmi?
    Grazie mille!
    Edoardo
    Ultima modifica fatta da:Canapone; 05/07/17 alle 13:20 Motivo: Risolto

  2. #2
    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    5337
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    1714
    Likes dati
    1093

    Re: Nome Foglio come variabile in una cella

    Ciao,
    più che INDIRIZZO centra la funzione INDIRETTO.

    Se per esempio hai un intervallo da contare nel foglio "GERMANIA" in A1:A10, quando la lettera a fianco corrisponde ad "a", allora puoi usare questa formula:

    =MATR.SOMMA.PRODOTTO((INDIRETTO("'"&E1&"'!A1:A10"))*(INDIRETTO("'"&E1&"'!B1:B10")="a"))

    Ti allego il file di esempio ... provaci tu col tuo file.

    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. I seguenti 2 utenti hanno dato un "Like" a ges per questo post:


  4. #3
    L'avatar di Edoardo91
    Clicca e Apri
    Data Registrazione
    Sep 2016
    Località
    Milano
    Messaggi
    2
    Versione Office
    2013
    Likes ricevuti
    1

    Re: Nome Foglio come variabile in una cella

    Grazie ges,
    Mi hai risolto un bel "problema"!


    Ho comunque preferito mantenere la formulazione originale (SOMMA.PIU'.SE()) in questo modo - magari a qualcuno potrà servire in futuro:

    Codice: 
    =SOMMA.PIU'.SE(INDIRETTO("'"&C$1&"'!F:F");INDIRETTO("'"&C$1&"'!I:I");C$4;INDIRETTO("'"&C$1&"'!B:B");$B5)



    Grazie ancora davvero!
    Edoardo
    Ultima modifica fatta da:Canapone; 05/07/17 alle 13:21

  5. I seguenti utenti hanno dato un "Like"


Discussioni Simili

  1. Riferimento a celle di altro foglio a prescindere dal nome del foglio
    Di Matteo2017 nel forum Domande su Excel in generale
    Risposte: 20
    Ultimo Messaggio: 18/02/17, 19:01
  2. Macro che salva foglio in pdf prendendo il nome da una cella
    Di Fagor nel forum Domande su Excel VBA e MACRO
    Risposte: 13
    Ultimo Messaggio: 15/02/17, 06:40
  3. Risposte: 19
    Ultimo Messaggio: 21/11/16, 14:32
  4. Macro per lanciare .bat con nome variabile inserito in una cella
    Di Gambry nel forum Domande su Excel VBA e MACRO
    Risposte: 10
    Ultimo Messaggio: 15/06/16, 20:06
  5. Macro per aprire un file con nome sempre variabile
    Di kellington90 nel forum Domande su Excel VBA e MACRO
    Risposte: 5
    Ultimo Messaggio: 21/05/16, 11:30

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •