Risultati da 1 a 5 di 5

Discussione: Ricercare dei dati con tre condizioni e inserirli in una tabella



  1. #1
    L'avatar di raffaelealta
    Clicca e Apri
    Data Registrazione
    Oct 2016
    LocalitÓ
    bari
    EtÓ
    53
    Messaggi
    66
    Versione Office
    excel 2010
    Likes ricevuti
    1

    Ricercare dei dati con tre condizioni e inserirli in una tabella

    Buongiorno a tutti,
    ho la necessitÓ di una formula che, dato un periodo di data (dal____ al____) e data la condizione "VISITE MEDICHE " mi inserisce in una tabella tutte le fatture emesse in quel periodo relative alla prestazione delle visite mediche.
    Allego un file per meglio comprendere il problema.
    Grazie per la disponibilitÓ.
    Raffaele Altamura
    File Allegati File Allegati

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Barcellona P.G.
    EtÓ
    54
    Messaggi
    1567
    Versione Office
    2010 PC
    Likes ricevuti
    823
    Likes dati
    158

    Re: Ricercare dei dati con tre condizioni e inserirli in una tabella

    ciao
    in A9:
    =SE.ERRORE(INDICE(FATTURE!A$2:A$437;AGGREGA(15;6;RIF.RIGA(FATTURE!$A$2:$A$437)-RIF.RIGA(FATTURE!$A$2)+1/((FATTURE!$B$2:$B$437>=$A$3)*(FATTURE!$B$2:$B$437<=$B$3)*(FATTURE!$D$2:$D$437='RIEPILOGO MENSILE'!$C$1));RIGHE($A$9:A9)));"")
    e trascini , adattando il primo range in base alla colonna che vuoi estrarre

    https://www.dropbox.com/s/bfkeyk9crr...ORUM.xlsm?dl=0
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed Ŕ un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. #3
    L'avatar di raffaelealta
    Clicca e Apri
    Data Registrazione
    Oct 2016
    LocalitÓ
    bari
    EtÓ
    53
    Messaggi
    66
    Versione Office
    excel 2010
    Likes ricevuti
    1

    Re: Ricercare dei dati con tre condizioni e inserirli in una tabella

    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    ciao
    in A9:
    =SE.ERRORE(INDICE(FATTURE!A$2:A$437;AGGREGA(15;6;RIF.RIGA(FATTURE!$A$2:$A$437)-RIF.RIGA(FATTURE!$A$2)+1/((FATTURE!$B$2:$B$437>=$A$3)*(FATTURE!$B$2:$B$437<=$B$3)*(FATTURE!$D$2:$D$437='RIEPILOGO MENSILE'!$C$1));RIGHE($A$9:A9)));"")
    e trascini , adattando il primo range in base alla colonna che vuoi estrarre

    https://www.dropbox.com/s/bfkeyk9crr...ORUM.xlsm?dl=0
    GRAZIE INFINITAMENTE
    ti ringrazio di cuore, ho risolto un'annoso problema.
    Il quesito Ŕ risolto qualcuno sÓ come si fÓ a scrivere nel forum?
    Grazie.
    Buona giornata

  4. #4

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Sardegna
    EtÓ
    37
    Messaggi
    3413
    Versione Office
    2013
    Likes ricevuti
    1021
    Likes dati
    816

    Re: Ricercare dei dati con tre condizioni e inserirli in una tabella

    Citazione Originariamente Scritto da raffaelealta Visualizza Messaggio
    Il quesito Ŕ risolto qualcuno sÓ come si fÓ a scrivere nel forum?
    Ciao,
    Il [RISOLTO] viene messo dall'amministratore o da un moderatore (l'ho appena messo).
    Basta che il richiedente scriva (o faccia capire) nella discussione di aver risolto... come hai giustamente fatto

    Ciao
    Tore

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno pu˛ immaginare."

  5. #5

    L'avatar di alfrimpa
    Clicca e Apri
    Data Registrazione
    Dec 2015
    LocalitÓ
    Napoli
    EtÓ
    63
    Messaggi
    4896
    Versione Office
    2007 - 2013
    Likes ricevuti
    537
    Likes dati
    93

    Re: Ricercare dei dati con tre condizioni e inserirli in una tabella

    Ciao a tutti

    Giusto per partecipare e visto che l'avevo scritta propongo una mia soluzione in VBA

    Codice: 
    Sub elenca()
    Dim dal As Date
    Dim al As Date
    Dim rng As Range
    Dim cel As Range
    Dim ur As Long
    dal = Worksheets("RIEPILOGO MENSILE").Range("A3").Value
    al = Worksheets("RIEPILOGO MENSILE").Range("B3").Value
    Set rng = Worksheets("FATTURE").Range("B2:B500")
    Worksheets("RIEPILOGO MENSILE").Range("a9:d1000").ClearContents
    For Each cel In rng
    ur = Worksheets("RIEPILOGO MENSILE").Cells(Rows.Count, 1).End(xlUp).Row
        If cel.Value >= dal And cel.Value <= al And cel.Offset(0, 2).Value = "VISITE MEDICHE " Then
            Worksheets("RIEPILOGO MENSILE").Cells(ur + 1, 1) = cel.Offset(0, -1).Value
            Worksheets("RIEPILOGO MENSILE").Cells(ur + 1, 2) = cel.Value
            Worksheets("RIEPILOGO MENSILE").Cells(ur + 1, 3) = cel.Offset(0, 1).Value
            Worksheets("RIEPILOGO MENSILE").Cells(ur + 1, 4) = cel.Offset(0, 3).Value
        End If
    Next cel
    End Sub
    La macro Ŕ associata ad un pulsante sul foglio RIEPILOGO MENSILE.

    Allego il file
    File Allegati File Allegati
    Alfredo

    "Non esistono cose facili o difficili; esistono cose che si sanno e cose che non si sanno"

    "Solo due cose sono infinite: l'universo e la stupiditÓ umana; riguardo l'universo ho ancora dei dubbi" (Albert Einstein)

Discussioni Simili

  1. Estrarre dati e inserirli in un foglio modello
    Di livio1982 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 24/02/17, 17:09
  2. [Risolto] Creare una tabella estraendo i dati in base a determinate condizioni
    Di MaxpoweR nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 30/01/17, 22:15
  3. [Risolto] prendere dati da un'altro foglio e inserirli in un form
    Di John nel forum Domande su Excel VBA e MACRO
    Risposte: 11
    Ultimo Messaggio: 28/09/16, 10:47
  4. Unica Tabella dati con pi¨ condizioni da men¨ a tendina
    Di Emanuele nel forum Domande su Excel in generale
    Risposte: 24
    Ultimo Messaggio: 11/06/16, 23:38
  5. quiz #9 Analisi dei dati 3 condizioni in una tabella incrociata
    Di Gerardo ZuccalÓ nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 23/06/15, 23:26

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •