Risultati da 1 a 4 di 4

Discussione: matr.somma.prodotto ma spostato di n posizioni



  1. #1
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    711
    Versione Office
    2010 64 bit
    Likes ricevuti
    103
    Likes dati
    54

    matr.somma.prodotto ma spostato di n posizioni

    Ciao a tutti,
    ho una semplice tabella (haimè non costruita proprio bene ma tantè) nella quale dovrei ricavarmi un valore.
    Ho pensato al solito matr.somma.prodotto ma c'è un ma.
    Non dovrei acquisirmi il valore che incrocia la varie condizioni, ma il valore spostato di 5 posizioni.
    Vi allego il file.
    Grazie anche per delle altre soluzioni perchè forse quella scelta da me penso non sia la funzione più azzeccata.
    ciao
    ale
    File Allegati File Allegati
    Ultima modifica fatta da:Gerardo Zuccalà; 05/10/16 alle 23:29 Motivo: Messo risolto

  2. #2
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    711
    Versione Office
    2010 64 bit
    Likes ricevuti
    103
    Likes dati
    54

    Re: matr.somma.prodotto ma spostato di n posizioni

    temo l'alternativa sia modificare la tabella...inserendo le date in tutte le colonne e diversificando la seconda intestazione così da rendere campi univoci.
    ciao
    ale

  3. #3
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4680
    Versione Office
    Office 365
    Likes ricevuti
    1039
    Likes dati
    1011

    Re: matr.somma.prodotto ma spostato di n posizioni

    Ciao Alessandro
    non mi è molto chiaro

    ma io vedo che hai tante tabelle incrociate, e devi ricercare tra due condizioni
    la prima condizione è la lettera che si trova sulle intestazione di righe, ma manca la seconda condizione che sono le intestazioni di colonna
    ma la data che ruolo ha? perchè hai messo la data come seconda condizione?

    Prova questa
    in B11 metti questa formula

    =SOMMA(SCARTO(B2;CONFRONTA(A11;$A$3:$A$7;0);5);SOMMA(SCARTO(B2;CONFRONTA(A11;$A$3:$A$7;0);5+6)))

    Fai sapere

  4. #4
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    711
    Versione Office
    2010 64 bit
    Likes ricevuti
    103
    Likes dati
    54

    Re: matr.somma.prodotto ma spostato di n posizioni

    Ciao Gerardo,
    grazie per il tentativo.
    Stavo scrivendo per chiudere il post: non perchè ho risolto ma perchè ho preso un'altra strada per acquisirmi i dati e va bene così.
    Nulla toglie a chi volesse cmq cimentarsi.
    Riguardo al tuo dubbio considera che quella è una parte di una tabella composta da tutti e 12 i mesi. Ogni mese è composto da 6 col. Il mio tentativo è avere la somma con la condizione della lettera e la condizione temporale (<= di una certa data).
    Per dire con questa semplice formula
    =MATR.SOMMA.PRODOTTO($B$3:$S$7*($A$3:$A$7=A11)*(($B$1:$S$1=B10)))
    avrei avuto come risultato 16. Ma a me, oltre a voler il risultato spostato di 5 posizioni (26) volevo anche che la discriminante data fosse <= e non solo =.
    Da qui il doppio problema: la mancanza di univocità delle intestazioni e la mancanza delle date (o meglio la presenza della data nella sola prima colonna del periodo scelto).
    In ogni modo lascio aperto il posto solo per chi ci vuole giocare...x me è da considerare risolto.
    Grazie ancora.
    ciao
    ale

Discussioni Simili

  1. MATR.SOMMA.Prodotto... un pò di teoria
    Di Beppe nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 29/05/16, 21:02
  2. Matr.somma.prodotto
    Di Khan nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 29/03/16, 12:33
  3. =matr.somma.prodotto()
    Di marigenny nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 11/11/15, 11:59
  4. matr.somma.prodotto
    Di Alessandro nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 19/10/15, 16:52
  5. MATR.SOMMA.PRODOTTO per contare o sommare
    Di Baloon_50 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 22/08/15, 21:12

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •