Risultati da 1 a 3 di 3

Discussione: Resoconto automatico intervalli temporali



  1. #1
    L'avatar di alessioje
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    roma
    Età
    36
    Messaggi
    23
    Versione Office
    Excel 2007,
    Mi Piace ricevuti
    0
    Mi Piace dati
    0

    Resoconto automatico intervalli temporali

    Buonasera a tutti,
    ho un file resoconto annuale delle presenze in cui segno con il valore 1 la presenza e 0 l'asenza.
    A fine anno mi ritrovo a dover segnalare gli intervalli delle presenze es. dal 01/01 al 03/01 ecc ecc..
    mi chiedevo se fosse possibile fare ciò tramite formula..
    allego un file come esempio cosi sicuramente la cosa è molto piu chiara:) le date che voglio trovare sono quelle in giallo!
    grazie a chiunque proverà :)
    File Allegati File Allegati

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    54
    Messaggi
    1380
    Versione Office
    2010 PC
    Mi Piace ricevuti
    695
    Mi Piace dati
    142

    Re: Resoconto automatico intervalli temporali

    ciao
    per non incasinare troppo le formule, ti chiedo qualche modifica al foglio:
    - inserire due colonne vuote, una all'inizio ed una alla fine del calendario (prima della D e dopo CV), da nascondere
    - i giorni dei mesi della riga 12, metterli come data e dare il formato personalizzato "gg" es. 27/05/2016 ed incrementare di 1 via via le altre.

    le formula da usare:
    in CY14:
    =SE.ERRORE(INDICE($E$12:$CY$12;AGGREGA(15;6;(RIF.COLONNA($E14:$CX14)-RIF.COLONNA($E14)+1)/(($D14:$CW14=0)*($E14:$CX14=1));INT((COLONNE($CZ$17:CZ17)+1)/2)));"")
    in CZ14:
    =SE.ERRORE(INDICE($E$12:$CW$12;AGGREGA(15;6;(RIF.COLONNA($E14:$CW14)-RIF.COLONNA($E14)+1)/(($E14:$CW14=1)*($F14:$CX14=0));INT((COLONNE($CZ$17:CZ17)+1)/2)));"")

    siccome ho notato che hai excel 2007 e non riconosce AGGREGA, le due precedenti diventano rispettivamente:
    =SE.ERRORE(INDICE($E$12:$CY$12;PICCOLO(SE($D14:$CW14=0;SE($E14:$CX14=1;RIF.COLONNA($E14:$CX14)-RIF.COLONNA($E14)+1));INT((COLONNE($CZ$14:CZ14)+1)/2)));"")

    ed

    =SE.ERRORE(INDICE($E$12:$CW$12;PICCOLO(SE($E14:$CW14=1;SE($F14:$CX14=0;RIF.COLONNA($E14:$CW14)-RIF.COLONNA($E14)+1));INT((COLONNE($CZ$17:CZ17)+1)/2)));"")

    in questo caso si devono confermare con CTRL+MAIUSCOLO+INVIO

    allego mio file di lavoro:
    https://www.dropbox.com/s/yd5s220jow...inai.xlsx?dl=0
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. I seguenti utenti hanno dato un "Mi Piace"


  4. #3
    L'avatar di alessioje
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    roma
    Età
    36
    Messaggi
    23
    Versione Office
    Excel 2007,
    Mi Piace ricevuti
    0
    Mi Piace dati
    0

    Re: Resoconto automatico intervalli temporali

    grazie mille! funziona benissimo senza problemi senza nemmeno errori o altro in caso di valori pari a zero! complimenti per la tempestività:) alla prossima

Discussioni Simili

  1. [Risolto] calcolare un subtotale con somma se ma per date temporali differenti
    Di ortofrutta_palladino nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 18/11/16, 08:10
  2. Somma valori con criteri temporali
    Di damiaà nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 28/06/16, 10:13
  3. Resoconto Ordinato/Consegnato/Inviato
    Di Barchetta nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 13/05/16, 00:15
  4. intervalli dinamici e aggiornamento in automatico di una tavola dati
    Di Enrico C. nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 14/03/16, 12:13
  5. Caselle combinate temporali
    Di Beppe92 nel forum Domande su Excel in generale
    Risposte: 17
    Ultimo Messaggio: 15/02/16, 01:19

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •