Risultati da 1 a 12 di 12

Discussione: Data superata = testo



  1. #1
    L'avatar di nicocaporale
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Omignano Scalo (SA)
    Età
    42
    Messaggi
    90
    Versione Office
    2007 Win
    Mi Piace ricevuti
    0
    Mi Piace dati
    31

    Data superata = testo

    Salve a tutti, avrei bisogno di una formula che mi restituisca un testo quando la data a cui si riferisce è passata.
    Esempio oggi è il giorno 11-10-2016
    quando nella cella A1 inserisco una data già passata ( 01-10-2016 ) nella cella A2 mi deve riportare un testo.
    Qualcuno può aiutarmi?

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    54
    Messaggi
    1380
    Versione Office
    2010 PC
    Mi Piace ricevuti
    695
    Mi Piace dati
    142

    Re: Data superata = testo

    ciao
    prova:
    =SE(E(A1<>"";A1<OGGI());"testo";"")
    se vuoi che il testo esca anche quando la cella è vuota, togli una condizione:
    =SE(A1<OGGI();"testo";"")
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. I seguenti 2 utenti hanno dato un MI Piace a ninai per questo post:


  4. #3
    L'avatar di nicocaporale
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Omignano Scalo (SA)
    Età
    42
    Messaggi
    90
    Versione Office
    2007 Win
    Mi Piace ricevuti
    0
    Mi Piace dati
    31

    Re: Data superata = testo

    Grazie ninai funziona benissimo, era quello che cercavo

  5. #4
    L'avatar di nicocaporale
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Omignano Scalo (SA)
    Età
    42
    Messaggi
    90
    Versione Office
    2007 Win
    Mi Piace ricevuti
    0
    Mi Piace dati
    31

    Re: Data superata = testo

    Ninai ti volevo chiedere, se la data ancora non è passata, mi può riportare il risultato di un'altra cella?

  6. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    52
    Messaggi
    3650
    Versione Office
    2011/2016MAC
    Mi Piace ricevuti
    1087
    Mi Piace dati
    638

    Re: Data superata = testo

    Ciao a tutti,
    se vuoi la soluzione con le formule devi scrivere in quell'altra cella questa formula:

    =SE(E(A1<>"";A1>OGGI());"testo";"")
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  7. I seguenti 2 utenti hanno dato un MI Piace a ges per questo post:


  8. #6
    L'avatar di nicocaporale
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Omignano Scalo (SA)
    Età
    42
    Messaggi
    90
    Versione Office
    2007 Win
    Mi Piace ricevuti
    0
    Mi Piace dati
    31

    Re: Data superata = testo

    Nel mio caso ho la necessità che quando non c'è una data mi deve riportare il risultato numerico di un'altra.
    Esempio:
    se in A1 la data è passata la cella C1 deve riportare un testo.
    se in A1 la data ancora non compare, mi deve riportare il dato numerico della cella B1

  9. #7
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    54
    Messaggi
    1380
    Versione Office
    2010 PC
    Mi Piace ricevuti
    695
    Mi Piace dati
    142

    Re: Data superata = testo

    ciao ges
    io ho capito che:
    =SE(E(A1<>"";A1<OGGI());"testo";B1)


    nico, un consiglio, sforzati di capire la logica, leggi la guida in linea delle funzioni, fai delle prove....., lo dico per te, per non essere dipendente ed imparare
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  10. I seguenti utenti hanno dato un "Mi Piace"


  11. #8
    L'avatar di nicocaporale
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Omignano Scalo (SA)
    Età
    42
    Messaggi
    90
    Versione Office
    2007 Win
    Mi Piace ricevuti
    0
    Mi Piace dati
    31

    Re: Data superata = testo

    Ho provato questa formula e va bene fino a quando nella cella B1 ci sono dei numeri, mentre quando questa cella è vuota mi riporta 0, e questo vorrei evitarlo

  12. #9
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    54
    Messaggi
    1380
    Versione Office
    2010 PC
    Mi Piace ricevuti
    695
    Mi Piace dati
    142

    Re: Data superata = testo

    vi sono tanti modi per nascondere gli zeri, uno potrebbe essere:
    =SE(E(A1<>"";A1<OGGI());"testo";B1&"")
    poi esiste: la formattazione condizionale, formati personalizzati, opzioni di excel, altre formule ecc.
    in base al contesto generale ed all'uso dei dati , si sceglie quale modo è più idoneo
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  13. I seguenti utenti hanno dato un "Mi Piace"


  14. #10
    L'avatar di nicocaporale
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Omignano Scalo (SA)
    Età
    42
    Messaggi
    90
    Versione Office
    2007 Win
    Mi Piace ricevuti
    0
    Mi Piace dati
    31

    Re: Data superata = testo

    Questo è il mio problema

    Celle
    L M N
    13 23-9-16 Finito
    14 09-10-16 Finito
    15 15

    Quando nella cella M1 (23-09-16) la data è superata, deve darmi Finito nella cella L1
    Quando nella cella M3 ( ) la data ancora non è presente deve riportarmi il dato della cella L3 (15)

  15. #11
    L'avatar di nicocaporale
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Omignano Scalo (SA)
    Età
    42
    Messaggi
    90
    Versione Office
    2007 Win
    Mi Piace ricevuti
    0
    Mi Piace dati
    31

    Re: Data superata = testo

    Scusate la disposizione ma sono in colonna i dati

  16. #12

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    52
    Messaggi
    3650
    Versione Office
    2011/2016MAC
    Mi Piace ricevuti
    1087
    Mi Piace dati
    638

    Re: Data superata = testo

    Da quel che ho capito ti servirebbe questa formula in L1 trascinandola in basso:

    =SE(NON(VAL.NUMERO(M2));M2;SE(M2<OGGI();"Finito"))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  17. I seguenti 2 utenti hanno dato un MI Piace a ges per questo post:


Discussioni Simili

  1. formula somma più se, con condizioni di testo o data
    Di -Matteo- nel forum Domande su Excel in generale
    Risposte: 31
    Ultimo Messaggio: 28/11/16, 20:33
  2. [Risolto] COnvertire Testo contenente Data in Inglese in Data in Italiano
    Di cnbgpp69d nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 06/11/16, 21:55
  3. Inserire Testo con Data
    Di ProgrammD69 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 13/06/16, 08:55
  4. Estrazione di una data da stringa di testo
    Di Allocco nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 10/04/16, 16:03
  5. Convertire una data in testo (non valore)
    Di Dimpy nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 14/03/16, 12:44

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •